Microsoft Excel

Herbers Excel/VBA-Archiv

ZÄHLENWENN innerhalb Datumszeitraum

Betrifft: ZÄHLENWENN innerhalb Datumszeitraum von: Bernd
Geschrieben am: 10.10.2020 17:50:22

Hallo,

ich habe eine Problem mit einer ZÄHLENWENN-Formel innerhalb eines Datumzeitraums.

https://www.herber.de/bbs/user/140785.xlsx

In unserer Datei befinden sich im Blatt Daten die von den Sachbearbeitern eingetragenen daten, also das Datum, das Gerät und der Kunde. Im Original natürlich viel mehr als hier im Beispiel.

Zu Auswertungszwecken wird nun im Blatt Eingabe der Zeitraum, das Gerät und der Kunde vorgegeben.

Im Feld Anzahl (B8) soll nun die Anzahl der angegebenen Geräte stehen, die der bestimmte Kunde im angegebenen Zeitraum erhalten hat.

Mir scheint das mit ZÄHLENWENN lösbar...aber wie bekomme ich den Datumsbereich da rein.

Jede Hilfe = Arbeitserleichterung <:-)>
bernd

Betrifft: AW: ZÄHLENWENN innerhalb Datumszeitraum
von: Hajo_Zi
Geschrieben am: 10.10.2020 17:55:21

Hallo Bernd,


eingabe
 AB
8Anzahl0

verwendete Formeln
Zelle Formel Bereich N/A
B8=SUMMENPRODUKT((daten!A:A>=B3)*(daten!A:A<=B4)*(daten!B:B=B5)*(daten!C:C=B6))  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



GrußformelHomepage

Betrifft: AW: mit ZÄHLENWENNS() ...
von: neopa C
Geschrieben am: 10.10.2020 17:58:15

Hallo Bernd,

... so: =ZÄHLENWENNS(daten!B:B;B5;daten!C:C;B6;daten!A:A;">="&B3;daten!A:A;"<="&B4)

Gruß Werner
.. , - ...

Betrifft: AW: mit ZÄHLENWENNS() ...
von: Bernd
Geschrieben am: 10.10.2020 18:18:16

Hallo Hajo,
hallo Werner,

vielen Dank für Eure Hilfe.
Ich bin ehrlich: wäre ich nicht drauf gekommen.

Ihr habt ja zwei unterschiedliche Ansätze, einmal SUMMENPRODUKT und einmal ZÄHLENWENNS.
Beides funktioniert ja...aber hat eine der Formeln einen Vorteil gegenüber der anderen?

Betrifft: AW: Auswertungen über gesamten Zeilenbereich ...
von: neopa C
Geschrieben am: 10.10.2020 19:06:37

Hallo Bernd,

... bzw. schon bei einer größeren Menge an auszuwertenden Datensätze, dürfte ZÄHLENWENNS() wesentlich performanter sein als eine analoge SUMMENPRODUKT()-Formel.

Gruß Werner
.. , - ...

Betrifft: AW: Auswertungen über gesamten Zeilenbereich ...
von: Bernd
Geschrieben am: 10.10.2020 19:32:31

Danke für die Rückmeldung,
Dann werde ich mal im Hinblick auf die Anzahl der Daten besser die ZÄHLENWENNS-Formel verwenden.

Bernd