Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Monate zählen und Jahren zuweisen

Monate zählen und Jahren zuweisen
08.11.2012 12:53:46
e-o
Hallo miteinander,
erneut habe ich mit einem Problem zu kämpfen, bei dem ich irgendwie feststecke:
Ich habe ein Anfangs- und ein Enddatum, nun möchte ich die Monate (angebrochende zählen voll) dazwischen zählen. Das ist auch recht simpel zu bewerkstelligen.
z.B. 25.03.2012 bis 01.08.2012 = 6 Monate
Aber ich würde gerne die Monate in Abhängigkeit der Jahre zählen.
Beispiel:
01.08.2012 bis 12.05.2013 = 5 Monate in 2012 und 5 Monate in 2013
Daneben soll eine 0 ausgegeben werden, wenn ein jahr gar nicht mehr betroffen ist.
z.B.
02.05.2013 - 07.09.2013 = 0 Monate in 2012 und 5 Monate in 2013
Ich habe schon mit der JAHR und MONAT funktion herumprobiert, aber das lässt sich irgendwie nicht bewerkstelligen.Ich habe versucht das ganze in eine WENN-Abfrage zu packen.
Könnt ihr mir helfen?

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Monate zählen und Jahren zuweisen
08.11.2012 13:21:50
Wilfried
Hallo!
Meinst du es so?
Tabelle1

 ABCDEF
1AnfangEnde2011201220132014
201.06.201130.09.20137129 
301.04.201131.05.20112   
401.03.201231.08.2013 108 
501.07.201131.10.20146121210
6     Format 0;;

Formeln der Tabelle
ZelleFormel
C2=ABRUNDEN(SUMMENPRODUKT((JAHR(ZEILE(INDIREKT($A2&":"&$B2)))=C$1)*1)/30;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Wilfried

Anzeige
AW: Monate zählen und Jahren zuweisen
08.11.2012 13:50:57
e-o
Hallo Wilfried,
Danke, genau das brauche ich.
Habe jedoch festgestellt, dass es nicht immer funktioniert.
z.B. bei
23.02.2012 bis 04.05.2012 oder
05.12.2011 bis 15.06.2012
Da wird beim ersteren statt 4 Monate (Feb - Mai) lediglich 2 angegeben
bei zweiterem für 2011: 0 und 2012: 5
werden nicht korrekte Werte ausgegeben.
Woran kann das liegen?
Viele Grüße
Andy

AW: Monate zählen und Jahren zuweisen
08.11.2012 15:39:00
Wilfried
Hallo!
Passt es jetzt besser!
Tabelle1

 ABCDEF
3AnfangEnde2011201220132014
401.06.201130.09.20137129 
523.02.201204.05.2012 3  
601.03.201231.08.2013 108 
701.07.201131.10.20146121210
8      
9  Format 0;;   

Formeln der Tabelle
ZelleFormel
C4{=SUMME(ISTZAHL(VERGLEICH(DATUM(C$3;ZEILE($1:$12); 1); ZEILE(INDIREKT($A4&":"&$B4)); 0))*1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Wilfried

Anzeige
AW: Monate zählen und Jahren zuweisen
08.11.2012 15:57:36
e-o
Hallo Wilfried,
teilweise... :-)
Bei deinem zweiten Beispiel (23.02.12 - 04.05.12) errechnen sich nur 3 Monate statt 4?
Warum Excel hier Daten unterschiedlich behandelt ist mir ein Rätsel.

AW: Monate zählen und Jahren zuweisen
08.11.2012 16:56:04
robert
Hi,
so vielleicht ?
Gruß
robert
Tabelle2
 ABCDE
3AE201120122013
412.06.201116.09.20137129

verwendete Formeln
Zelle Formel Bereich
C4 =DATEDIF($A4;MIN(DATUM(JAHR($A4);12;31);$B4);"M")+1 
D4 =DATEDIF(DATUM(D3;1;1);MIN(DATUM($D3;12;31);$B4);"M")+1 
E4 =DATEDIF(DATUM(E3;1;1);MIN(DATUM(E3;12;31);$B4);"M")+1 

Tabellendarstellung in Foren Version 5.47


Anzeige
AW: Monate zählen und Jahren zuweisen
09.11.2012 09:32:46
Wilfried
Hallo!
Wie kommst du auf 4 Monate?
Tabelle1

 ABC
123.02.201204.05.20122 Monate 11 Tage

Formeln der Tabelle
ZelleFormel
C1=WENN(DATEDIF(A1;B1+1;"m")=0;"";DATEDIF(A1;B1+1;"m")&" Monat"&WENN(DATEDIF(A1;B1+1;"m")<>1;"e ";" "))&WENN(TAG(B1+1)-TAG(A1)+(TAG(A1)>TAG(B1+1))*TAG(DATUM(JAHR(A1); MONAT(A1)+1;))=0;"";TAG(B1+1)-TAG(A1)+(TAG(A1)>TAG(B1+1))*TAG(DATUM(JAHR(A1); MONAT(A1)+1;))&" Tag"&WENN(TAG(B1)-TAG(A1)+1+(TAG(A1)>TAG(B1))*TAG(DATUM(JAHR(A1); MONAT(A1)+1;))<>1;"e";""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Wilfried

Anzeige
AW: Monate zählen und Jahren zuweisen
09.11.2012 18:25:35
e-o
Es sollen alle betroffenen/angebrochenen Monate gezählt werden.
das wären Feb, Mär, Apr, Mai = 4 Monate
Viele Grüße
Andy

AW: Monate zählen und Jahren zuweisen
09.11.2012 18:28:20
Hajo_Zi
Hallo andy,
=Monat(b1)-Monat(a1)+1

AW: Monate zählen und Jahren zuweisen
09.11.2012 18:32:25
Hajo_Zi
und falls es übers Jahresende geht.
Tabelle1
 ABC
101.02.201205.05.20124
201.12.201203.02.20133

verwendete Formeln
Zelle Formel Bereich
C1 =REST(MONAT(B1)-MONAT(A1)+1;12) 
C2 =REST(MONAT(B2)-MONAT(A2)+1;12) 

Tabellendarstellung in Foren Version 5.50


Gruß Hajo
Anzeige

343 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige