Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Datum nach Prüfung mehrer Bedingungen anzeigen

Datum nach Prüfung mehrer Bedingungen anzeigen
28.08.2008 13:27:54
Wilfried
Hallo, brauche dringend Hilfe !!
In einer Tabelle mit Kundendaten wird in Spalte C2:C350 zu Prüfzwecken ein "x" eingetragen. In Spalte AB2:AB350 erfolgt der Eintrag "N" wenn der Kunde nicht erschienen ist. In Spalte Z2:Z350 steht das dazugehörige Datum. Ich benötige eine Formel, welche mir nur in der Kombination z.B. C 33 x und AB 33 N das Datum Z33 anzeigt. Danke !!!

17
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
so wie Du fragst ...
28.08.2008 13:39:51
neopa
Hallo
... einfach =(C33="x")*(AB33="N")*Z33
Gruß Werner
.. , - ...
AW: so wie Du fragst ...
28.08.2008 14:04:00
Wilfried
Danke Werner,
ich benötige die Daten aber zur Prüfung ganzer Spalten. Ob C2:C350 "x" enthält, AB2:AB350 "N" enthält. Wenn die Ergebnisse zutreffen, soll das Datum in der entsprechen Zeile Z2:Z350 angezeit werden. Die Formel habe ich umgebaut, aber es klappt nicht.
MfG Wilfried J.
AW: so wie Du fragst ...
28.08.2008 14:15:03
David
Ist denn das Datum in Spalte Z manuell eingegeben? Wenn ja, kannst du in der Spalte keine Formel eingeben, denn es geht nur ENTWEDER Wert ODER Formel.
Also entweder du machst eine weitere Spalte, mit der Formel von Werner, oder du formatierst deine Datumsspalte per bedingter Formatierung so, dass die entsprechenden Zellen hervorgehoben werden.
Gruß
David
Anzeige
AW: so wie Du fragst ...
28.08.2008 14:42:00
Wilfried
Hallo David,
Das Datum in Spalte Z wurde manuell eingegeben, es ist ein regelmässig wahrzunehmender Termin. Es soll nach Prüfung der beiden Voraussetzungen x und N an anderer Stelle angezeigt werden, um es dann in ein Erinnerungsschreiben einzufügen. Die Markierung per bedingte Formatierung genügt also nicht.
MfG Wilfried J.
AW: Es wäre hilfreich, ...
28.08.2008 15:18:55
mpb
... wenn Du Deinen Versuch mal posten würdest. Die Formeln von Werner und Hary machen genau das, was Du willst. Wenn ein "x" und ein "N" in einer Zeile in den Spalten C und AB eingetragen sind, wird in der Zelle, in der Du die Formel einträgst das Datum aus der Spalte Z eingetragen. Wo ist das Problem?
Gruß
Martin
Anzeige
AW: Es wäre hilfreich, ...
28.08.2008 15:29:15
Wilfried
Hallo Martin,
kann leider den Link von Hary auf meinem "Dienstrechner" nicht öffnen. Habe mir aus allen Tipps eine Formel gebastelt, welche mir eigentlich das gewünschte Datum anzeigen sollte. Ergibt leider immer wieder Falsch.
=WENN(UND(C2:C350="x";Y2:Y350="N");SVERWEIS(Z2:Z350;Z2:Z350;1;FALSCH))
MfG Wilfried J.
AW: Es wäre hilfreich, ...
28.08.2008 15:41:00
David
Irgendwie redest du an uns vorbei.
Tabellenblattname: Tabelle1
 

A

B

C

D

E

F

1

Kunde

X oder nicht X

N oder nicht N

Datum

 

Treffer

2

1

x

n

28.08.2008

 

28.08.2008

3

2

x

 

29.08.2008

 

 

4

3

 

n

30.08.2008

 

 

5

4

x

n

31.08.2008

 

31.08.2008

6

5

x

 

01.09.2008

 

 

7

6

 

n

02.09.2008

 

 

8

7

 

n

03.09.2008

 

 

9

8

x

n

04.09.2008

 

04.09.2008

10

9

 

 

05.09.2008

 

 

11

10

x

n

06.09.2008

 

06.09.2008

12

11

 

 

07.09.2008

 

 

13

12

 

n

08.09.2008

 

 

14

13

x

n

09.09.2008

 

09.09.2008

15

14

x

 

10.09.2008

 

 

16

15

x

 

11.09.2008

 

 


Benutzte Formeln:
F2: =WENN(UND(B2="x";C2="n");D2;"")
F3: =WENN(UND(B3="x";C3="n");D3;"")
F4: =WENN(UND(B4="x";C4="n");D4;"")
F5: =WENN(UND(B5="x";C5="n");D5;"")
F6: =WENN(UND(B6="x";C6="n");D6;"")
F7: =WENN(UND(B7="x";C7="n");D7;"")
F8: =WENN(UND(B8="x";C8="n");D8;"")
F9: =WENN(UND(B9="x";C9="n");D9;"")
F10: =WENN(UND(B10="x";C10="n");D10;"")
F11: =WENN(UND(B11="x";C11="n");D11;"")
F12: =WENN(UND(B12="x";C12="n");D12;"")
F13: =WENN(UND(B13="x";C13="n");D13;"")
F14: =WENN(UND(B14="x";C14="n");D14;"")
F15: =WENN(UND(B15="x";C15="n");D15;"")
F16: =WENN(UND(B16="x";C16="n");D16;"")
Wo ist da jetzt dein Problem?
Gruß
David
Anzeige
AW: Es wäre hilfreich, ...
28.08.2008 16:39:34
Wilfried
Hallo David,
danke für Deine Bemühungen. Mein Problem ist, dass ich das Ergebnis nur in einer einzigen Zelle angezeigt haben will. Ich will nicht noch die Tabelle durch unzählige Hilfsspalten aufblähen. Das x wird in C2:C350 jeweils nur einmal zu Kontrollzwecken bei dem Kunden gesetzt, dessen Termin ich bearbeite. Alle anderen Zellen bleiben leer. Das N steht in AB2:AB 350 bereits mehrfach , da auch ca. 350 Kunden zu unterschiedlichen Terminen erscheinen bzw. nicht erschienen sind. Deine Tabelle trifft die Sache schon, allerdings soll nur (am Beispiel Deiner Tabelle) Spalte B2 das x enthalten. Wenn dann zusätzlich in Spalte C2 ein N steht, soll in Spalte F(oder eine andere) das Datum aus D2 angezeigt werden.
Anzeige
AW: Es wäre hilfreich, ...
28.08.2008 17:50:06
mpb
Hallo Wilfried,
die entscheidende Information ist, dass das "x" in Spalte C genau einmal vorkommt. Dann geht es z.B. mit folgender Matrixformel:
=SUMME(((C2:C350)="x")*((Y2:Y350)="N")*(Z2:Z350))
Eingabe nicht mit ENTER, sondern mit STRG-SHIFT-ENTER abschließen.
Gruß
Martin
AW: Alternative
28.08.2008 17:51:35
mpb
Folgende einfach Formel funktioniert auch:
=SUMMENPRODUKT(((C2:C350)="x")*((Y2:Y350)="N")*(Z2:Z350))
Gruß
Martin
Mann kannst Du klammern ;-) ...
28.08.2008 18:24:33
neopa
Hallo Martin
... ohne das jetzt wirklich nachzuprüfen, behaupte ich mal, dass Du hier 6 Klammern einsparen kanst, wenn Du das letzte * duch ein Semikolon ersetzt.
also =SUMMENPRODUKT((C2:C350="x")*(Y2:Y350="N");Z2:Z350)
sollte eigentlich reichen. Oder?
Gruß Werner
.. , - ...
Anzeige
AW: Die Klammern...
29.08.2008 11:49:00
mpb
... blieben von der vorher geposteten Matrixformel "übrig", die Summenprodukt-Formel habe ich dann noch schnell nachgeschoben. Generell setze ich aber lieber zuviel als zuwenige Klammern, da sicherer und leichter nachvollziehbar.
Gruß
Martin
AW: Es wäre hilfreich, ...
28.08.2008 15:44:00
hary
Hallo Wilfried
diese Formel und runterkopieren

=WENN(UND(C2="x";Y2="N");Z2;"")


Gruss Hary

AW: Es wäre hilfreich, ...
28.08.2008 16:13:00
Wilfried
Ergänzung : Diese Formel steht in AO 63 und soll das mit Sverweis aus Z2:Z350 ermittelte Datum anzeigen; wenn in der gleichen Zeile C2:C350 das x und in Y2:Y350 das N vorhanden sind
MfG Wilfried J.
Anzeige
AW: Es wäre hilfreich, ...gewesen......
28.08.2008 18:36:00
hary
Nochmals Hallo Wilfried
Haettest Du gleich gesagt das "x" nur einmal vorkommt!!!! Dann waere die Antwort viel frueher bei Dir.
Gruss hary
AW: Es wäre hilfreich, ...gewesen......
28.08.2008 21:31:03
Wilfried
Hallo,
an alle fleißigen Helfer! Die Formel von neopa war`s. Die Tabelle funktioniert nun wie ein Uhrwerk. Hatte mich so sehr auf Wenn und Sverweis versteift, dass ich die Variante mit Summenprodukt garnicht in Erwägung gezogen habe.
Nochmals Dank an alle !!!!!!!!! MfG Wilfried J.

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige