Live-Forum - Die aktuellen Beiträge
Datum
Titel
19.07.2024 18:36:17
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zeitraum zweier Daten in Zahlen umwandeln

Zeitraum zweier Daten in Zahlen umwandeln
BoB
Hallo zusammen,
ich bin noch nicht besonders versiert in Excel, aber ich möchte es werden:).
Wie kann ich den Zeitraum zwischen zwei Daten in Zahlen umwandeln. z.B. 11.07.2011 - 17.07.2011
Ich könnte natürlich das Anfangsdatum vom Enddatum subtrahieren, dann habe ich den Zeitraum von 7 Tagen.
Das Problem ist im Prinzip folgenedes, ich bekomme immer einen Rohwert "siehe Beispiel oben" und muss dieses splitten auf 11.07/12.07/13.07 usw. an jedem Tag soll dann eine 1 erscheinen, damit in der Summe am Ende wieder 7 als Ergebnis erscheint.
Ich hoffe ich hab mich verständlich ausgedrückt. Bitte bedenkt ich bin ein Frischling, also habt nachsicht und antwortet nicht zu kompliziert.
Vielen Dank im Voraus für eure großartige Hilfe.
Der BoB
AW: Zeitraum zweier Daten in Zahlen umwandeln
12.07.2011 08:12:46
fcs
Hallo BoB,
Hier ein Beispiel mit Formeln. Die Formeln für Tag 2 kannst dann nach unten kopieren.
Gruß
Franz
Tabelle1

 ABC
1Periode11.07.2011 - 17.07.2011 
21. Tag11.07.2011Anz. Tage
3Letzter Tag17.07.20117
4Summe 7
5TagDatumDiff
6Tag 111.07.20111
7Tag 212.07.20111

Formeln der Tabelle
ZelleFormel
B2=DATWERT(GLÄTTEN(TEIL(B1;1;SUCHEN("-";B1)-1)))
B3=DATWERT(GLÄTTEN(TEIL($B$1;SUCHEN("-";$B$1)+1;15)))
C3=B3-B2+1
C4=SUMME(C6:C50)
A6=WENN(B6="";"";"Tag " & ZEILE() -ZEILE($A$5))
B6=DATWERT(GLÄTTEN(TEIL(B1;1;SUCHEN("-";B1)-1)))
C6=WENN(B6="";"";1)
A7=WENN(B7="";"";"Tag " & ZEILE() -ZEILE($A$5))
B7=WENN(B6="";"";WENN(DATWERT(GLÄTTEN(TEIL($B$1;SUCHEN("-";$B$1)+1;15)))>=B6+1;B6+1;""))
C7=WENN(B7="";"";1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige
Zeitraum zweier Daten in Zahlen
12.07.2011 08:15:47
Erich
Hi,
meinst du das so? (Formeln von D2:E2 nach unten kopieren)
 ABCDE
1von11.07.2011 DatumTage
2bis17.07.2011 11.07.20111
3Tage:7 12.07.20111
4   13.07.20111
5   14.07.20111
6   15.07.20111
7   16.07.20111
8   17.07.20111
9    0
10    0

Formeln der Tabelle
ZelleFormel
D2=B1
E2=1*ISTZAHL(D2)
B3=B2+1-B1
D10=WENN(D$2+ZEILE(D8)<=B$2;D$2+ZEILE(D8); "")
E10=1*ISTZAHL(D10)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
Zeitraum zweier Daten - Korrektur
12.07.2011 08:18:19
Erich
Hi,
sorry, das war Unfug, hier eine neue Version (Formeln von D3:E3 nach unten kopieren)
 ABCDE
1von11.07.2011 DatumTage
2bis17.07.2011 11.07.20111
3Tage:7 12.07.20111
4   13.07.20111
5   14.07.20111
6   15.07.20111
7   16.07.20111
8   17.07.20111
9    0
10    0

Formeln der Tabelle
ZelleFormel
D2=B1
E2=1*ISTZAHL(D2)
B3=B2+1-B1
D3=WENN(D$2+ZEILE(D1)<=B$2;D$2+ZEILE(D1); "")
E3=1*ISTZAHL(D3)
D10=WENN(D$2+ZEILE(D8)<=B$2;D$2+ZEILE(D8); "")
E10=1*ISTZAHL(D10)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: Zeitraum zweier Daten in Zahlen umwandeln
12.07.2011 08:22:12
Reinhard
Hallo Bob,
:::Wie kann ich den Zeitraum zwischen zwei Daten in Zahlen umwandeln. z.B. 11.07.2011 - 17.07.2011
:::Ich könnte natürlich das Anfangsdatum vom Enddatum subtrahieren, dann habe ich den Zeitraum von 7 :::Tagen.
nein, da kommt 6 raus.
:::Das Problem ist im Prinzip folgenedes, ich bekomme immer einen Rohwert "siehe Beispiel oben" und
Was heißt das, steht dann
11.07.2011 - 17.07.2011
in einer Zelle?
:::muss dieses splitten auf 11.07/12.07/13.07 usw.
Was heißt das, steht dann
11.07/12.07/13.07...
in einer Zelle?
:::an jedem Tag soll dann eine 1 erscheinen,
wo soll die denn nun wieder stehen/erscheinen?
Gruß
Reinhard
Anzeige
AW: Zeitraum zweier Daten in Zahlen umwandeln
12.07.2011 08:40:11
BoB
Hallo Reinhard,
ich bekomme einen Auszug aus einem System, wo der Urlaub eines jeden Mitarbeiters erscheint.11.07 zb. in Spalte A und 17.07 in Spalte B. Hat der MA jetzt vom 11.07 - 17.07 Urlaub, so sind dies 7 Tage an denen er Urlaub hat. Natürlich hast du recht, wenn du sagst, dass eine Subtraktion 6 ergibt. Dieser Wert ist jedoch richtig, denn eine Arbeitswoche beträgt (hier zumindest) max. 6 Werktage.
Mit splitten meine ich, dass ich in den Spalten D bis XYZ(je nachdem wie weit dies geht) dann die einzelnen tage , d.h. 12.7 in Spalte D ind E 13.07 stehen habe. Auf der linken Seite stehen die Mitarbeiter untereinander, nach rechts hinweggehend (wie ein Zeitstrahl) ist die Datumsangabe des ganzen Jahres (spalte für Spalte) und neben dem MA kommen die Rohdaten.
Die 1 soll nun immer in Richtung rechts erscheinen, unter z.b. dem 12.7 (eine 1) wenn der MA links dort Urlaub hat.
Bitte entschuldige meine schlechte Sprachgewandheit, diese Materie ist neu für mich, von daher weiß ich nicht genau wie ich meine Probleme schildern muss, damit ich Hilfe erwarten kann. Ich hoffe dies war etwas verständlicher für dich?
Lieben Gruß
BoB
Anzeige
AW: Zeitraum zweier Daten in Zahlen umwandeln
12.07.2011 09:19:48
Reinhard
Hallo Bob,
was ist wenn der gleiche Mitarbeiter im Jahr nochmal frei hat?
Die anderen Lösungen, kriegste die umgebastelt/eingebaut?
Und, sieht deine Tabelle in etwa so aus?
Wenn nicht lad mal ein beispiel hoch.
Userbild
Gruß
Reinhard
AW: Zeitraum zweier Daten in Zahlen umwandeln
12.07.2011 15:52:43
BoB
Hallo Reinhard, ja genauso soll die Datei dann aussehen. Über die Problematik, wenn jemand häufiger im Jahr urlaub hat, habe ich mir noch keinen Kopf gemacht. Hast du da eine Lösung?
AW: Zeitraum zweier Daten in Zahlen umwandeln
12.07.2011 10:13:27
BoB
Hallo Reinhard,
ich bekomme einen Auszug aus einem System, wo der Urlaub eines jeden Mitarbeiters erscheint.11.07 zb. in Spalte A und 17.07 in Spalte B. Hat der MA jetzt vom 11.07 - 17.07 Urlaub, so sind dies 7 Tage an denen er Urlaub hat. Natürlich hast du recht, wenn du sagst, dass eine Subtraktion 6 ergibt. Dieser Wert ist jedoch richtig, denn eine Arbeitswoche beträgt (hier zumindest) max. 6 Werktage.
Mit splitten meine ich, dass ich in den Spalten D bis XYZ(je nachdem wie weit dies geht) dann die einzelnen tage , d.h. 12.7 in Spalte D ind E 13.07 stehen habe. Auf der linken Seite stehen die Mitarbeiter untereinander, nach rechts hinweggehend (wie ein Zeitstrahl) ist die Datumsangabe des ganzen Jahres (spalte für Spalte) und neben dem MA kommen die Rohdaten.
Die 1 soll nun immer in Richtung rechts erscheinen, unter z.b. dem 12.7 (eine 1) wenn der MA links dort Urlaub hat.
Bitte entschuldige meine schlechte Sprachgewandheit, diese Materie ist neu für mich, von daher weiß ich nicht genau wie ich meine Probleme schildern muss, damit ich Hilfe erwarten kann. Ich hoffe dies war etwas verständlicher für dich?
Lieben Gruß
BoB
Anzeige

424 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige