Microsoft Excel

Herbers Excel/VBA-Archiv

Wort in Zahl umwandeln für ein Spiel


Betrifft: Wort in Zahl umwandeln für ein Spiel von: Bulls Eye
Geschrieben am: 10.07.2017 00:00:16

Hallo,

ich möchte durch eine Formel, wörter in Zahlen unter berücksichtigung der position im alphabet generieren usw folgendes für a=1 b=2 c=3 usw

Habe ich bsp in Zelle E5 das Wort ANNA soll in Zelle G3 eine 40 Stehen weil A=1 N=19 N=19 A=1

kann jemand helfen?

  

Betrifft: AW: Wort in Zahl umwandeln für ein Spiel von: Daniel
Geschrieben am: 10.07.2017 00:17:55

HI

für die 26 "normalen" Buchstaben (A-Z) beispielsweise so:

=SUMMENPRODUKT(CODE(TEIL(GROSS(E5&WIEDERHOLEN("?";99));ZEILE($A$1:$A$99);1))-63)

wobei "N" die Postion 14 hat und nicht 19.

Daniel


  

Betrifft: nicht "?" und -63 sondern @ und -64 von: WF
Geschrieben am: 10.07.2017 05:58:05

Hi,

CODE("A") ist 65
=SUMMENPRODUKT(CODE(TEIL(GROSS(E5&WIEDERHOLEN("@";99));ZEILE($A$1:$A$99);1))-64)

WF


  

Betrifft: danke für die korrektur von: Daniel
Geschrieben am: 10.07.2017 08:15:50




  

Betrifft: AW: danke für die korrektur von: Bulls Eye
Geschrieben am: 11.07.2017 01:00:38

Danke :) hat geklappt


  

Betrifft: AW: alternativ ohne WIEDERHOLEN() mit INDEX() ... von: ... neopa C
Geschrieben am: 10.07.2017 09:41:38

Hallo,

... so:

=SUMME(INDEX(CODE(TEIL(GROSS(E5);ZEILE(A$1:INDEX(D:D;LÄNGE(E5)));1))-64;))

und wenn auch eine 0 für eine Leerzelle ausgeben werden soll, dann z.B. so:
=SUMME(INDEX(CODE(TEIL(GROSS(E5&"@");ZEILE(A$1:INDEX(D:D;LÄNGE(E5)+1));1))-64;))

Gruß Werner
.. , - ...


  

Betrifft: Das sind 8 Funktionen statt 6. von: WF
Geschrieben am: 10.07.2017 10:34:26

.


  

Betrifft: AW: dafür dreht die Schleife keine unnötigen.. von: Daniel
Geschrieben am: 10.07.2017 10:56:04

Umläufe.
das kann auch ein Vorteil sein.

Gruß Daniel


  

Betrifft: Wenn es auf die Anzahl der Fktt ankäme und ... von: Luc:-?
Geschrieben am: 10.07.2017 19:12:58

…außerdem scheinbar überflüssige „Leerläufe“ vermieden wdn sollten, Folks,
wären wohl unter der Einbeziehung von KleinBuchstaben (ohne Sonderbuchstaben!) und Leerzellen bei Akzeptanz einer einzigen UDF folgende Fmln kaum zu unterbieten:
=SumBin(KLEIN(A1))-(CODE("a")-1)*LÄNGE(A1) → Leerzelle liefert 0, SonderBstabe Wert außerhalb 1… 26
=SUMME(SPALTE(INDIREKT(T(VSplit(A1;"";;1))&1))) → Leerzelle liefert #WERT!, SonderBstabe #BEZUG!
=WENNFEHLER(SUMME(SPALTE(INDIREKT(T(VSplit(A1;"";;1))&1)));0)
SumBin: https://www.herber.de/cgi-bin/callthread.pl?index=1565164#1565169 *
VSplit: https://www.herber.de/bbs/user/99024.xlsm
* Alifa hatte dort ein ganz ähnliches Problem!
Feedback nicht unerwünscht! Gruß, Luc :-?

Besser informiert mit …


  

Betrifft: AW: unter Zuhilfenahme von UDFs ist die .... von: Daniel
Geschrieben am: 10.07.2017 22:06:44

...kürzestmögliche Formel immer

=x(A1)

Weil man den benötigten Rechenumfang in den Code der Funktion packen kann.

Gruß Daniel


  

Betrifft: Aber die kann dann auch nur das, .... von: Luc:-?
Geschrieben am: 11.07.2017 02:25:00

…Daniel,
wie du weißt, aber meine UDFs sollen Angebotslücken schließen, nicht wie komplette Projekte fktionieren, was ja auch bei Xl-Fktt der Fall ist…
Insofern ist deine Aussage zwar im Prinzip richtig, aber irrelevant, da sie ein UDF-Verständnis zeigt, das weder das meine ist noch den Absichten der Xl-Entwickler entsprechen dürfte. *
SumBin liegt zwar etwas mehr in dieser Richtung, aber mitunter könnte man ja auch die volle Summe der CodeWerte benötigen, um davon ggf ungefähre Textlängen in cm o.a. abzuleiten.
Und VSplit schließt eine Lücke, die von TEIL nicht unbedingt vollends ausgefüllt wird, was man schon bemerkt, wenn man hier VSplit durch TEIL ersetzen wollte → es wird komplizierter!
Letztlich kann das gesamte Fml-InterpretationsPgm*° von Xl als eine (mathematische) Fkt f(x) aufgefasst wdn, die sich auch gewisser „UnterFktt“ bedient, um eine rationelle AufgabenBeschreibung und -Lösung zu ermöglichen. Die XLM-Fkt AUSWERTEN und das VBA-Ggstück Evaluate stellen hierbei die allgemeinste Form° dar.
* Dem kommen Container-Fktt wie TEILERGEBNIS und AGGREGAT schon näher, allerdings benötigen sie noch zusätzliche Argumente, um etwas universeller zu wdn. Der Nutzer kann also auch den EinsatzZweck in gewissem Umfang fallweise festlegen, was er bei einfachem x(A1) oder besser f(x) nicht könnte; hier müsste eine bestimmte f gwählt wdn.
° Man könnte natürlich auch ein eigenes Fml-InterpretationsPgm für (speziell notierte) FmlTexte schreiben, wie ich es vor 13 Jahren mal getan hatte (und zZ auf neuer DarstellungsBasis versuche). In diesem Fall bestimmt der Nutzer bis ins Detail, was berechnet wdn soll, ohne ein VBA-Pgm schreiben zu müssen.

Gruß, Luc :-?


  

Betrifft: AW: Aber die kann dann auch nur das, .... von: Daniel
Geschrieben am: 11.07.2017 07:48:26

macht ja nichts, dass sie nur das kann.
ist als UDF dafür schnell und von jedem Anwender mit VBA-Grundkenntnissen zu erstllen.
ist ja nirdgenswo festgeschrieben, dass nur dein Verständniss für die Anwendung von UDFs hier relevant sein soll.
Wenn man in den Wettbewerb um die kürzeste Formel eintritt, dann sollte man in diesen Wettbewerb auch mit dem selben Funktionsumfang antreten wie alle anderen Wettbewerber auch, man fährt ja auch nicht mit einem E-Bike bei der Tour de France mit.

Gruß Daniel


  

Betrifft: Ich trete in keinen Wettbewerb ein, ... von: Luc:-?
Geschrieben am: 11.07.2017 19:05:58

…Daniel,
denn das ist nicht mein Ziel (auch, wenn's hier und anderswo gelegentlich so aussieht). Ich verwende UDFs dort, wo MS mit Fktt geknausert hat (und es zT bis heute tut)! Die von dir präferierten „schnellen“ (wenn sie es denn auch sind, aber zumindest relativ schnell pgmmierten) EinzelStücke würden in ihrer Gesamtheit eine unübersichtliche FktsLandschaft bilden, die so ziemlich das Ggteil von dem darstellt, was die ursprünglichen Xl-Pgmmierer beabsichtigt hatten. Deine diesbzgl Logik ist die von Pgmmierern, die Fkts­Prozeduren allein als Pgmmier­Hilfsmittel sehen. Diese Sichtweise sollte man nicht auf UDFs für den Fml-Einsatz übertragen, denn das würde uU zur Vermüllung eines Xl-Arbeits­platzes beitragen und dem nächsten Mitarbeiter auf demselben Probleme bereiten können, die er ggf nur radikal lösen könnte. Wer so etwas anbietet, arbeitet also auf lange bzw längere Sicht für das digitale Nir­vana!
Wieviele Anwender haben denn VBA-Grundwissen? Ist das nicht eher eine Minderheit, die idR weder von ihren Firmen noch MS adäquat unterstützt wird (abgesehen mal von den Fällen, in denen ein Admin defacto Pgmmier­Laien - mitunter kreuz­gefährlich - herum­wursteln lässt, aber qualifizierte AddIns, auch offizielle, sperrt). Und wer mit Grundwissen immer nur momentane Probleme löst, wird sich kaum umfassendere Kenntnisse aneignen. Wenn er dann im Netz auch nur so etwas findet, gelangt er womöglich zu einer falschen Auffassung von VBA…
Und das ist nicht etwa nur meine Meinung, sondern diese dürfte auch die Grundlage für die Pgmm der Xl-StandardFktt sein, wobei bei den meisten noch eine auf der üblichen Xl-Ebene kaum extern (per VBA) nach­voll­ziehbare Beson­derheit hinzu­kommt → die von vornherein vorgesehene umfängliche Zusammen­Arbeit mit dem Xl-Fml-Inter­pretations­pgm!
Luc :-?


  

Betrifft: ... aber ein Add-in könntest Du bauen von: lupo1
Geschrieben am: 12.07.2017 10:43:03

... wo Deine Funktionen, die Du als fehlend im Standard siehst, enthalten sind.

Am besten gleich auf Englisch (so wie Du sie ja schon hast), damit Sprachwechsel keine Auswirkungen haben.

Verlinken kannst Du auf das Add-In übrigens per (anonymem!) Shortcut auf Google Drive oder MS OneDrive, falls Du einen E-Mail-Zugang zu einem von den beiden Diensten hast.

Separater Doku-Link wäre nicht schlecht. Und einer auf eine Beispieldatei für die Nutzung der Funktionen ebenfalls.


  

Betrifft: E5&"@" in der zweiten Formel ist Quatsch von: WF
Geschrieben am: 10.07.2017 12:32:26

Hi,

CODE( &"@") ergibt 32 (den Code für ne Leerzelle).
A NNA ergibt so -2

Da hilft nur WECHSELN(E5;" ";)

WF


  

Betrifft: AW: Leerzelle! nicht Leerzeichen von: Daniel
Geschrieben am: 10.07.2017 12:51:14

Hi WF
bitte lies nochmal den Lösungvorschlag genau.
Du verwechselst hier Leerzelle mit Leerzeichen.

Gruß Daniel


  

Betrifft: stimmt von: WF
Geschrieben am: 10.07.2017 12:59:16

.


Beiträge aus den Excel-Beispielen zum Thema "Wort in Zahl umwandeln für ein Spiel"