Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählen der zellen >0 in einer tabelle + dropdown

Zählen der zellen >0 in einer tabelle + dropdown
Björn
hallo ich habe eine tabelle (siehe link) in der ich in der oberen tabelle eintrageungen machen möchte
unten soll in den zellen B14 - B21 über ein dropdown menü die verschiedenen eingaben aus der oberen tabelle auswählbar sein. durch diese auswahl soll die berechnung in den zellen C14 - C21 gesteuert werden.
teilweise funktioniert dieses schon. ich kann hiermit die summe aus der gewünschten zeille der oberen tabelle bilden.
mir fehlt jetzt eine (weitere) funktion um die zellen, welche größer 0 sind in dieser zeile zu zählen.
das ganze soll das ziel haben den mittelwert aller zellen größer 0 innerhalb einer zeile bilden zu können.
hat jemand eine einfache idee?
https://www.herber.de/bbs/user/77831.xlsx

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Zählen der zellen >0 in einer tabelle + dropdown
06.12.2011 12:04:19
Rudi
Hallo,
kann das nicht öffnen.
Warum nicht einfach mit
=Summe(1:1)/Zählenwenn(1:1;">0")
Gruß
Rudi
AW: Zählen der zellen >0 in einer tabelle + dropdown
06.12.2011 12:39:52
Björn
hmm danke für deinen lösungsvorschlag aber so einfach ist die geforderte lösung nicht. weiß auch nicht warum du das nicht öffnen kannst. ich habs nochmal runter geladen und bei mir ging es. ist ne *.xlsx datei. also excel ab 2007.
vielleicht noch jemand anderes eine idee?
ich kann das nicht öffnen, ....
06.12.2011 13:28:18
Rudi
Hallo,
weil ich kein 2007 habe. Und wenn du Bezüge jenseits IV65536 einbaust, dann macht der Konverter nur #BEZUG! daraus. Ich sehe auch kein DropDown.
Du musst also auf meine Hilfe verzichten oder eine .xls erstellen.
Gruß
Rudi
Anzeige
ZählenWenn()
06.12.2011 12:58:26
Matthias
Hallo
Sollte doch mit Zählenwenn funktionieren.
Tabelle1

 ABCD
3 BauvorhabenSjip-Wai 14Wenzel
4 ArchitektHelmut GerdtHoffmann
51.Bauschild0,00 €0,00 €
62.Schuttbeseitigung, Baureinigung0,00 €202,06 €
73.Strom, Wasser, Telefon 0,4%475,39 €202,06 €
84.Bauwesenversicherung 0,2%0,00 €101,03 €
95.Bauwesenversicherung 0,3%356,54 €0,00 €
106.Vertragsstrafe/Mängel/Vergütung/Minderung0,00 €0,00 €
117.Nachlass5.942,36 €0,00 €
12    
13    
14 Bauschild0,00 €0
15 Schuttbeseitigung, Baureinigung202,06 €1
16 Strom, Wasser, Telefon 0,4%677,45 €2
17 Bauwesenversicherung 0,2%101,03 €1
18 Bauwesenversicherung 0,3%356,54 €1
19 Vertragsstrafe/Mängel/Vergütung/Minderung0,00 €0
20 Nachlass5.942,36 €1

Formeln der Tabelle
ZelleFormel
C14{=SUMME(WENN($B$5:$B$11=B14;$C$5:$ZZ$11))}
D14=ZÄHLENWENN(C5:XFD5;">0")
C15{=SUMME(WENN($B$5:$B$11=B15;$C$5:$ZZ$11))}
D15=ZÄHLENWENN(C6:XFD6;">0")
C16{=SUMME(WENN($B$5:$B$11=B16;$C$5:$ZZ$11))}
D16=ZÄHLENWENN(C7:XFD7;">0")
C17{=SUMME(WENN($B$5:$B$11=B17;$C$5:$ZZ$11))}
D17=ZÄHLENWENN(C8:XFD8;">0")
C18{=SUMME(WENN($B$5:$B$11=B18;$C$5:$ZZ$11))}
D18=ZÄHLENWENN(C9:XFD9;">0")
C19{=SUMME(WENN($B$5:$B$11=B19;$C$5:$ZZ$11))}
D19=ZÄHLENWENN(C10:XFD10;">0")
C20{=SUMME(WENN($B$5:$B$11=B20;$C$5:$ZZ$11))}
D20=ZÄHLENWENN(C11:XFD11;">0")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige
AW: ZählenWenn()
06.12.2011 13:07:27
Björn
ja das mit zählenwenn ist mir klar. aber ich weiß nicht, wie ich das mit dem dropdownmenü in den zellen B14 bis B21 verbinde, dass bei einer änderung mit dem dropdown sich auch die formel immer auf die richtige zeile der oberen tabelle bezieht.
Vorschlag mit SUMMENPRODUKT
06.12.2011 13:28:40
Erich
Hi Björn,
wie wäre es damit?
 CDE
13SummeAnzahl(>0)Mittelwert(>0)
14677,45 €2338,725

Formeln der Tabelle
ZelleFormel
C14{=SUMME(WENN($B$5:$B$11=B14;$C$5:$ZZ$11))}
D14=SUMMENPRODUKT(($B$5:$B$11=B14)*($C$5:$ZZ$11>0))
E14=SUMMENPRODUKT(($B$5:$B$11=B14)*$C$5:$ZZ$11)/SUMMENPRODUKT(($B$5:$B$11=B14)*($C$5:$ZZ$11>0))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige
AW: Vorschlag mit SUMMENPRODUKT
06.12.2011 13:34:37
Björn
danke hat geklappt
C14 einfacher
06.12.2011 13:36:33
Rudi
Hallo Erich,
da ja Mittelwert*Anzahl Werte=Summe ist, sollte in C14 doch auch =E14*E14 reichen.
Alternativ
C14: =SUMMENPRODUKT(($B$5:$B$11=B14)*$C$5:$ZZ$11)
D14: =SUMMENPRODUKT(($B$5:$B$11=B14)*($C$5:$ZZ$11>0))
E14: =C14/D14
Gruß
Rudi
oder auch so?
06.12.2011 16:19:43
Erich
Hi Rudi,
wenn die Anzahl nicht als Ergebnis, sondern nur als Zwischenergebnis gebraucht wird, dann auch so:
 BCD
13 SummeMittelwert(>0)
14Bauschild0,00 €is nich
15Schuttbeseitigung, Baureinigung202,06 €202,06
16Strom, Wasser, Telefon 0,4%677,45 €338,725

Formeln der Tabelle
ZelleFormel
C14=SUMMENPRODUKT(($B$5:$B$11=B14)*$C$5:$ZZ$11)
D14=WENN(SUMMENPRODUKT(($B$5:$B$11=B14)*($C$5:$ZZ$11>0))=0;"is nich"; C14/SUMMENPRODUKT(($B$5:$B$11=B14)*($C$5:$ZZ$11>0)))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige

348 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige