Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zahlen von einer in eine andere Tabelle

Zahlen von einer in eine andere Tabelle
einer
Hallo,
ich benötige mal wieder Hilfe. Diese Tabelle bringt mich noch um.
Mein Problem:
Ich habe 2 Tabellen.
In der einen habe ich den GDP von allen Ländern Spalte A (untereinander, alphabetisch geordnet) von den Jahren 2003 -2007 (die in den Spalten B-F stehen).
In der anderen Tabelle habe ich auch die Länder in Spalte A, (aber wahrscheinlich nicht 100% die gleichen, es könnte sein, das einige nicht dabei sind, die aber bei Tabelle 1 sind, oder andersrum.)
Nun sollen die GDP Zahlen von Tabelle 1 in Tabelle 2 in die Spalten N (2003), W (2004), AH (2005), AS (2006), BD (2007).
Gibt es da irgendeine Möglichkeit das mit einer Formel zu machen? Ohne das ich die ganzen Zahlen abtippen muss? Das wäre super wenn mir einer helfen könnte.
Danke schon mal.
Thomas
P.S. GDP = Bruttoinlandsprodukt
AW: Zahlen von einer in eine andere Tabelle
19.08.2009 15:43:34
einer
Hallo Thomas,
schau Dir die Funktion SVERWEIS an. Das ist genau das richtige Vehikel.
Gruß
Helmut
AW: Zahlen von einer in eine andere Tabelle
19.08.2009 16:44:53
einer
hi Thomas, ich würde das mit INDEX() regeln... leider hast du keine (beispiel-)datei hochgeladen oder einen tabellenauschnitt...
hierzu gibt es ein hervorragendes tool auf der seite von Beverly (Karin) auf ihrer internetseite: http://beverly.excelhost.de/
dort auf Komplettlösungen Tabellendarstellung in Foren oder direkt http://c.excelhost.de/c_beverly/getfile.php?id=122

cu jörg
ein feedback wär ganz reizend
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 09:41:22
einer
Hallo,
ich bekomme es weder mit SVERWEIS hin, noch mit INDEX.
Ich habe jetzt beide Tabellen mal angehängt. Vielleicht kann mir einer ja sagen, wie ich das Machen muss:
Tabelle 1: in die die Zahlen von Tabelle 2 sollen:
Userbild
Tabelle2:
Userbild
Ich hoffe das hilft weiter.
LG Thomas
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 10:16:31
einer
hi Thomas, schade, dass du ein bild hochgeladen hast, ich habe nicht die zeit das nach zu bauen und bleibe beim tipp mit dem INDEX() ...
cu jörg
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 10:30:03
einer
hi Thomas, alles habe ich nicht nachgebaut, aber das sollte zur anschauung reichen, oder?
Tabelle2
 ABCDEF
4  20032004200520062007
5Afghanistan         
6Austria62347
7           



Tabelle1
 ANWAHASBD
3  20032004200520062007
4           
5  GPDGPDGPDGPDGPD
6           
7Countries         
8Austria62347
9Austria & Switzerland         

verwendete Formeln
Zelle Formel
N8 =WENN(ISTNV(VERGLEICH($A8;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A8;Tabelle2!$A:$A;0);VERGLEICH(N3;Tabelle2!4:4;0)))
W8 =WENN(ISTNV(VERGLEICH($A8;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A8;Tabelle2!$A:$A;0);VERGLEICH(W3;Tabelle2!4:4;0)))
AH8 =WENN(ISTNV(VERGLEICH($A8;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A8;Tabelle2!$A:$A;0);VERGLEICH(AH3;Tabelle2!4:4;0)))
AS8 =WENN(ISTNV(VERGLEICH($A8;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A8;Tabelle2!$A:$A;0);VERGLEICH(AS3;Tabelle2!4:4;0)))
BD8 =WENN(ISTNV(VERGLEICH($A8;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A8;Tabelle2!$A:$A;0);VERGLEICH(BD3;Tabelle2!4:4;0)))
N9 =WENN(ISTNV(VERGLEICH($A9;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A9;Tabelle2!$A:$A;0);VERGLEICH(N4;Tabelle2!5:5;0)))
W9 =WENN(ISTNV(VERGLEICH($A9;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A9;Tabelle2!$A:$A;0);VERGLEICH(W4;Tabelle2!5:5;0)))
AH9 =WENN(ISTNV(VERGLEICH($A9;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A9;Tabelle2!$A:$A;0);VERGLEICH(AH4;Tabelle2!5:5;0)))
AS9 =WENN(ISTNV(VERGLEICH($A9;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A9;Tabelle2!$A:$A;0);VERGLEICH(AS4;Tabelle2!5:5;0)))
BD9 =WENN(ISTNV(VERGLEICH($A9;Tabelle2!$A:$A;0));"";INDEX(Tabelle2!$A:$F;VERGLEICH($A9;Tabelle2!$A:$A;0);VERGLEICH(BD4;Tabelle2!5:5;0)))

Tabellendarstellung in Foren Version 4.17



cu jörg
ein feedback wär ganz reizend
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 11:21:29
einer
hi Thomas, das sind links zu zwei dateien nicht zwei tabellen cu jörg
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 11:27:08
einer
Danke, für deine Arbeit, ich habe die Formel bei jetzt umgeformt für meine Tabelle. Das Problem, der zeigt mit gar nichts an. Also auch keine Fehlermeldung. Aber leider nicht den Wert den iich haben will.
Die formel sieht bei mir nun so aus:
=WENN(ISTNV(VERGLEICH($A$9;LÄNDER;0));"";INDEX(LÄNDER;VERGLEICH($A$9;LÄNDER;0);VERGLEICH(N3;LÄNDER;0) ))
Ich habe mittlerweile die Tabelle 2 in 1 reinkopiert und die Matrix "Länder" bennant.
Keine Ahnung warum es nicht funktioniert.
Danke noch mal.
Thomas
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 11:31:28
einer
hi Thomas, schau mal auf die Spalte A in der ausgangsdatei dort steht vor den ländernamen ein leerzeichen - das konnte dann auch nicht gehen. meine vorschläge sehen also nun so aus... das mit dem zusammenlegen der dateien ist löblich, weil leichter zu händeln...
Tabelle1
 ABCDEF
2  20032004200520062007
3  GDPGDPGDPGDPGDP
4           
5Countries         
6EUROPE         
7Albania5652.32 7464.45 8376.48 9097.86 10831.22 
8Andorra00000
9Austria         

verwendete Formeln
Zelle Formel
B6 =WENN(ISTNV(SVERWEIS($A6;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A6;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
B7 =WENN(ISTNV(SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
C7 =WENN(ISTNV(SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
D7 =WENN(ISTNV(SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
E7 =WENN(ISTNV(SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
F7 =WENN(ISTNV(SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A7;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
B8 =WENN(ISTNV(SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
C8 =WENN(ISTNV(SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
D8 =WENN(ISTNV(SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
E8 =WENN(ISTNV(SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
F8 =WENN(ISTNV(SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A8;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
B9 =WENN(ISTNV(SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
C9 =WENN(ISTNV(SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
D9 =WENN(ISTNV(SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
E9 =WENN(ISTNV(SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
F9 =WENN(ISTNV(SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A9;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))



Tabelle1 (2)
 ABCDEF
2  20032004200520062007
3  GDPGDPGDPGDPGDP
4           
5Countries         
6EUROPE         
7Albania5652.32 7464.45 8376.48 9097.86 10831.22 
8Andorra00000
9Austria         

verwendete Formeln
Zelle Formel
B6 =WENN(ISTNV(SVERWEIS($A6;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0));"";SVERWEIS($A6;[63942.xls]Tabelle1!$A$1:$F$10;SPALTE();0))
B7 =WENN(ISTNV(VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
C7 =WENN(ISTNV(VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
D7 =WENN(ISTNV(VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
E7 =WENN(ISTNV(VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
F7 =WENN(ISTNV(VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A7;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
B8 =WENN(ISTNV(VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
C8 =WENN(ISTNV(VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
D8 =WENN(ISTNV(VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
E8 =WENN(ISTNV(VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
F8 =WENN(ISTNV(VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A8;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
B9 =WENN(ISTNV(VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
C9 =WENN(ISTNV(VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
D9 =WENN(ISTNV(VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
E9 =WENN(ISTNV(VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))
F9 =WENN(ISTNV(VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0));"";INDEX([63942.xls]Tabelle1!$A:$F;VERGLEICH($A9;[63942.xls]Tabelle1!$A:$A;0);SPALTE()))

Tabellendarstellung in Foren Version 4.17



cu jörg
ein feedback wär ganz reizend
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 12:26:54
einer
Hallo Jörg,
also entweder liegst am Wetter oder ich bin einfach zu blöd. Ich krieg das nicht hin. Tut mir leid, wenn ich dich nerve.
Bei mir ist immer alles leer. Ich werden nun noch mal die Datei anhängen, einmal in jpg, wie sie wirklich aussieht und einmal zusammen geschrumpft als xls Datei.
Die Leertasten habe ich jetzt alle gelöscht.
kannst du mir einfach die Formel so hinschreiben, dass ich die rauskopieren kann und einfügen. Vielleicht liegt das daran. Das ich sie nicht richtig editiere.
Hier die Originaltabelle
Userbild
Und hier die Tabelle als xls, hier habe ich alle nicht relevanten Spalten gelöscht.
https://www.herber.de/bbs/user/63948.xls
Ich hoffe, das ich es danach hinkriege, sonst werde ich es paar Hand übertragen müssen..
Danke für deine Gedult.
Thomas
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 21:52:50
einer
hi Thomas, du bringst aber auch immer wieder neue konstallationen ins spiel... die formel ist nach unten und nach rechts "ziehbar" ...
Tabelle1
 ABCDEFGHIJKL
1  20032004200520062007           
2                       
3  GDPGDPGDPGDPGDP           
4                       
5Countries            20032004200520062007
6EUROPE          Afghanistan4584.68 5951.97 7305.56 8399.04  
7Albania5652.32 7464.45 8376.48 9097.86 10831.22 Albania5652.32 7464.45 8376.48 9097.86 10831.22 
8Andorra00000Algeria68018.61 85013.95 102339.10 116459.04 135285.46 
9Austria255276.53 293207.11 305098.88 323544.09 373192.00 American Samoa         
10Switzerland          Andorra         
11Austria & Switzerland          Angola13956.27 19775.22 30632.36 45163.24 61403.28 
12Estonia          Antigua and Barbuda754.33 818.46 870.33 980.88  
13Latvia          Argentina129597.10 153129.48 183193.40 214241.20 262450.81 
14Lithuania          Armenia2807.06 3576.62 4900.44 6384.46 9204.47 
15Baltics          Aruba         
16Belarus          Australia455256.28 598485.57 674817.31 724359.12 820973.54 
17Belgium          Austria255276.53 293207.11 305098.88 323544.09 373192.00 
18Luxembourg          Azerbaijan7275.77 8680.41 13245.42 20982.24 31248.48 
19Netherlands          Bahamas, The5512.00 5650.00 5983.00 6237.00 6571.00 
20Benelux          Bahrain9747.60 11235.67 13460.20 15828.35  
21Deutschland6660000Deutschland666       

verwendete Formeln
Zelle Formel
B7 =WENN(ISTNV(VERGLEICH($A7;$G$5:$G$21;0));"";INDEX($G$5:$L$21;VERGLEICH($A7;$G$5:$G$21;0);VERGLEICH(B$1;$G$5:$L$5;0)))

Tabellendarstellung in Foren Version 4.17



cu jörg
ein feedback wär ganz reizend
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 12:27:11
einer
Hallo Jörg,
also entweder liegst am Wetter oder ich bin einfach zu blöd. Ich krieg das nicht hin. Tut mir leid, wenn ich dich nerve.
Bei mir ist immer alles leer. Ich werden nun noch mal die Datei anhängen, einmal in jpg, wie sie wirklich aussieht und einmal zusammen geschrumpft als xls Datei.
Die Leertasten habe ich jetzt alle gelöscht.
kannst du mir einfach die Formel so hinschreiben, dass ich die rauskopieren kann und einfügen. Vielleicht liegt das daran. Das ich sie nicht richtig editiere.
Hier die Originaltabelle
Userbild
Und hier die Tabelle als xls, hier habe ich alle nicht relevanten Spalten gelöscht.
https://www.herber.de/bbs/user/63948.xls
Ich hoffe, das ich es danach hinkriege, sonst werde ich es paar Hand übertragen müssen..
Danke für deine Gedult.
Thomas
Anzeige
AW: Zahlen von einer in eine andere Tabelle
20.08.2009 11:30:40
einer
Danke, für deine Arbeit, ich habe die Formel bei jetzt umgeformt für meine Tabelle. Das Problem, der zeigt mit gar nichts an. Also auch keine Fehlermeldung. Aber leider nicht den Wert den iich haben will.
Die formel sieht bei mir nun so aus:
=WENN(ISTNV(VERGLEICH($A$9;LÄNDER;0));"";INDEX(LÄNDER;VERGLEICH($A$9;LÄNDER;0);VERGLEICH(N3;LÄNDER;0) ))
Ich habe mittlerweile die Tabelle 2 in 1 reinkopiert und die Matrix "Länder" bennant.
Keine Ahnung warum es nicht funktioniert.
Danke noch mal.
Thomas
AW: Zahlen von einer in eine andere Tabelle
21.08.2009 15:31:15
einer
Danke danke danke,
es klappt endlich.

318 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige