Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl Zellen in Spalte dividiern durch Zahl | Herbers Excel-Forum


Betrifft: Anzahl Zellen in Spalte dividiern durch Zahl von: edie
Geschrieben am: 14.12.2009 22:16:54

Hallo zusammen,

die Spalte A mit Zahlen ist variabel lang, nun hätte ich gerne, dass die Anzahl der belegten
Zellen in Spalte A dividiert wird durch die Zahl in der Zelle C1 und in die Spalte B wird einfach eine 1 bzw. 2 u.s eingetragen.

Hier das Beispiel:

Spalte A C1 =2 C1=3 C1=4
33,0 1 1 1
5,0 1 1 1
8,2 1 1 1
7,4 1 1 1
3,2 1 1 1
3,4 1 1 1
10,0 1 1 1
2,4 1 1 2
2,6 1 1 2
2,1 1 1 2
2,4 1 2 2
22,0 1 2 2
3,3 1 2 2
4,7 1 2 2
33,0 1 2 3
5,5 2 2 3
23,0 2 2 3
6,6 2 2 3
2,0 2 2 3
2,8 2 2 3
4,3 2 3 3
2,7 2 3 3
3,9 2 3 4
6,0 2 3 4
4,2 2 3 4
3,0 2 3 4
1,0 2 3 4
3,4 2 3 4
2,9 2 3 4
1,4 2 3 4

Meine Frage wie kann man solch eine Aufgabe lösen?
Kann mir jemand dabei helfen?

Vielen Dank schon mal im Voraus.

Grüße

  

Betrifft: ich brauche mehr Details!!! oT von: Christian
Geschrieben am: 14.12.2009 22:22:47




  

Betrifft: =ANZAHL(A:A)/C1 von: {Boris}
Geschrieben am: 14.12.2009 22:24:26

Hi,

...das zumindest ist die Antwort auf Deine Frage

nun hätte ich gerne, dass die Anzahl (Zahlen) der belegten
Zellen in Spalte A dividiert wird durch die Zahl in der Zelle C1


Grüße Boris


  

Betrifft: =Anzahl(A:A)/C1 von: NoNet
Geschrieben am: 14.12.2009 22:23:00

Hallo Edie,

mit dieser Funktion kannst Du Deine Berechnung durchführen : =Anzahl(A:A)/C1

Das mit der Zahl 1,2 etc in Spalte B habe ich jedoch nicht kapiert... :-/

Gruß, NoNet


  

Betrifft: AW: =Anzahl(A:A)/C1 von: edie
Geschrieben am: 14.12.2009 22:32:12

Hallo Christian
Hallo NoNet,

wenn z. B. die Anzahl der Zelle in Spalte A 30 ist und in der Zelle C1 eine 2 steht, dann
sollen die ersten 15 Zellen in Spalte A eine 1 haben und die Zellen 16 bis 30 eine 2


wenn z. B. Zelle C1 eine 3 steht, dann
sollen die ersten 10 Zellen in Spalte A eine 1 haben die Zellen 11 bis 20 eine und die
Zellen 21 bis 30 eine 3.

Bei der Zahl 4 in der Zelle C1 soll durch 4 geteilt werden

Danke für die Hilfe

Grüße


  

Betrifft: Korrektur: in Spalte B von: edie
Geschrieben am: 14.12.2009 22:36:49

Hallo an Alle.

logisch in Spalte Bund nich in Spalte A sollen das Ergebnis stehen.

Grüße


  

Betrifft: Spalte B ist also wurscht - Arrayformel von: WF
Geschrieben am: 14.12.2009 22:30:42

Hi,

{=SUMME(WENN(ISTZAHL(C1:C99);(A1:A99)/(C1:C99)))}

Salut WF


  

Betrifft: AW: Anzahl Zellen in Spalte dividiern durch Zahl von: Josef Ehrensberger
Geschrieben am: 14.12.2009 22:44:16

Hallo edie,

so?

Tabelle3

 ABCD
110,913 
210,11  
36,11  
4291  
526,11  
633,81  
721,42  
821,42  
917,22  
1029,32  
11202  
1232,52  
139,52  
14303  
1527,63  
1623,43  
1716,53  
1812,23  
1924,13  
2010,63  
213,64  
22    
23    

Formeln der Tabelle
ZelleFormel
B1=GANZZAHL((ZEILE()/(ANZAHL(A:A)/$C$1)))+1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: es funktioniert, vielen Dank. von: edie
Geschrieben am: 14.12.2009 22:57:52

Hallo Sepp,

bin so froh, das es so prima funktioniert.

Herzlichen Dank.

Danke an Alle Helfer.

Grüße


Beiträge aus den Excel-Beispielen zum Thema "Anzahl Zellen in Spalte dividiern durch Zahl"