Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen in mehreren Spalten

Betrifft: Zählen in mehreren Spalten von: Tabea
Geschrieben am: 10.11.2014 16:11:23

Moin,

ich fuchse mich gerade ganz neu in Excel ein, komme nun aber irgendwie nicht weiter und würde mich freuen, hier Rat zu finden!

Ich habe eine eine Spalte D mit den drei Variablen 0, 1 und 2 sowie fünf Spalten (L, M, N, O, P) mit Variablen zwischen 0 und 18. Ich möchte nun wissen, wie häufig ich in den fünf Spalten L – P Werte zwischen 1 und 3 (also 1 oder 2 oder 3) habe, sofern ich in der ersten Spalte eine 1 habe.

Ich habe es bis jetzt mit diversen =zählenwenns versucht, aber mir scheinen die richtigen Befehle zu fehlen… Ich lese immer wieder etwas von =summenprodukt, aber ich will ja nichts multiplizieren oder addieren, sondern nur zählen, wieviele Einsen, Zweien und Dreien ich in den fünf Spalten L bis P habe, wenn in Spalte D eine Eins steht.

Wenn mir hier Jemand helfen könnte, wäre das ganz großartig! Vielen Dank im Voraus!
Tabea

  

Betrifft: AW: Zählen in mehreren Spalten von: ChrisL
Geschrieben am: 10.11.2014 16:36:54

Hi Tabea

Summenprodukt ist schon ok. In dieser Konstelation wird die Summe aus WAHR-Werten gebildet und entspricht somit der Anzahl.

=SUMMENPRODUKT((D:D=1)*(E:L<=3))~f~

Den Bereich solltest Du noch etwas eingrenzen, damit die Berechnung nicht zu lange dauert z.B.
~f~=SUMMENPRODUKT((D1:D100=1)*(E1:L100<=3))

cu
Chris


  

Betrifft: AW: Zählen in mehreren Spalten von: Tabea
Geschrieben am: 12.11.2014 08:39:23

Danke Chris, werd ich ausprobieren und mich dann wieder melden! Vielen Dank schon mal!!


  

Betrifft: AW: Zählen in mehreren Spalten von: Oberschlumpf
Geschrieben am: 10.11.2014 16:37:05

Hi Tabea

Und wenn du die Funktion ZÄHLENWENN probierst?

=ZÄHLENWENN("L:P";"1")

müsste als Ergebnis die Anzahl bringen, wie oft im Bereich "L:P" der Wert 1 verwendet wurde.

Anstelle von "L:P", was komplett alle Zeilen in "L:P" bedeutet, könntest du ja noch auf die Zeilen begrenzen, die wirklich genutzt werden.

Hilfts?

Ciao
Thorsten


  

Betrifft: AW: Zählen in mehreren Spalten von: Tabea
Geschrieben am: 12.11.2014 08:40:37

Hey Thorsten, ich glaub damit bekomm ich noch nicht ganz mein Ergebnis, aber ich tüftel nochmal ein bisschen... Trotzdem danke!!


  

Betrifft: AW: Zählen in mehreren Spalten von: Matze Matthias
Geschrieben am: 10.11.2014 16:39:18




Tabelle1

 QRS
1'Wert 1'Wert 2'Wert 3
2311

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
Q2=WENN($D2=1;ZÄHLENWENN($L2:$P2;1) )   =IF(RC4=1,COUNTIF(RC12:RC16,1) )
R2=WENN($D2=1;ZÄHLENWENN($L2:$P2;2) )   =IF(RC4=1,COUNTIF(RC12:RC16,2) )
S2=WENN($D2=1;ZÄHLENWENN($L2:$P2;3) )   =IF(RC4=1,COUNTIF(RC12:RC16,3) )

XHTML Tabelle für Darstellung in Foren,
einschl. Bedingter Formatierung ab Version 2007
XHTML-Version 11.50 einschl 64 Bit Version




Gruß Matze


  

Betrifft: AW: Zählen in mehreren Spalten von: Tabea
Geschrieben am: 12.11.2014 08:42:55

Hi Matze, vielen Dank - aber das versteh ich gerad auf den ersten Blick erstmal nicht. Aber ich schaus mir nochmal genauer an, vielleicht erschließt es sich mir noch! Danke!


  

Betrifft: Hier Muster so wie ich es verstanden habe von: Matze Matthias
Geschrieben am: 12.11.2014 16:31:16

Hallo Tabea,

grün hinterlegt zählt in Jeder Zeile (das was du wolltest)
blau hinterlegt würde ALLE Zeilen des Bereichs errechnen

https://www.herber.de/bbs/user/93719.xlsx

wenn das hier nicht richtig ist stell doch bitte eine Musterdatei ein
Gruß Matze


  

Betrifft: AW: Zählen in mehreren Spalten von: Tabea
Geschrieben am: 12.11.2014 08:34:21

Oh wow, vielen Dank! Das werd ich alles ausprobieren und mich dann wieder melden, vielen Dank!!!


 

Beiträge aus den Excel-Beispielen zum Thema "Zählen in mehreren Spalten"