Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählenwenn mit 7 Kriterien

Zählenwenn mit 7 Kriterien
17.01.2013 08:50:47
Peter
Guten Morgen,
in folgendem Formular habe ich über die Funktion Summenprodukt versucht, 7 Kriterien
zu setzen, was nicht klappt.
https://www.herber.de/bbs/user/83444.xlsx
Die Kriterien sehen wie folgt aus:
(A4:A33=1) oder (A4:A33=2) oder (A4:A33=6) oder (A4:A33=5555)
und (B4:B33>=C1) oder (B4:B33=1)
und (C4:C33>12)
Das kann man doch mit Summenprodukt ausdrücken, oder?
Vielen Dank für einen kleinen Denkanstoß!
Grüße
Peter

13
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zählenwenn mit 7 Kriterien
17.01.2013 09:02:08
Klaus
Hallo,
(A4:A33=1)*(A4:A33=2)
ergibt immer 0 !!
das prüft ja, ob in A4 gleichzeitig und gleichberechtigt 1 und 2 steht. Schrödingers Zelle, sozusagen.
Was willst du denn erreichen? Deine Formel ist formallogisch so falsch, dass ich nicht intuitiv erkennen kann WAS ausgerechnet werden soll.
Tip: Lad die Musterdatei nochmal hoch, aber diesmal färbe alle Zellen gelb die in der Rechnung beachtet werden sollen!
Grüße,
Klaus M.vdT.

AW: Zählenwenn mit 7 Kriterien
17.01.2013 09:13:20
Peter
Hallo Klaus,
ich versuche es nochmal anders auszudrücken:
=zählenwenn(A4:A33=1oder2oder6oder5555)und((B4:B33<C1)oder1)und(C4:C33>12)
oder anders gesagt:
Wenn Spalte A 1 oder 2 oder 6 oder 5555 wahr ist
UND Spalte B 1 oder kleiner C1 ist
UND Spalte C größer als 12 ist
DANN zähle 1.
https://www.herber.de/bbs/user/83446.xlsx
Danke nochmals.

Anzeige
AW: Zählenwenn mit 7 Kriterien
17.01.2013 09:21:37
Rudi
Hallo,
so?
=SUMMENPRODUKT((A4:A33={1.2.6.555})*(ODER(B4:B3312))
Gruß
Rudi

AW: Zählenwenn mit 7 Kriterien
17.01.2013 09:39:17
Peter
Hallo Rudi,
nein, leider auch nicht, dabei wird Spalte C mit Kriterium nicht beachtet und Spalte B
nicht gezählt, wenn der Wert 1 ist.
Gruß
Peter

AW: Zählenwenn mit 7 Kriterien
17.01.2013 09:45:47
Rudi
Hallo,
man sollte gucken, bevor man einen Beitrag abschickt.
Irgendwie hat die Forensoftware meine Formel gekürzt.
=SUMMENPRODUKT((A4:A33={1.2.6.555})*(ODER(B4:B33<C1;B4:B33=1))*(C4:C33>12))
Gruß
Rudi

AW: Zählenwenn mit 7 Kriterien
17.01.2013 09:56:57
Peter
Die Funktion (ODER(B4:B33<C1;B4:B33=1))~f~ funktioniert hier irgendwie nicht:
Wenn ich bei ~f~B4:B33=1 aus der 1 eine 2 oder 3 mache, ändert das am Ergebnis nichts.
Dann müsste aber eigentlich 0 rauskommen.
Hier vielleicht noch eine Idee?
Danke.

Anzeige
AW: Zählenwenn mit 7 Kriterien
17.01.2013 10:06:06
Rudi
Hallo,
ändert das am Ergebnis nichts.
natürlich nicht.
Weil 3 kleiner C1 (201105) ist. Ergo ist B4:B33<C1 WAHR.
Gruß
Rudi

AW: Zählenwenn mit 7 Kriterien
17.01.2013 10:48:57
Peter
Klar, da hast Du recht. Habe das Argument B4:B33=1 jetzt gelöscht.
Ich bekomme zwar noch nicht die richtigen (erwarteten) Ergebnisse, aber die Formel funktioniert an sich.
Wenn ich jetzt noch ein Kriterium Spalte D größer 0 integrieren will, würde ich das so schreiben:
=SUMMENPRODUKT((A4:A33={1.2.6.555})*(ODER(B4:B33<C1)*(C4:C33>12)*(D4:D33>0)))
Das klappt aber nicht. Kann ich die Kriterien nicht beliebig hinzuschreiben?
Danke.

Anzeige
SUMMENPRODUKT ohne ODER
17.01.2013 11:02:46
Erich
Hi Peter und Rudi,
ein Problem ist wohl das ODER in der Matrixfkt. SUMMENPRODUKT.
ODER gibt nicht einen Vektor mit 30 Werten (für 4:33) zurück, sondern nur einen einzigen Wert.
Ein neuer Versuch:
 E
31
4 

Formeln der Tabelle
ZelleFormel
E3=SUMMENPRODUKT(((A4:A33=1)+(A4:A33=2)+(A4:A33=6)+(A4:A33=555))*((B4:B33<C1)+(B4:B33=1)>0)*(C4:C33>12))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
SUMMENPRODUKT ohne ODER kürzer
17.01.2013 11:14:34
Erich
Hi,
das passt wohl auch:
 E
41
5 

Formeln der Tabelle
ZelleFormel
E4=SUMMENPRODUKT((A4:A33={1.2.6.555})*((B4:B33<C1)+(B4:B33=1)>0)*(C4:C33>12))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
AW: SUMMENPRODUKT ohne ODER kürzer
17.01.2013 11:31:19
Peter
Hallo Erich,
das probiere ich gleich direkt aus.
Wenn ich jetzt noch ein Kriterium Spalte D größer 0 integrieren will, würde ich das so schreiben, das klappt allerdings nicht so recht:
=SUMMENPRODUKT((A4:A33={1.2.6.555})*(ODER(B4:B33<C1)*(C4:C33>12)*(D4:D33>0)))~f~
Wie kann ich das Kriterium ~f~(D4:D33>0) in deine Funktion noch einbauen?

OHNE ODER ! owT
17.01.2013 12:58:15
Erich

Neuer Versuch
17.01.2013 16:50:16
Erich
Hi Peter,
bei etwas genauerem Hinsehen ist mir aufgefallen, dass du einen Apfel (C1) mit Birnen (B4:B33) vergleichst.
C1 ist eine Zahl, in Spalte B stehen aber Texte (standardmäßig linksbündig angezeigt).
Du musst dich entscheiden: Entweder C1 auch Text oder Zahlen in Spalte B.
Im Beispiel habe ich mal ein paar Zahlen in Spalte B geschrieben:
 ABCDE
1  201105 WAHR
2     
3RotGelbBlau 3
4110 2
561495,691 
612012110 FALSCH
7220110413 WAHR
82201103131FALSCH
92201103131WAHR
1012012100 FALSCH

Formeln der Tabelle
ZelleFormel
E1=ISTZAHL(C1)
E3=SUMMENPRODUKT((A4:A33={1.2.6.555})*((B4:B33<C1)+(B4:B33=1)>0)*(C4:C33>12))
E4=SUMMENPRODUKT((A4:A33={1.2.6.555})*((B4:B33<C1)+(B4:B33=1)>0)*(C4:C33>12)*(D4:D33>0))
E6=ISTZAHL(B6)
E7=ISTZAHL(B7)
E8=ISTZAHL(B8)
E9=ISTZAHL(B9)
E10=ISTZAHL(B10)

Zeile 7 erfüllt die Bed. in E3, aber nicht die in E4.
Zeile 8 witrd nicht gezählt, weil in B8 Text steht.
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige

314 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige