Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählen wenn mit 3 Spalten

Zählen wenn mit 3 Spalten
Heinz
Hallo Liebe Excellenten,
ich habe gerade einen Blackout (vielleicht liegt's an der Hitze) ;-)
Ich habe Drei Spalten.
In den Zellen darunter ist jeweils eine 0 oder eine 1.
Ich möchte die Anzahl der Zeilen wissen, in denen entweder
in Spalte1 oder in Spalte2 oder in Spalte3 eine 1 steht.
Könnt Ihr mir helfen? (bestimmt).
Hilfsspalte würde gehen, aber ich möchte gerne was dazulernen.
Meine Versuche kreisen um die Formeln
Zählenwenns und Summe(wenn "mit einer ODER Funktion".
Aber irgendiwe gehts nicht.
Ich freue mich auf Eure Lösungen.
Heinz
AW: Zählen wenn mit 3 Spalten
19.06.2012 15:19:41
bibo
Hallo Heinz,
nach Deinen Vorgaben kann die "1" ja nur 1 x je Zeile vorkommen.
Deshalb sollte z.B. =ZÄHLENWENN(A:C;1) ausreichend sein.
Wenn nicht die ganzen Spalten erfasst werden sollen, vergib einen Bereichsnamen, der die die nicht gewünschten Zellen ausschliesst.
Gruß
Bibo
AW: Zählen wenn mit 3 Spalten
19.06.2012 15:51:59
Heinz
Hallo Bibo,
ggf. habe ichs nicht richtig beschrieben.
In den 3 Spalten können in einer Zeile
alle möglichen Kombinationen aus 0 und
1 vorkommen, also auch mehrmals die
1.
Heinz
Nimm den lösungsvorschlag von bibo,...
19.06.2012 16:16:30
bibo,...
Hallo Heinz,...
 ABCD
11113
20112
30011
41012
51102
60101
71001
80000

Formeln der Tabelle
ZelleFormel
D1=ZÄHLENWENN($A1:$C1;1)
D2=ZÄHLENWENN($A2:$C2;1)
D3=ZÄHLENWENN($A3:$C3;1)
D4=ZÄHLENWENN($A4:$C4;1)
D5=ZÄHLENWENN($A5:$C5;1)
D6=ZÄHLENWENN($A6:$C6;1)
D7=ZÄHLENWENN($A7:$C7;1)
D8=ZÄHLENWENN($A8:$C8;1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matze
Anzeige
AW: Nimm den lösungsvorschlag von bibo,...
19.06.2012 16:30:00
bibo,...
Hallo Matthias,
nein, nehme ich nicht ;-)
Ich will die Anzahl der Zeilen wissen, nicht die Zellen.
In deinem Beispiel wäre es 7 Zeilen, in denen mindestens
1x eine 1 drin steht.
Wie gesagt mit einer Hilfsspalte wäre es einfach, aber es muss doch auch
eine Lösung ohne geben.
Heinz
AW: Nimm den lösungsvorschlag von bibo,...
19.06.2012 16:59:42
bibo,...
Hallo Heinz,
In D1:
Zählenwenn($A$1:$C$100=1)
Gruß
Rentner Walter
AW: Nimm den lösungsvorschlag von bibo,...
19.06.2012 17:01:41
bibo,...
 ABC
1444
2111
3011
4001
5101
6110
7010
8100
9000

Formeln der Tabelle
ZelleFormel
A1=ZÄHLENWENN(A2:A9;1)
B1=ZÄHLENWENN(B2:B9;1)
C1=ZÄHLENWENN(C2:C9;1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Dann anners rum,..
Anzeige
papperlapapp - Du benötigst ne Arrayformel
19.06.2012 17:59:14
WF
Hi,
"Nimm den lösungsvorschlag von bibo,..." ist Quatsch.
{=SUMME(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1:C1;ZEILE(1:99)-1;);1);1))}
siehe unsere:
http://www.excelformeln.de/formeln.html?welcher=46
Salut WF
AW: papperlapapp - Du benötigst ne Arrayformel
20.06.2012 11:53:41
Heinz
Hallo WT,
endlich jemand, der meine Aufgabenstellung
genau erfasst hat. Sieht gut aus.
Warum geht das eigentlich nur mit
"Bereich.verschieben" und nicht mit einer
normalen Namensgebung für den Bereich?
Ich Danke Dir auf jeden Fall für Deine Lösung
und wünsche einen schönen Tag.
Heinz
Anzeige

330 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige