Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn mit unterschiedlichen Bereichen

Betrifft: Zählenwenn mit unterschiedlichen Bereichen von: Chris
Geschrieben am: 15.09.2014 13:19:09

Hallo zusammen,

ich suche jetzt schon vergebens nach einer Lösung für folgendes Problem:

Ich habe Sales-Daten für Produkte (nach Zeilen) pro Tag (Spalten). Für diese möchte ich Mittelwerte errechnen - ABER erst ab dem Tag, ab dem ein erster Sales erkennbar ist. Also müsste sich der Zählenwenn-Bereich entsprechend verschieben.
Wäre klasse wenn hier jemand eine Idee hätte.

Tausend Dank!

Chris

https://www.herber.de/bbs/user/92632.xlsx

  

Betrifft: AW: Zählenwenn mit unterschiedlichen Bereichen von: Rudi Maintaire
Geschrieben am: 15.09.2014 13:47:22

Hallo,
wo ist der Unterschied?

CDEFGHIJ
113.04.201414.04.201415.04.201416.04.201417.04.201418.04.2014  
200101233

ZelleFormel
I2=ZÄHLENWENN(C2:H2;">0")
J2=ZÄHLENWENN(E2:H2;">0")


Gruß
Rudi


  

Betrifft: AW: Zählenwenn mit unterschiedlichen Bereichen von: Chris
Geschrieben am: 15.09.2014 13:56:18

Hi Rudi,

und danke. Stimmt, das macht so wenig Sinn. Es geht mit prinzipiell darum die Zellen mit Null auch in die MIttelwert-Betrachtung einflißen zu lassen, aber erst ab dem ersten Wert ungleich Null.
In Deinem Bsp-Fall würde ich also gerne ein "4" sehen. Ist das irgendwie möglich?

Danke!


  

Betrifft: AW: Zählenwenn mit unterschiedlichen Bereichen von: Rudi Maintaire
Geschrieben am: 15.09.2014 14:20:50

Hallo,

CDEFGHI
113.04.201414.04.201415.04.201416.04.201417.04.201418.04.2014Mittelwert
20010121,00
30222011,40
43322222,33

ZelleFormel
I2{=SUMME(C2:H2)/ANZAHL(INDEX(C2:H2;MIN(WENN(C2:H2>0;SPALTE(A2:F2);""))):H2)}
I3{=SUMME(C3:H3)/ANZAHL(INDEX(C3:H3;MIN(WENN(C3:H3>0;SPALTE(A3:F3);""))):H3)}
I4{=SUMME(C4:H4)/ANZAHL(INDEX(C4:H4;MIN(WENN(C4:H4>0;SPALTE(A4:F4);""))):H4)}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.


Gruß
Rudi


  

Betrifft: AW: Zählenwenn mit unterschiedlichen Bereichen von: Chris
Geschrieben am: 15.09.2014 14:44:34

Ja Wahnsinn! Super! Es klappt!
Besten Dank, Rudi!


 

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mit unterschiedlichen Bereichen"