Microsoft Excel

Herbers Excel/VBA-Archiv

ZÄHLENWENN mit Zusatzkriterium

Betrifft: ZÄHLENWENN mit Zusatzkriterium von: Michi
Geschrieben am: 22.09.2014 10:28:53

Hallo,

in Erweiterung meines bereits heute morgen gestellten Problems (https://www.herber.de/forum/messages/1382790.html) möchte ich nun in einer Personenliste zählen, wie häufig eine bestimmte Punktzahl erreicht wurde, wobei das nach Geschlecht aufgeschlüsselt werden soll.

https://www.herber.de/bbs/user/92744.xlsx

Bei der Formel aus dem vorherigen Beitrag {=MAX(WENN(B2:B12="m";C2:C12))} müsste jetzt ja so etwas rein wie ZÄHLENWENN, allerdings bekomme ich das mit den Argumenten nicht ganz hin.

Könnt Ihr mir auch hierbei helfen?

Viele Grüße
Michi

  

Betrifft: AW: ZÄHLENWENN mit Zusatzkriterium von: Hajo_Zi
Geschrieben am: 22.09.2014 10:32:25

Hallo Michi,


Tabelle1

 CDE
14Punktemw
15000
16101
17201
18320
19401
20510
21611
22711
23810
24900
251000

verwendete Formeln
Zelle Formel Bereich N/A
D15:E25=ZÄHLENWENNS($B$2:$B$12;D$14;$C$2:$C$12;$C15)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.13 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: ZÄHLENWENN mit Zusatzkriterium von: Daniel
Geschrieben am: 22.09.2014 10:36:29

Hi
da hast du ein Zählen mit mehrern Bediungungen (Punktzahl, Geschlecht).
dazu gibts seit Excel 2007 die Funktion ZählenWenns:

für dein Beispiel folgende Formel lin D15 und dann nach rechts und nach unten ziehen

=ZÄHLENWENNS($B$2:$B$12;D$14;$C$2:$C$12;$C15)
Gruß Daniel


  

Betrifft: Vielen Dank! von: Michi
Geschrieben am: 22.09.2014 11:06:43

Mal wieder bin ich begeistert, wie schnell und wie passend Ihr antwortet!

Vielen Dank an Daniel und Hajo!
Die ZÄHLENWENNS-Funktion war mir neu.


 

Beiträge aus den Excel-Beispielen zum Thema "ZÄHLENWENN mit Zusatzkriterium"