Microsoft Excel

Herbers Excel/VBA-Archiv

Maximum ermitteln unter Kriteriumsberücksichtigung

Betrifft: Maximum ermitteln unter Kriteriumsberücksichtigung von: Michi
Geschrieben am: 22.09.2014 08:46:41

Hallo alle zusammen,

in einer Personenliste stehen hinter jedem Namen in den Spalten je Geschlecht ("m" oder "w") und erreichte Punkte.

https://www.herber.de/bbs/user/92743.xlsx

Nun möchte ich gerne mit Formeln geschlechtergetrennt auswerten, z. B. das Maximum der erreichten Punkte oder den Mittelwert bei den Frauen und bei den Männern. Mit den bisherigen Ansätzen (wenn(B2="w";max(C:C);...)) war ich leider nicht erfolgreich

Könnt Ihr mir helfen?

Viele Grüße
Michi

  

Betrifft: AW: Maximum ermitteln unter Kriteriumsberücksichtigung von: hary
Geschrieben am: 22.09.2014 08:59:15

Moin Michi



Tabelle1

 BC
15Maximum Männer456
16Maximum Frauen642
17Durchschnitt Männer326,5
18Durchschnitt Frauen474,6

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C15{=MAX(WENN(B2:B12="m";C2:C12))}$C$15 =MAX(IF(R[-13]C[-1]:R[-3]C[-1]="m",R[-13]C:R[-3]C))
C16{=MAX(WENN(B2:B12="w";C2:C12))}$C$16 =MAX(IF(R[-14]C[-1]:R[-4]C[-1]="w",R[-14]C:R[-4]C))
C17{=MITTELWERT(WENN(B2:B12="m";C2:C12))}$C$17 =AVERAGE(IF(R[-15]C[-1]:R[-5]C[-1]="m",R[-15]C:R[-5]C))
C18{=MITTELWERT(WENN(B2:B12="w";C2:C12))}$C$18 =AVERAGE(IF(R[-16]C[-1]:R[-6]C[-1]="w",R[-16]C:R[-6]C))
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: Danke, mal wieder hervorragend gelöst! von: Michi
Geschrieben am: 22.09.2014 10:15:27

Danke, mal wieder hervorragend gelöst!


 

Beiträge aus den Excel-Beispielen zum Thema "Maximum ermitteln unter Kriteriumsberücksichtigung"