Microsoft Excel

Herbers Excel/VBA-Archiv

Datum der nächsten Lottoziehung ermitteln

Betrifft: Datum der nächsten Lottoziehung ermitteln von: Howard
Geschrieben am: 30.11.2013 09:26:14

Hallo,
ich möchte das Datum ermitteln, an dem die nächste Lottoziehung ist und habe eine
Tabelle angelegt, die aus 2 Spalten besteht:
A B
Samstag 0
Sonntag 3
Montag 2
Dienstag 1
Mittwoch 0
Donnerstag 2
Freitag 1

Der Wert in B gibt an, wieviele Tage noch bis zur nächsten Ziehung.

Habe nun in Feld C1 mit =HEUTE() das aktuelle Datum ermittelt und benutzerorientiert so formatiert, daß nur der Wochentag angezeigt wird.

Nun hatte ich vor mit =SVERWEIS(C1;A1:B7;2) den Wert der zweiten Spalte zu
ermitteln, um dann diesen zum Tageswert des heutigen Datums zu addieren und
das Ergebnis zum Schluß als Tagesdatum , formatiert ( Wochentag, TT.MM.JJJJ)
anzeigen zu lassen.

In Feld C1 erscheint aber #NV.

Deshalb 1.) Wo liegt der Fehler?
2.) Kennt jemand eine bessere Lösung für die Aufgabenstellung?

Für Eure Mühe jetzt schon mal ein Danke im vorhinein.


  

Betrifft: AW: Datum der nächsten Lottoziehung ermitteln von: Marcy
Geschrieben am: 30.11.2013 09:44:00

Hi,

ermittel doch mit =TEXT(C1;"TTTT") den Wochentag und rechne damit weiter

Gruß Marcy


  

Betrifft: Datum nächste Lottoziehung von: Erich G.
Geschrieben am: 30.11.2013 09:47:59

Hi,
du vermengst da ein wenig Zellformat und Zellwert.

In Spalte A stehen bei dir (vermutlich) Texte: Montag, ...
In C1 steht ein Datum. Das ist ein Zahl - wie auch immer die Zelle formatiert ist.

=SVERWEIS(C1;A1:B7;2) witrd immer #NV sein, da du eine Zahl (ein Datum) unter Texten suchst.
Das ist unabhängig von der Anzeige, der Formatierung der Zelle.

Zu 2. mein Vorschlag:

 AB
1heutenext Lotto
2Sa  30.11.13Sa  30.11.13
3So  01.12.13Mi  04.12.13
4Mo  02.12.13Mi  04.12.13
5Di  03.12.13Mi  04.12.13
6Mi  04.12.13Mi  04.12.13
7Do  05.12.13Sa  07.12.13
8Fr  06.12.13Sa  07.12.13
9Sa  07.12.13Sa  07.12.13
10So  08.12.13Mi  11.12.13

Formeln der Tabelle
ZelleFormel
B2=A2+REST(REST(-A2-3;7); 4)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Datum nächste Lottoziehung von: Howard
Geschrieben am: 30.11.2013 14:55:30


Hallo Erich,

ich hatte zuerst die Wochentage in der A-Spalte ermittelt durch =HEUTE() ( = Samstag), =HEUTE()+1
bis =HEUTE()+6 , und hab dann eben eine Formatierung vorgekommen, war mir aber bewußt, daß da ein
Zahlenwert in den Zellen steht. Wollte nun den entsprechenden Zahlen aus der B-Spalte dazuaddieren.

Hab REST bisher immer nur verwendet, um zwischen geraden und ungeraden Werten zu unterscheiden und
wär da alleine auf Deine Formel nie gekommen. Die 3 steht ja wohl für den Max-Wert aus B, der Divisor 7
für die Anzahl der Wochentage und die 4 für die Anzahl verschiedener Werte in B.

Hast Du vielleicht noch ein anderes Beispeil, in dem die REST-Funktion so oder so ähnlich zur
Anwendung kommt?

Gruß Howard




  

Betrifft: AW: Datum nächste Lottoziehung von: Ralf P.
Geschrieben am: 01.12.2013 00:34:56

Hallo,

REST ist die Formel-Variante von Modulo (gibt des ganzzahligen Rest einer Division zurück, so wie man das bei der schriftlichen division macht)

tipp mal =rest( in die bearbeitungszeile, drücke auf den button links davon "fx"
da kommt der assi, links unten auf "Hilfe für diese Funktion"

das wird alles fein säuberlich erklärt ;)

Gruß
Ralf


  

Betrifft: RESTe-Formel von: Erich G.
Geschrieben am: 02.12.2013 14:23:31

Hi Howard,
deine Vermutungen zur Formel stimmen nur teilweise.

Der Divisor 7 ist natürlich die Anzahl der Wochentage.

Die -3 hat keine besondere Bedeutung, lässt sich durch andere, z. B. (4), ersetzen.
Mit -3 oder 4 wird nur erreicht, dass der Mittwoch als 7er-Divisionsrest die 0 bekommt (Zelle B6).

Zu der 4 könnte man sagen, dass zu heute immer nur 0, 1, 2 oder 3 Tage addiert werden bis zum Lotto-Tag.
Mit REST(...;4) werden aus den 7er-Resten 6, 5 und 4 die Zahlen 2, 1 und 0. (vgl. Zellen B7:B9)
Die 7er-Reste 3, 2, 1 und 0 bleiben unverändert.

Statt
=A2+REST(REST(-A2-3;7);4)
kann man einfacher schreiben
=A2+REST(REST(4-A2;7);4)

Es hat keinen Einfluss auf das Resultat, wenn man bei der Zahl Vielfache von 7 addiert oder subtrahiert.
(siehe Zeilen 13:14)

 ABCDE
1heutemod 7mod 4zusamnext Lotto
2Sa  30.11.13400Sa  30.11.13
3So  01.12.13333Mi  04.12.13
4Mo  02.12.13222Mi  04.12.13
5Di  03.12.13111Mi  04.12.13
6Mi  04.12.13000Mi  04.12.13
7Do  05.12.13622Sa  07.12.13
8Fr  06.12.13511Sa  07.12.13
9Sa  07.12.13400Sa  07.12.13
10So  08.12.13333Mi  11.12.13
11     
12 allesistgleich 
13Sa  30.11.13444 
14 444 

Formeln der Tabelle
ZelleFormel
B2=REST(4-A2;7)
C2=REST(B2;4)
D2=REST(REST(4-A2;7); 4)
E2=A2+D2
B13=REST(4-A13;7)
C13=REST(11-A13;7)
D13=REST(18-A13;7)
B14=REST(-3-A13;7)
C14=REST(-10-A13;7)
D14=REST(-17-A13;7)

In Spalte D sind genau die Zahlen 3,2,1,0 berechnet, die du in deinem Eingangspost geschrieben hast. :-)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


 

Beiträge aus den Excel-Beispielen zum Thema "Datum der nächsten Lottoziehung ermitteln"