Microsoft Excel

Herbers Excel/VBA-Archiv

Lieferdatum ermitteln

Betrifft: Lieferdatum ermitteln von: PeMoe
Geschrieben am: 07.11.2014 09:03:25

Hallo zusammen,

dieses Mal suche ich Hilfe für ein "Tool", welches den Liefertag einer Bestellung errechnet und dabei verschiedene Rahmenbedingungen berücksichtigt.

Der Ausgangspunkt der Berechnung ist der Tag der Anforderung. Anforderungen können an jedem Wochentag entstehen. Der Tag der Anforderung sollte als Datum eingegeben werden.
Anforderungen werden zwei Mal pro Woche, immer Dienstags und Donnerstags beim Lieferanten bestellt. Die Dauer von Anforderung bis Bestellung ist der erste zu ermittelnde Zeitraum.
Von Bestellung bis Anlieferung am Lager ist mit einer festen Lieferzeit von 5 Tagen zu rechnen. Dies ist der zweite Zeitraum.
Die letztendliche Auslieferung an den Anforderer erfolgt immer am Montag, Mittwoche und Freitag. Zeitraum drei ist also von Anlieferung am Lager bis Auslieferung an Anforderer.
Im Ergebnis sollte die Dauer von Anforderung bis Auslieferung in Tagen ausgegeben werden.

Ganz toll wäre es, wenn man die Bestelltage (aktuell Dienstag und Donnerstag) und die Ausliefertage (aktuell Montag, Mittwoch und Freitag) flexibel vor der Berechnung "einstellen" könnte.

Hat jemand Zeit und Lust sich mit dieser Fragestellung zu befassen?

Vielen Dank!

PeMoe

  

Betrifft: AW: Lieferdatum ermitteln von: Christian
Geschrieben am: 07.11.2014 11:37:15

Hallo,
so zB:

 ABC
1 DatumDauer
2Anforderung:Fr  07.11.2014 
3Bestellung:Di  11.11.20144
4Lager:So 16.11.20145
5Auslieferung:Mo 17.11.20141
6Gesamt-Dauer: 10

Formeln der Tabelle
ZelleFormel
B3=VERWEIS(WOCHENTAG(B2); {1.2.3.4.5.6.7};{2.1.0.1.0.4.3})+B2
C3=B3-B2
B4=B3+5
C4=B4-B3
B5=VERWEIS(WOCHENTAG(B4); {1.2.3.4.5.6.7};{1.0.1.0.1.0.2})+B4
C5=B5-B4
C6=SUMME(C3:C5)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Erläuterung zu den Verweisfunktionen:
das erste Array enthält die Wochentage 1-7 (So-Sa), das zweite Array den jeweiligen Versatz bis zur Bestellung bzw. Auslieferung.

Alternativ mit verschachteten WENN-Funktionen...

Gruß
Christian


  

Betrifft: AW: Lieferdatum ermitteln von: PeMoe
Geschrieben am: 07.11.2014 11:59:19

Hallo Christian,
vielen Dank für Deine Lösung!
Ich habe noch vergessen zu beschreiben, dass das Lager am Samstag und am Sonntag geschlossen ist und somit Anlieferungen erst am darauf folgenden Montag erfolgen.
Wie könnte ich Deine Lösung entsprechend anpassen?

Gruß
PeMoe


  

Betrifft: AW: Lieferdatum ermitteln von: PeMoe
Geschrieben am: 07.11.2014 12:05:33

Hat sich erledigt, habe es hin bekommen.
Danke nochmal!

PeMoe


 

Beiträge aus den Excel-Beispielen zum Thema "Lieferdatum ermitteln"