Microsoft Excel

Herbers Excel/VBA-Archiv

Währungsfaktoren ermitteln | Herbers Excel-Forum


Betrifft: Währungsfaktoren ermitteln von: Excel
Geschrieben am: 21.12.2009 14:34:53

Hallo,
ich benötige Hilfe/Tips für diese Aufgabe:

Eine Mappe mit mehreren Blättern, hier z.B. Preislisten.
Auf jedem Blatt gibt es eine Zelle, in der mittels Auswahlliste eine Währung ausgewählt werden kann.
Alle verfügbaren Währungen sind nebst Umrechnungsfaktor auf einem sepearaten Blatt gespeichert.
Der Bereich ist benannt und der Faktor kann mittels SVERWEIS aus diesem Bereich ermittelt werden.

Die SVERWEIS-Formel soll nun in einem tabellenweit gültigen NAMEN gekapselt werden, um Zellformel nicht unnötig "aufzublähen".

Problem: Der Name soll sich auf das jeweilige Tabellenblatt beziehen, sprich die der dort angegebene Währung verwenden.

Danke für Tips bzw. andere Lösungsmöglichkeiten.

  

Betrifft: AW: Währungsfaktoren ermitteln von: Mike
Geschrieben am: 21.12.2009 14:41:27


Hey Unbekannter,

ein Gruss und realer Name am Schluss machen Dein Anliegen bei uns freundlicher .. ;-)

Im Prinzip musst Du ja nur für den Währungsbereich den Namen vergeben und mit
dem kannst Du dann arbeiten.

Ansonsten umschreib es nochmals.

Gruss
Mike


  

Betrifft: AW: Währungsfaktoren ermitteln von: Excel
Geschrieben am: 21.12.2009 14:52:31

Danke für die schnelle Antwort.
Soweit wie beschrieben ist schon alles klar:
Der "Währungsbereich" hat einen Namen: "currencies"
Der jeweilige Umrechnungsfaktor wird ermittelt: =SVERWEIS($B$2;currencies;2)

Problem: wenn ich diese Formel einem Namen zuweise, dann bezieht sich die Formel in diesem Namen immer auf EIN (fixes) Tabellenblatt. Der Bezug soll aber für das jeweilige Blatt gelten

/Frank


  

Betrifft: ...d.h. wohl für alle Blätter?! Dann musst... von: Luc:-?
Geschrieben am: 21.12.2009 15:06:16

...du, Frank,
den TabBlattNamen im Bezug des Namens löschen und nur ! stehen lassen (so war's vorher), da du aber über xl12 verfügst, kannst du die Namensgültigkeit im Erstellungsmenü festlegen. Probiere das mal durch!
Gruß Luc :-?


  

Betrifft: AW: ...d.h. wohl für alle Blätter?! Dann musst... von: Excel
Geschrieben am: 21.12.2009 15:22:25

Wunderbar! Dein Tip mit dem ! ist die Lösung.
Ich habe das bisher immer mit weggelöscht.

Mit der Gültigkeit in xl12 geht das auch nicht anders :-(

/Frank


  

Betrifft: wie .. für alle Blätter von: Mike
Geschrieben am: 21.12.2009 15:35:16


Hey Luc,

Dein Tipp hat mich "gluschtig" gemacht. Wie soll das genau funktionieren?
Danke für die ergänzende Erklärung.

Gruss
Mike


  

Betrifft: So wie ich es beschrieben habe! Der Name... von: Luc:-?
Geschrieben am: 21.12.2009 18:30:39

...bezieht sich dann stets auf das jeweilige Blatt, Mike.
Beim Kopieren von Blättern mit Bereichsnamen wird/wurde man gefragt, ob der Name für die ganze Mappe gelten solle. Je nach Antwort wurde dann unterschiedl in der Namensliste signiert. Beim notgedrungenen Versuch, das nachträgl zu ändern, bin ich auf diese Lösung gekommen, die aber wahrscheinl nicht der eigentl Standard ist...
Gruß Luc :-?


  

Betrifft: AW: Währungsfaktoren ermitteln von: Tino
Geschrieben am: 21.12.2009 15:10:12

Hallo,
meinst Du so, Kursliste einfach erweitern, sollte sich alles anpassen.

https://www.herber.de/bbs/user/66746.xls

Gruß Tino


  

Betrifft: AW: Währungsfaktoren ermitteln von: Excel
Geschrieben am: 21.12.2009 15:25:36

Danke für deine Beispiel-Tabelle, Tino.
Ich ermittle den Faktor aber mit SVERWEIS, finde ich einfacher.
=SVERWEIS($B$2;currencies;2)
"currencies" ist dabei schon ein dynamischer Bereich.

Das Problem mit den Namensbezügen hat Luc perfekt gelöst.

/Frank


  

Betrifft: viele Wege führen nach Rom ;-) oT. von: Tino
Geschrieben am: 21.12.2009 15:46:12




Beiträge aus den Excel-Beispielen zum Thema "Währungsfaktoren ermitteln"