Werte durch 2 varialble Bedingungen ermitteln



Excel-Version: 2000 (9.0)
  

Matrixformel

von: mathias r.
Geschrieben am: 15.04.2002 - 13:01:15


Da wird dir hoffentlich eine Matrixformel weiterhelfen (mit STRG+SHIFT+ENTER eingeben.
Folgendes Beispiel kannst du für dich adaptieren:


MS Excel von mathias r. an Udo
 ABCDE
1Walter  01.01.0208:0009:00
2Fresco  01.01.0208:0109:01
3Cohaus  01.01.0208:0209:02
4Walter  02.01.0208:0309:03
5Fresco  02.01.0208:0409:04
6Cohaus  02.01.0208:0509:05
7Walter  03.01.0208:0609:06
8Fresco  03.01.0208:0709:07
9Cohaus  03.01.0208:0809:08
10    
11    
12  01.Jan01.Jan 
13  VonBis 
14Cohaus08:0209:02 
15Walter08:0009:00 
16    
17FürB14:=SUMME(($A$1:$A$9=A14)*($C$1:$C$9=B12)*$D$1:$D$9)  

nach unten

Betrifft: Werte durch 2 varialble Bedingungen ermitteln
von: Udo
Geschrieben am: 14.04.2002 - 14:38:56

Hallo Experten,

Wie kann ich einen Wert auslesen, der durch 2 Bedingungen gefunden werden muß?
in dem Tabellenblatt "Liste" in Spalte A4:A100 Stehen Namen, in Spalte C4:C100 steht das Datum, in Spalte D4:D100 und E4:E100 stehen die Zeitangaben die ich im Tabellenblatt "Druck" einfügen lassen will.

Da die Namen im Tabellenblatt "Liste" aber zudem auch noch mehrfach vorkommen können, habe ich sie in der Tabelle "Filter" auf 1 mal pro Namen reduziert (Filteroption in Excel), und im Tabellenblatt "Aussuchen" die entsprechenden Datums hinter den dazugehörigen Namen eintragen lassen (mit Sverweis).

Die vorkommenden Datumsangaben sind immer auf eine Kalenderwoche reduziert.( wegen der Druckausgabe)

Zum besseren Verständnis hab ich Euch die Screenshots von "liste", "Druck", "Filter" und "Aussuchen" unter "http://www.ergste.de/excel/" mal hinterlegt, damit Ihr Euch ein Bild meines Problems machen könnt.

Seit 2 Wochen, 3 Excel-Büchern inkl. VBA, eine genervte Freundin und einen wirklich (inzwischen) hoffnungslosen User,
versuch ich es mal hier bei Euch Experten.


Im Voraus vielen Dank und Gruß
Udo

P.s. Habe auch schon ALLE Beiträge im Forum und im Archiv durchstöbert, leider ohne Erfolg.


Eine andere Lösung wäre auch, wenn ich im Tabellenblatt "Aussortieren" alle Datums des entsprechenden Namens in einer Reihe bekommen würde (klappt leider nicht mit sverweis).

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Werte durch 2 varialble Bedingungen ermitteln"