Microsoft Excel

Herbers Excel/VBA-Archiv

doppelte Wörter

Betrifft: doppelte Wörter von: Herbert Gius
Geschrieben am: 18.08.2008 09:10:55

Hallo zusammen,

ich haben von verschiedenen Abteilungen Adressen bekommen - ca. 5000 - die ich bereinigen muss. Da einmal Franz Mayr und einmal Mayr Franz stehen kann, komme ich mit =Wenn(Zählenwenn......) nicht weiter. Kann mir bitte jemand sagen, wie ich es anstellen kann, dass auf der Tabelle "Adressen" die Zellen mit Mayr und die Zellen mit Franz als doppelt erkannt und in der Tabelle "Dublikate", mit Angabe der Zelle von Tabelle "Adressen", aufgelistet werden.

Danke für die Hilfe und noch einen schönen Tag

Herbert

  

Betrifft: AW: doppelte Wörter von: Tino
Geschrieben am: 18.08.2008 10:02:29

Hallo,
bin zwar nicht der Formelexperte aber manchmal versuche ich mich darin.

Kannst du damit etwas anfangen?

 ABCD
1 Hilfsspaltedoppelt in Zeiledoppelter Name
2Franz Mayr25Mayr Franz
3Muster Mann24Mann Muster
4Mann Muster23Muster Mann
5Mayr Franz22Franz Mayr
6Muster frau1  
7Name eins1  
8Name zwei210zwei Name
9Name drei1  
10zwei Name28Name zwei

Formeln der Tabelle
ZelleFormel
B2=ZÄHLENWENN($A:$A;RECHTS($A2;LÄNGE($A2)-FINDEN(" ";$A2))& " "&LINKS($A2;FINDEN(" ";$A2)-1))+ZÄHLENWENN($A:$A;$A2)
C2=WENN($B2>1;VERGLEICH(RECHTS($A2;LÄNGE($A2)-FINDEN(" ";$A2))& " "&LINKS($A2;FINDEN(" ";$A2)-1); A:A;0); "")
D2=WENN(B2>1;BEREICH.VERSCHIEBEN($A$1;$C2-1;0); "")
B3=ZÄHLENWENN($A:$A;RECHTS($A3;LÄNGE($A3)-FINDEN(" ";$A3))& " "&LINKS($A3;FINDEN(" ";$A3)-1))+ZÄHLENWENN($A:$A;$A3)
C3=WENN($B3>1;VERGLEICH(RECHTS($A3;LÄNGE($A3)-FINDEN(" ";$A3))& " "&LINKS($A3;FINDEN(" ";$A3)-1); A:A;0); "")
D3=WENN(B3>1;BEREICH.VERSCHIEBEN($A$1;$C3-1;0); "")
B4=ZÄHLENWENN($A:$A;RECHTS($A4;LÄNGE($A4)-FINDEN(" ";$A4))& " "&LINKS($A4;FINDEN(" ";$A4)-1))+ZÄHLENWENN($A:$A;$A4)
C4=WENN($B4>1;VERGLEICH(RECHTS($A4;LÄNGE($A4)-FINDEN(" ";$A4))& " "&LINKS($A4;FINDEN(" ";$A4)-1); A:A;0); "")
D4=WENN(B4>1;BEREICH.VERSCHIEBEN($A$1;$C4-1;0); "")
B5=ZÄHLENWENN($A:$A;RECHTS($A5;LÄNGE($A5)-FINDEN(" ";$A5))& " "&LINKS($A5;FINDEN(" ";$A5)-1))+ZÄHLENWENN($A:$A;$A5)
C5=WENN($B5>1;VERGLEICH(RECHTS($A5;LÄNGE($A5)-FINDEN(" ";$A5))& " "&LINKS($A5;FINDEN(" ";$A5)-1); A:A;0); "")
D5=WENN(B5>1;BEREICH.VERSCHIEBEN($A$1;$C5-1;0); "")
B6=ZÄHLENWENN($A:$A;RECHTS($A6;LÄNGE($A6)-FINDEN(" ";$A6))& " "&LINKS($A6;FINDEN(" ";$A6)-1))+ZÄHLENWENN($A:$A;$A6)
C6=WENN($B6>1;VERGLEICH(RECHTS($A6;LÄNGE($A6)-FINDEN(" ";$A6))& " "&LINKS($A6;FINDEN(" ";$A6)-1); A:A;0); "")
D6=WENN(B6>1;BEREICH.VERSCHIEBEN($A$1;$C6-1;0); "")
B7=ZÄHLENWENN($A:$A;RECHTS($A7;LÄNGE($A7)-FINDEN(" ";$A7))& " "&LINKS($A7;FINDEN(" ";$A7)-1))+ZÄHLENWENN($A:$A;$A7)
C7=WENN($B7>1;VERGLEICH(RECHTS($A7;LÄNGE($A7)-FINDEN(" ";$A7))& " "&LINKS($A7;FINDEN(" ";$A7)-1); A:A;0); "")
D7=WENN(B7>1;BEREICH.VERSCHIEBEN($A$1;$C7-1;0); "")
B8=ZÄHLENWENN($A:$A;RECHTS($A8;LÄNGE($A8)-FINDEN(" ";$A8))& " "&LINKS($A8;FINDEN(" ";$A8)-1))+ZÄHLENWENN($A:$A;$A8)
C8=WENN($B8>1;VERGLEICH(RECHTS($A8;LÄNGE($A8)-FINDEN(" ";$A8))& " "&LINKS($A8;FINDEN(" ";$A8)-1); A:A;0); "")
D8=WENN(B8>1;BEREICH.VERSCHIEBEN($A$1;$C8-1;0); "")
B9=ZÄHLENWENN($A:$A;RECHTS($A9;LÄNGE($A9)-FINDEN(" ";$A9))& " "&LINKS($A9;FINDEN(" ";$A9)-1))+ZÄHLENWENN($A:$A;$A9)
C9=WENN($B9>1;VERGLEICH(RECHTS($A9;LÄNGE($A9)-FINDEN(" ";$A9))& " "&LINKS($A9;FINDEN(" ";$A9)-1); A:A;0); "")
D9=WENN(B9>1;BEREICH.VERSCHIEBEN($A$1;$C9-1;0); "")
B10=ZÄHLENWENN($A:$A;RECHTS($A10;LÄNGE($A10)-FINDEN(" ";$A10))& " "&LINKS($A10;FINDEN(" ";$A10)-1))+ZÄHLENWENN($A:$A;$A10)
C10=WENN($B10>1;VERGLEICH(RECHTS($A10;LÄNGE($A10)-FINDEN(" ";$A10))& " "&LINKS($A10;FINDEN(" ";$A10)-1); A:A;0); "")
D10=WENN(B10>1;BEREICH.VERSCHIEBEN($A$1;$C10-1;0); "")




Gruß Tino


  

Betrifft: AW: doppelte Wörter von: Herbert Gius
Geschrieben am: 18.08.2008 10:14:49

Hallo Tino,

Super ----- Danke!

Herbert


 

Beiträge aus den Excel-Beispielen zum Thema "doppelte Wörter"