Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen wenn bei Datum

Betrifft: Zählen wenn bei Datum von: jens
Geschrieben am: 10.08.2008 11:30:33

Hallo Liebe Excel Gemeinde,
Ich suche nach einem Makro, mit dem ich meine Datumseinträge zählen kann:
Ich habe in der Spalte A ca 1000 Einträge mit verschiedenen Daten.
Jetzt möchte ich zählen, wie wiele Einträge ich z.B. vom 01.01.2006 bis 31.01.2006 habe.

Viele Grüße Jens

  

Betrifft: AW: Zählen wenn bei Datum von: Hajo_Zi
Geschrieben am: 10.08.2008 11:32:50

Hallo Jens,

das geht auch ohne Makro.
Summe für ein Monat
leer wird als Januar interpretiert / Excel bzw. Billy spinnen
um dieses auszuschließen:
=SUMMENPRODUKT((A1:A100<>"")*(MONAT(A1:A100)=1)*B1:B100)
hier werden die Werte aus B addiert wenn in A der Monat Januar steht (egal, welches Jahr)
Mit Jahreseingrenzung auf 2003 so:
=SUMMENPRODUKT((A1:A100<>"")*(MONAT(A1:A100)=1)*(JAHR( A1:A100)=2003)*B1:B100)

GrußformelHomepage


  

Betrifft: AW: Zählen wenn bei Datum von: jens
Geschrieben am: 10.08.2008 11:51:17

Hallo Hajo,
Geht es auch als Makro, es sollte nähmlich ein Teil eines Makro werden?
Im Deinem Code steht auch Summewenn, müßte es nicht besser Zählenwenn (countif) sein?
Viele Grüße
Jens


  

Betrifft: AW: Zählen wenn bei Datum von: {Boris}
Geschrieben am: 10.08.2008 11:55:37

Hi Jens,

da stand nix von SUMMEWENN, sondern von SUMMENPRODUKT - und das ist für das Zählen mit mehreren Bedingungen bestens geeignet.
Allerdings geht das natürlich auch mit ZÄHLENWENN (CountIf). Nutze dazu die gleichnamige WorksheetFunction:
Zähle alle Datümer größer/gleich 01.01.2006 sowie alle größer 31.01.2006. Jetzt subtrahierst Du letztere von erster Zählung.

Grüße Boris


  

Betrifft: AW: Zählen wenn bei Datum von: Daniel
Geschrieben am: 10.08.2008 12:05:25

Hi

jup, wollt ich auch grad anworten, sieht als Formel so aus:


=ZÄHLENWENN(A:A;"<=31.01.2006")-ZÄHLENWENN(A:A;"<1.1.2006")


wenn es viele Monate sind, die einzeln Ausgezählt werden sollen, dann würde ich zwei Zusätzliche Spalten einfügen mit den Formeln "=JAHR(Datum)" und "=Monat(Datum)" und damit ne Pivot-Tabelle erstellen.

Gruß, Daniel


  

Betrifft: AW: Zählen wenn bei Datum von: jens
Geschrieben am: 10.08.2008 14:07:44

Vielen Dank,
Jetzt läufts.

Jens