Microsoft Excel

Herbers Excel/VBA-Archiv

Datenvergleich über 4 Spalten in zwei Blättern

Betrifft: Datenvergleich über 4 Spalten in zwei Blättern von: Martin
Geschrieben am: 14.08.2008 14:33:37

Hallo,

ich komme mit eine Formel für folgenden Fall nicht weiter:

Erste Datei (oder erstes Tabellenbaltt):
Nachname in Spalte A, Geburtsdatum in Spalte B, Betrag in Spalte C
Zweite Datei (oder zweites Tabellenbaltt):
Nachname in Spalte A, Geburtsdatum in Spalte B, Betrag in Spalte C
Eine Formel in Spalte D im zweiten Tabellenblatt soll gleichen Namen und gleiches Geburtsdatum in der ersten Datei suchen und vergleich ob der Betrag in Spalte C identisch ist mit dem bei demselben Namen und Geburtsdatum in der zweite Tabelle steht: "Gleich" wenn gleich, "Ungleich", wenn ungleich.
Wie geht das bitte?
Man kann natürlich Name und Geburtsdatum zusammenziehen und dann ein Wenn/Dann mit Sverweis machen, aber geht das auch in einer Formel?

Bin für jeden Hinweis dankbar!

Martin

  

Betrifft: AW: Datenvergleich über 4 Spalten in zwei Blättern von: IngoG
Geschrieben am: 14.08.2008 14:50:45

Hallo Martin,

wenn jede Kombination nur einmal vorkommt kannst Du folgende Formel nutzen:

=WENN(SUMMENPRODUKT((Tab1!$A$2:$A$1000=A2)*(Tab1!$B$2:$B$1000=B2)*Tab1!$C$2:$C$1000)=C2;"gleich"; "ungleich") 



Gruss Ingo
PS eine Rueckmeldung waere nett...


  

Betrifft: AW: Datenvergleich über 4 Spalten in zwei Blättern von: Martin
Geschrieben am: 14.08.2008 20:01:25

Hallo, vielen Dank. Funktioniert leider nicht, weil ich mich unklar ausgedrückt habe.
Name und Geburtsdatum funktionieren als eine Art "einzigartiger" Schlüssel. Nur wenn beides zusammen übereisntimmt, soll der Wert in C verglichen werden, sonst nicht.

Sorry!

Martin


  

Betrifft: AW: Datenvergleich über 4 Spalten in zwei Blättern von: hary
Geschrieben am: 14.08.2008 23:26:03

Hallo Martin
So gehts

https://www.herber.de/bbs/user/54611.xls
Gruss Hary


 

Beiträge aus den Excel-Beispielen zum Thema "Datenvergleich über 4 Spalten in zwei Blättern"