Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn-Sverweis mit "Sprungbezug"

Betrifft: Wenn-Sverweis mit "Sprungbezug" von: eddie
Geschrieben am: 19.08.2008 20:39:41

Hallo zusammen,

ich habe ein kleines Problem mit einer Wenn-Sverweis-Verknüpfung.
Unten stehende Formeln stehen untereinander in einer Spalte in z.B. den Zellen V2 und V3. Mit Hilfe der Ausfüllfunktion möchte ich gern diese Formel nach unten kopieren, und das jeweils nach Aufgabenstellung zwischen ca. 5 und 50 Mal.
Mein Problem ist dabei der Bezug auf die Zelle A2. Wenn ich die erste Formel nach unten kopiere, wird aus der Zelladresse logischerweise A3, dann A4 usw.
Das soll aber nicht passieren. Der Bezug zur ersten Zelladresse A2 soll immer um 3 Zeilen „springen“, also A2; A5; A8; A11 usw. und das nur bei diesem einen Bezug, der Rest soll ganz normal entsprechend der relativen Adressierung nach unten wandern.
Wie bekomme ich das hin?
Grüße
Manfred

=WENN(A2>3000;SVERWEIS(N2;AB;5;);SVERWEIS(N2;AB;4;))
=WENN(A5>3000;SVERWEIS(N3;AB;5;);SVERWEIS(N3;AB;4;))

  

Betrifft: AW: Wenn-Sverweis mit "Sprungbezug" von: Daniel
Geschrieben am: 19.08.2008 21:01:10

Hi
in diesem Fall muss der Zellbezug auf A2 "gerechnet" werden, beispielsweise mit dieser Funktion (muss in die Formel für anstelle von A2 eingesetzt werden)
INDEX(A:A;2+3*(ZEILE()-2))

Gruß, Daniel


  

Betrifft: AW: Wenn-Sverweis mit "Sprungbezug" von: eddie
Geschrieben am: 19.08.2008 21:30:06

Hallo Daniel,

ich sage dir sicherlich nichts Neues, wenn ich mitteile, dass es funktioniert.
Danke

Manfred