Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

SVerweis - Wert suchen à la "Offset 1,3"

SVerweis - Wert suchen à la "Offset 1,3"
19.09.2008 14:21:11
Bernd
Hallo Freaks,
ich möchte einen Wert per Sverweis ermitteln, der " 3 Spalten rechts + 1 Zeile runter" steht.
Siehe bitte einfaches Beispiel anbei.
https://www.herber.de/bbs/user/55520.xls
Vorab besten Dank für Eure Hilfe und Mühen.
Grüße
Bernd

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: SVerweis - Wert suchen à la "Offset 1,3"
19.09.2008 14:24:45
David
Hallo Bernd,
nimm VERGLEICH anstatt Sverweis und dann per INDEX(Matrix;'gefundene Zeile'+1;'Spalte') die gewünschte Stelle. Da du Sverweis nimmst, muss ja die Spalte fix sein, dann einfach die 3 Spalten daneben angeben.
Gruß
David
@David
19.09.2008 16:22:00
Bernd
Hi David,
vielen herzlichen Dank f.d. Mühen. Variante 1 klappt, Variante 2 stimmt leider nicht. Wärst du so nett und würdest noch mal drüber blicken?

Die Datei https://www.herber.de/bbs/user/55529.xls wurde aus Datenschutzgründen gelöscht


Danke,
bernd
AW: @David
19.09.2008 19:56:00
David
Hallo Bernd.
Wer lesen kann ist klar im Vorteil. ;-)
Wie ich schon schrieb, bei der Variante mit Summenprodukt muss das erste Kriterium (=KST XX) in JEDER Zeile stehen!
Gruß
David
https://www.herber.de/bbs/user/55533.xls
Anzeige
AW: @David
22.09.2008 15:04:00
Bernd
Hi David,
vielen Dank für deine Mühen. Jetzt ist alles klar.
Das mit "dem Lesen ist klar im Vorteil" ist halt schwierig, wenn's nicht drinnen steht, dass man die KST ergänzen muss: "Da du Sverweis nimmst, muss ja die Spalte fix sein, dann einfach die 3 Spalten daneben angeben.". Ich hatte den Hinweis nicht verstanden.
Grüße und nochmals Danke,
bernd
AW: SVerweis - Wert suchen à la "Offset 1,3"
19.09.2008 14:29:29
David
auf dein Beispiel bezogen:
Tabellenblattname: Daten
 

B

C

D

11

Hauptkriterium

Nebenkriterium

Wert

12

KST 1

A

10

13

 

B

20

14

 

C

30

15

 

 

 

16

KST 2

A

40

17

 

B

50

18

 

C

60

19

 

 

 

20

 

 

 

21

 

 

 

22

Zielbereich:

 

 

23

 

 

 

24

Hauptkriterium

 

Wertübernahme

25

KST 1

 

10

26

 

 

20

27

 

 

30

28

 

 

 

29

KST 2

 

40

30

 

 

50

31

 

 

60


Benutzte Formeln:
D25: =INDEX($D$12:$D$18;VERGLEICH(B25;$B$12:$B$18;0)+0)
D26: =INDEX($D$12:$D$18;VERGLEICH(B25;$B$12:$B$18;0)+1)
D27: =INDEX($D$12:$D$18;VERGLEICH(B25;$B$12:$B$18;0)+2)
D29: =INDEX($D$12:$D$18;VERGLEICH(B29;$B$12:$B$18;0)+0)
D30: =INDEX($D$12:$D$18;VERGLEICH(B29;$B$12:$B$18;0)+1)
D31: =INDEX($D$12:$D$18;VERGLEICH(B29;$B$12:$B$18;0)+2)
Rückmeldung wäre nett.
Gruß
DAvid
Anzeige
AW: SVerweis - Wert suchen à la "Offset 1,3"
19.09.2008 14:34:00
David
Und hier noch die von dir gewünschte Alternative:
Tabellenblattname: Daten
 

B

C

D

11

Hauptkriterium

Nebenkriterium

Wert

12

KST 1

A

10

13

KST 1

B

20

14

KST 1

C

30

15

 

 

 

16

KST 2

A

40

17

KST 2

B

50

18

KST 2

C

60

19

 

 

 

20

 

 

 

21

 

 

 

22

Zielbereich:

 

 

23

 

 

 

24

Hauptkriterium

 

Wertübernahme

25

KST 1

A

10

26

KST 1

B

20

27

KST 1

C

30

28

 

 

 

29

KST 2

A

40

30

KST 2

B

50

31

KST 2

C

60


Benutzte Formeln:
D25: =SUMMENPRODUKT(($B$12:$B$18=B25)*($C$12:$C$18=C25)*$D$12:$D$18)
D26: =SUMMENPRODUKT(($B$12:$B$18=B26)*($C$12:$C$18=C26)*$D$12:$D$18)
D27: =SUMMENPRODUKT(($B$12:$B$18=B27)*($C$12:$C$18=C27)*$D$12:$D$18)
D29: =SUMMENPRODUKT(($B$12:$B$18=B29)*($C$12:$C$18=C29)*$D$12:$D$18)
D30: =SUMMENPRODUKT(($B$12:$B$18=B30)*($C$12:$C$18=C30)*$D$12:$D$18)
D31: =SUMMENPRODUKT(($B$12:$B$18=B31)*($C$12:$C$18=C31)*$D$12:$D$18)
Hier ist aber zu beachten, dass das Hauptkriterium in JEDER Zeile stehen muss. Über Umwege ginge es auch ohne, aber das würde eine ziemlich umfangreiche Matrixformel.
Gruß
David
Anzeige

304 Forumthreads zu ähnlichen Themen


Hallo Hans,
wenn ich die URLs richtig interpretiere, haben wir im Forum soeben die Zahl von 1 Million Beiträgen überschritten.
Herzlichen Glückwunsch zu dem Erfolg Deines "Babys"!
Gruß
Martin
Anzeige

Hallo zusammen!
Ich habe da als blutiger Anfänger in VBA zwei Fragen:
1.) Wie kann ich in meiner Tabelle in jeder zweiten Spalte 4 leere Spalten einfügen lassen?
2.) Dann möchte ich unter den Inhalt der ersten fünf Spalten (A-E) den Inhalt der zweiten 5 Spalten (F-J) usw. In der grö...

Guten Morgen!
Ich hätte folgendes Problem: Ich erhalte automatisiert Exceltabellen, bei denen nicht alle Zellen einer Zeile gefüllt werden, wenn dort der Inhalt einer darüberliegenden Zeile stehen sollte. Zur Weiterverarbeitung muss ich aber diese Zellen mit den dazugehörigen Werten füllen....
Anzeige

Hallo zusammen,
ich habe eine lange Liste, in der in einer Spalte Daten stehen, wo ab und zu vorangehende Nullen nötig sind (mal eine - mal 2...etc.) - und manchmal auch keine.
Wie kann ich diese Zellen formatieren, das die vorangehenden "Nullen" nicht automatisch weggelassen werden?

Hallo Excel-Profis
ich habe folgenden Code in ein Makro eingebaut:
'Drucken mit Vorschau
Application.ActivePrinter = "\\dataserv\HP LaserJet 5L AV auf Ne05:"
ActiveWindow.SelectedSheets.PrintOut Copies:=1, Preview:=True, Collate:= _
True
Hier wird der Standard-Drucker an...

Hallo,
Ich brauche dringend Eure Hilfe. Unter https://www.herber.de/bbs/user/54533.xls findet Ihr eine Mappe, in welcher in Spalte A
1 für "Kaufen"
0 für " "
-1 für "Verkaufen"
steht. IN SPALTE B SIND BISHER NUR MANUELL ERSTELLTE BEISPIELEINTRÄGE ENTHALTEN, DAMIT ERSICHTLIC...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige