Exakte "verweis"-Definition



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Exakte "verweis"-Definition
von: Khan
Geschrieben am: 15.07.2002 - 13:55:02

Hallo!

Ich habe folgendes Problem:

Eine Zahlenfolge(als Text definiert) soll mit einer Liste von Zahlenfolgen verglichen werden und bei Gleichheit soll der Wert neben der Zahlenfolge ausgegeben werden.
Wenn die Zahlenfolge nicht exestiert wird der Wert "gibt´s nicht" ausgegeben.

Ich habe folgende Eingabe verwendet:

=WENN(B3="";"";(WENN(ISTNV(VERGLEICH(B3;$D$3:$D$59;0));"gibt´s nicht!";VERWEIS(B3;$D$3:$D$59;$E$3:$E$59))))

Das Problem ist jedoch daß die Formel nicht die exakte Zahlenfolge findet sondern nur die ersten zahlen nimmt bzw. überhaupt einen ganz anderen Wert nimmt....

Herzlichen Dank im Voraus!

nach oben   nach unten

Zusatz mit "falsch"
von: andreas e
Geschrieben am: 15.07.2002 - 14:05:45

hallo

ergänze den verweis durch "falsch"

VERWEIS(B3;$D$3:$D$59;$E$3:$E$59;falsch)

gruß

andreas e

http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr

nach oben   nach unten

Re: Zusatz mit "falsch"
von: Khan
Geschrieben am: 17.07.2002 - 11:47:29

Da krieg ich die Fehlermeldung "zu viele Argumente" .... :-(
nach oben   nach unten

und so ...?
von: andreas e
Geschrieben am: 17.07.2002 - 11:51:15

=WENN(B3="";"";(WENN(ISTNV(VERGLEICH(B3;$D$3:$D$59;0;falsch));"gibt´s nicht!";VERWEIS(B3;$D$3:$D$59;$E$3:$E$59;falsch))))

hoffe das hilft etwas weiter

gruß

andreas e

http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Syntax für "isttext" für mehrere Zellen"