Microsoft Excel

Herbers Excel/VBA-Archiv

Dopplete Einträge nicht mitzählen

Betrifft: Dopplete Einträge nicht mitzählen von: panos
Geschrieben am: 21.08.2008 14:17:19

Hallo, brauche eure Hilfe.

Doppelte Einträge sollen nicht mitgezählt werden.

z.b. APFEL
APFEL
BIRNE

Es soll 2 Rauskommen

hiermit klappt es ganz gut,

=SUMME(WENN(HÄUFIGKEIT(VERGLEICH(rng;rng;0);VERGLEICH(rng;rng;0))>0;1))

das Problem ist, wenn dazwischen freier Platz vorhanden ist, gibts eine Fehlermeldung,

Bsp.

APFEL
APFEL
leer
BIRNE

Hoffe Ihr könnt mir helfen, vielen Dank im Voraus

  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: ChrisAugsburg
Geschrieben am: 21.08.2008 14:36:24

{=SUMME(WENN(B1:B100<>"";1/ZÄHLENWENN(B1:B100;B1:B100)))}

versuch es mal hiermit

die Formel ohne geschweifte Klammern eingeben. und die Formel durch drücken von Strg+Shift+Enter Abschliessen.


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: panos
Geschrieben am: 21.08.2008 15:34:22

vielen Dank. Das klappt wohl bei dem kleinen Beispiel, wenn ich dass jedoch auf 100 Einträge erweitere klappt es leider nicht mehr, oder ich habe das falsch eingegeben.

APFEL
APFEL
leer
BIRNE
OBST1
OBST2
OBST3

Bei diesem beispiel sollte 5 rauskommen, doppelte Einträge werden nur einmal mitgezählt.
Hiermit klappts eigendlich :
{=SUMME(WENN(HÄUFIGKEIT(VERGLEICH(rng;rng;0);VERGLEICH(rng;rng;0))>0;1))}

Macht aber noch probleme bei leeren Einträgen,..,leere Einträge sollen nicht berücksichtigt werden.


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: ChrisAugsburg
Geschrieben am: 21.08.2008 15:44:46

Also bei mir klappts auch bei 1000 einträgen

=SUMME(WENN(B1:B1000<>"";1/ZÄHLENWENN(B1:B1000;B1:B1000)))

Wichtig ist das die 3 Bereiche IMMER gleich gross sind. Dass heisst wenn du vorne den Bereich auf B45:B336 anpasst müssen auch die beiden zweiten Bereiche in der Zählenwennformel auf B45:B336 angepasst werden. Und nach dem Anpassen muss die Formel wiederum mit Strg+Shift+Enter abgeschlossen werden.
Bei mir funtioniert das einwandfrei. Ab 30.000 Zeilen solltest du dir eine Hiflsspaltenlösung überlegen da dann die Arrayformel einfach zu lange braucht.

Gruss Chris


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: panos
Geschrieben am: 21.08.2008 15:53:20

Vielen Dank.
Ich werde es nacher mal in aller ruhe mal probieren.
wenn ich nur deine Formel eingebe, kommt komischer Weise null raus.

Vielen Dank, hast mir trotzdem sehr geholfen


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: ChrisAugsburg
Geschrieben am: 21.08.2008 15:59:07

Hast du die Formel als Arrayformel eingegeben? Hast du die Bereiche deinen Bedürfnissen angepasst? Falls ja dürfte nicht 0 rauskommen.


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: panos
Geschrieben am: 21.08.2008 16:47:50

Vielen Dank.
Ich werde es nacher mal in aller ruhe mal probieren.
wenn ich nur deine Formel eingebe, kommt komischer Weise null raus.

Vielen Dank, hast mir trotzdem sehr geholfen


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: panos
Geschrieben am: 21.08.2008 16:58:13

Ich hab die Excel Datei hochgeladen,..,vieleicht klappts jetzt!
https://www.herber.de/bbs/user/54787.xls

oder liegt es eventuell an den Einstellungen?


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: ChrisAugsburg
Geschrieben am: 21.08.2008 17:07:14

Die Formel darf selbstverständlich nicht im Bereich B1:B1000 stehen sonst bekommst du einen Zirkelbezug. Entweder du schreibst die Formel in die Spalte C oder du grenzt den Bereich in der Formel auf den Bereich oberhalb der Formel ein. In deinem Falle B1:B10 da die Formel in B11 steht. Dann kommt auch im Beispiel wie geplant 3 raus.


  

Betrifft: AW: Dopplete Einträge nicht mitzählen von: panos
Geschrieben am: 21.08.2008 17:30:41

Vielen Dank!!!!!!!!!!!!!!!!!!!!! - Supper gelöst


Klappt