Microsoft Excel

Herbers Excel/VBA-Archiv

summewenn mit <> | Herbers Excel-Forum


Betrifft: summewenn mit <> von: David
Geschrieben am: 28.10.2008 12:41:34

Hallo zusammen,

ich möchte Bereiche einer Spalte B summieren,
wenn die Werte in Spalte A größer als 796 aber
kleiner als 77 sind.
Wie schreibt man das?

Bekomme die Kombination von SUMMEWENN und der UND-
Funktion nicht hin.

Wäre Euch für Anregungen sehr dankbar.

Merci.

David

  

Betrifft: AW: summewenn mit <> von: Rudi Maintaire
Geschrieben am: 28.10.2008 12:45:59

Hallo,

wenn die Werte in Spalte A größer als 796 aber kleiner als 77 sind.


Das ist ein Widerspruch in sich.

Gruß
Rudi


  

Betrifft: AW: summewenn mit <> von: David
Geschrieben am: 28.10.2008 12:47:21

Ups, sorry.

Ich meinte größer als 76 aber kleiner als 77.

Gruß


David


  

Betrifft: AW: SUMMENPRODUKT von: Erich G.
Geschrieben am: 28.10.2008 12:51:33

Hallo David,
meinst du das jetzt so?

 ABC
17011100
27610 
376,1100 
476,91000 
57710000 
680100000 

Formeln der Tabelle
ZelleFormel
C1=SUMMENPRODUKT((A1:A999>76)*(A1:A999<77)*B1:B999)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: SUMMENPRODUKT von: JogyB
Geschrieben am: 28.10.2008 13:05:18

Oder so:

=SUMME(B1:B999)-SUMMEWENN(A1:A999;"<=76";B1:B999)-SUMMEWENN(A1:A999;">=77";B1:B999)

Gruss, Jogy


  

Betrifft: AW: SUMMENPRODUKT von: David
Geschrieben am: 28.10.2008 13:50:51

Hi Ihr beiden,

der Vorschlag von Jogy hat mir eingeleuchtet und
der funktioniert jetzt.
Erich, das mit dem Summenprodukt habe ich nicht
nachvollziehen können, wohl aber ein wenig damit
herumprobiert.

Danke vielmals!


David


  

Betrifft: AW: SUMMENPRODUKT von: JogyB
Geschrieben am: 28.10.2008 14:01:42

Die Summenproduktformel nutzt aus, dass in einer Rechnung WAHR als 1 und FALSCH als 0 interpretiert wird. Sobald eine 0 dabei ist, wird das gesamte Produkt 0 und der Wert aus B damit nicht aufsummiert.

Gruss, Jogy


  

Betrifft: AW: SUMMENPRODUKT von: David
Geschrieben am: 28.10.2008 14:54:18

Kurze Ergänzung noch:

Warum bekomme ich nicht dasselbe Ergebnis, wenn ich <=76000000 durch die Zelle
B1531 ersetze, in der dieser Wert steht?~f~

~f~=SUMME(C1:C1528)-SUMMEWENN(A1:A1528;"<=B1531";C1:C1528)-SUMMEWENN(A1:A1528;">=77000000";C1:C1528)~f~

ergibt nicht dasselbe wie

~f~=SUMME(C1:C1528)-SUMMEWENN(A1:A1528;"<=76000000";C1:C1528)-SUMMEWENN(A1:A1528;">=77000000";C1:C1528)

Gruß


David


  

Betrifft: AW: SUMMENPRODUKT von: JogyB
Geschrieben am: 28.10.2008 18:13:59

Ersetze "<=B1531" durch "<=" & B1531

Gruss, Jogy


  

Betrifft: AW: SUMMENPRODUKT von: Erich G.
Geschrieben am: 28.10.2008 18:17:51

Hi David,
in der ersten Formel werden die Zahlen in Spalte A mit dem Text "B1531" vergleichen,
aber nicht mit der Zahl, die in B1531 steht.

In E3 steht, wie das geschrieben werden muss, in E2 ist die falsche Formel:

 ABCDE
170000000760000001  
276000000 10 1111
376100000 100 1100
476900000 1000 1100
577000000 10000 1100
680000000 100000 1100

Formeln der Tabelle
ZelleFormel
E2=SUMME(C1:C1528)-SUMMEWENN(A1:A1528;"<=B1531";C1:C1528) -SUMMEWENN(A1:A1528;">=77000000";C1:C1528)
E3=SUMME(C1:C1528)-SUMMEWENN(A1:A1528;"<="&B1531;C1:C1528) -SUMMEWENN(A1:A1528;">=77000000";C1:C1528)
E4=SUMME(C1:C1528)-SUMMEWENN(A1:A1528;"<=76000000";C1:C1528) -SUMMEWENN(A1:A1528;">=77000000";C1:C1528)
E5=SUMMENPRODUKT((A1:A1528>76000000)*(A1:A1528<77000000)*C1:C1528)
E6=SUMMENPRODUKT((A1:A1528>B1531)*(A1:A1528<77000000)*C1:C1528)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


Beiträge aus den Excel-Beispielen zum Thema "summewenn mit <>"