Microsoft Excel

Herbers Excel/VBA-Archiv

An alle EXCEL-CHECKER , Bedingung für zählenwenn



Excel-Version: 10.0 (Office XP)

Betrifft: An alle EXCEL-CHECKER , Bedingung für zählenwenn
von: shaka
Geschrieben am: 06.06.2002 - 12:14:30

Hallo WernerB. !!

ich habe da ein ähnliches Problem!!

habe 3 Spalten
in der ersten Spalte steht die KW 1 bis 22 sortiert.
dabei sind die kw öfters je in einer Zeile vorhanden.

in der zweiten spalte steht steht ein "ok" oder "offen" drinne.
in der dritten spalte steht die Ticketnummer zu diesem Problem

jetzt möchte ich, Eine TAbelle erstellen
die mir sagt, wieviele Tickets von Woche 1 ,2 u.s.e
ok bzw. offen sind.

also eine Formel die so z.B. aussehen könnte:
wenn Spalte A=1; dann zähle die Zellen, die in der gleichen
Zeile bei Spalte A eine 1 haben, und in der Spalte B ein "ok" haben.
jetzt könnte ich zwar manuell den Bereich abgrenzen z.B. für die Woche 1 mit : zählenwenn(b1:b6;"ok"), möchte aber das Excel
anhand von einer Abfrage selber den Bereich ermittelt, durch die Bedingung, wenn Spalte A=1 bzw. 2 etc.. ist

also eine Formel die ungefähr so aussehen muss :
Für (A:A)=1,merke dir den Wertebereich durch 2 Variable X,Y und dann setze ein :Zählenwenn(bX:BY;"ok")

hoffe ihr versteht mein Problem, und könnt es lösen !!

shaka grüßt euch alle !!!

Tabellenbeispiel:
A B c
1 ok tik298
1 ok tik982
1 ok tik221
1 offen tik985
1 ok tik164
1 ok tik202
2 ok tik111
2 offen tik983
2 offen tik006
2 ok tik123
3 offen tik432
3 offen tik119
3 ok tik222

usw.


  

Re: An alle EXCEL-CHECKER , Bedingung für zählenwenn
von: Coach
Geschrieben am: 06.06.2002 - 12:26:50

Hallo shaka,

nimm folgende Arrayformel (Eingabe mit Strg+Shift+Enter):
=SUMME(WENN((A2:A1000=1)*(B2:B1000="ok");1;0))

Beispiel für (KW 1 und Status ok)

Gruß Coach

  

mit Summenprodukt
von: snickers
Geschrieben am: 06.06.2002 - 12:28:43

Hi Shaka,

in E1 die Kalenderwoche: 1
in F1 ok oder offen

in G1: =Summenprodukt((A2:A65000=E1)*(B2:B65000=F1))

 

Beiträge aus den Excel-Beispielen zum Thema "An alle EXCEL-CHECKER , Bedingung für zählenwenn"