Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
116to120
116to120
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zähle Anzahl der "X"e in einem Zellwert

Zähle Anzahl der "X"e in einem Zellwert
30.04.2002 13:21:17
Jens K.
Hallo,
ist es irgendwie möglich die Anzahl einer Zeichenfolge in einem Zellwert z.B.

Zellwert A1 = "X blabla X blabla X"
Zellwert A2 = 3 (weil 3 mal "X")

zu ermitteln ?

Für jeden Tip wäre ich dankbar.

Jens

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Zähle Anzahl der "X"e in einem Zellwert
30.04.2002 13:45:22
Tobi@s
Hallo,

ich würde an deiner Stelle eine selbstgebastelte Funktion nehmen, denn Formel habe ich keine gefunden.

Public Function ZF(Zeichenfolge, Suchtext)
Wert = Zeichenfolge.Text 'Ausgangswert
ST = Suchtext 'gesuchter Begriff
Anz = 0 'Anzahl
For I = 1 To Len(Wert) - Len(ST) + 1 'prüft Zeichenfolge
HT = Mid(Wert, I, Len(ST)) 'prüft Teil von Zeichenfolge
If HT = ST Then Anz = Anz + 1 'Suchtext vorhanden -> Anzahl erhöhen
Next
ZF = Anz 'Eintrag
End Function

Wenn man diese Tabelle (mit der Funktion) als xla abspeichert, kann man diese dann auch in jeder beliebigen Mappe benutzen, da als Add-In verfügbar.

Funktion ist bei "Benutzerdefiniert" zu finden.
Bsp: =ZF(A1;"r")
Gruß

Anzeige
Re: Zähle Anzahl der "X"e in einem Zellwert
30.04.2002 14:50:10
Joachim L.
Hallo Jens,

für Formel schau mal auf dieser Internetseite:
http://www.excelformeln.de

Wenn Du in einer Zelle(z.B. A1) X suchst, dann benutze folgende Formel in A2:
=SUMME(LÄNGE(A1))-SUMME(LÄNGE(WECHSELN(A1;"X";"")))

Bei einem Bereich (z.B. A1 bis A8) mußt Du mit STRG+SHIFT+Enter abschließen, dadurch werden die geschweiften Klammern eingefügt:
{=SUMME(LÄNGE(A1:A8))-SUMME(LÄNGE(WECHSELN(A1:A8;"x";"")))}

Ich hoffe das hilft.
Gruß Joachim

304 Forumthreads zu ähnlichen Themen


Hi!
Unten meine aktuelle Formel. Nun möchte ich aber, daß Excel zählen soll, wenn es ungleich X und ungleich Leerfeld ist.
Oder er soll nur dann zählen, wenn eine Zahl drin steht.
=ZÄHLENWENN(C3:AJ3;"X")
Bestimmt leicht für euch ...
Danke, Toby ...
Anzeige

Hi,
ich will einfach per VBA ein Button der auf eine Makro verlinkt ist, in das aktive Tabellenblatt einsetzt und zwar genau passend in die Zelle B1.
Kann mir da vll. einer den Code dafür sagen mit dem Makrorekorder muss ich das passend ziehen das gefällt mir nicht so.
mfg Tom
...

Guten Morgen @ all
Ich habe mal wieder ein kleines problem :-)
Ich würde gerne Daten, die alle in einer Spalte sind auteilen.... dazu soll entweder der 1,3,5,7.... oder 2,4,6,8 ... Wert immer in die danebenliegende Spalte kopiert werden
IST:
Hallo
Hello
Gut
Good
...
Anzeige

Hallo zusammen,
bei einer Exceltabelle, die aus ca. 40 freien Zeilen besteht, die sich über die Zeit füllen, soll in Zeile 41 immer die Zahl der letzten gefüllten Zeile angezeigt werden.
Ist das möglich?
Danke im voraus!
Hendrik

Hallo Leute
Ich habe eine Spalte mit einer menge Uhrzeiten und möchte die Häufigkeit einer Uhrzeit ( wie oft ist eine eintrag vorhanden)zum Beispiel zwischen 08:00 und 17:00!! Ich weiß das für euch sicher ein leichtes ist jemanden wie mir zu helfen!
Schon jetzt besten Dank für eure Mühe...

Hallo Leute
Ich habe eine Spalte mit einer menge Uhrzeiten und möchte die Häufigkeit einer Uhrzeit ( wie oft ist eine eintrag vorhanden)zum Beispiel zwischen 08:00 und 17:00!! Ich weiß das für euch sicher ein leichtes ist jemanden wie mir zu helfen!
Schon jetzt besten Dank für eure Mühe...

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige