Herbers Excel-Forum - das Archiv

Zähle Anzahl der "X"e in einem Zellwert



Excel-Version: 9.0
nach unten

Betrifft: Zähle Anzahl der "X"e in einem Zellwert
von: Jens K.


Geschrieben am: 30.04.2002 - 13:21:17

Hallo,
ist es irgendwie möglich die Anzahl einer Zeichenfolge in einem Zellwert z.B.

Zellwert A1 = "X blabla X blabla X"
Zellwert A2 = 3 (weil 3 mal "X")

zu ermitteln ?

Für jeden Tip wäre ich dankbar.

Jens


nach oben   nach unten

Re: Zähle Anzahl der "X"e in einem Zellwert
von: Tobi@s


Geschrieben am: 30.04.2002 - 13:45:22

Hallo,

ich würde an deiner Stelle eine selbstgebastelte Funktion nehmen, denn Formel habe ich keine gefunden.

Public Function ZF(Zeichenfolge, Suchtext)
Wert = Zeichenfolge.Text 'Ausgangswert
ST = Suchtext 'gesuchter Begriff
Anz = 0 'Anzahl
For I = 1 To Len(Wert) - Len(ST) + 1 'prüft Zeichenfolge
HT = Mid(Wert, I, Len(ST)) 'prüft Teil von Zeichenfolge
If HT = ST Then Anz = Anz + 1 'Suchtext vorhanden -> Anzahl erhöhen
Next
ZF = Anz 'Eintrag
End Function

Wenn man diese Tabelle (mit der Funktion) als xla abspeichert, kann man diese dann auch in jeder beliebigen Mappe benutzen, da als Add-In verfügbar.

Funktion ist bei "Benutzerdefiniert" zu finden.
Bsp: =ZF(A1;"r")
Gruß

nach oben   nach unten

Re: Zähle Anzahl der "X"e in einem Zellwert
von: Joachim L.


Geschrieben am: 30.04.2002 - 14:50:10

Hallo Jens,

für Formel schau mal auf dieser Internetseite:
http://www.excelformeln.de

Wenn Du in einer Zelle(z.B. A1) X suchst, dann benutze folgende Formel in A2:
=SUMME(LÄNGE(A1))-SUMME(LÄNGE(WECHSELN(A1;"X";"")))

Bei einem Bereich (z.B. A1 bis A8) mußt Du mit STRG+SHIFT+Enter abschließen, dadurch werden die geschweiften Klammern eingefügt:
{=SUMME(LÄNGE(A1:A8))-SUMME(LÄNGE(WECHSELN(A1:A8;"x";"")))}

Ich hoffe das hilft.
Gruß Joachim

 nach oben

Excel-Beispiele zum Thema "Zähle Anzahl der "X"e in einem Zellwert"
Seitenanzahl eintragen Funktion ANZAHL2 ohne ausgeblendete Spalten
Anzahl der über ParamArray festgelegten Parameter Anzahl eines bestimmten Wochentages im Monat
Anzahl der einzufügenden Zeilen abfragen Bestimmte Anzahl von Zeichen zulassen
Seitennummer und Seitenanzahl per VBA in Kopfzeile Nur AJM in TextBox akzeptieren und Anzahl zählen
Anzahl von CheckBoxes in einer UserForm ermitteln Anzahl der gelb hinterlegten Zellen ermitteln