Microsoft Excel

Herbers Excel/VBA-Archiv

2 Formeln zu einer | Herbers Excel-Forum


Betrifft: 2 Formeln zu einer von: Snewi
Geschrieben am: 03.04.2012 11:55:36

Hallo wie bekomme ich diese beiden Formeln:

=WENN(ODER(C9>4500;C9<2500);1;0)
=WENN(UND(C9=0;E9>0);1;0)

in einer unter??

Gruß

  

Betrifft: ohne WENN von: Erich G.
Geschrieben am: 03.04.2012 12:02:48

Hi Snewi,
probier mal H9;

 FGH
9111
1000 

Formeln der Tabelle
ZelleFormel
F9=WENN(ODER(C9>4500;C9<2500); 1;0)
G9=--((C9>4500)+(C9<2500)>0)
H9=--((C9>4500)+(C9<2500)+(C9=0)*(E9>0)>0)
F10=WENN(UND(C9=0;E9>0); 1;0)
G10=(C9=0)*(E9>0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: ohne WENN von: Snewi
Geschrieben am: 03.04.2012 12:23:10

Hi,
leider kommt wenn C9 und E9 eine hat als Ergebnis eine 1! es soll ja nur eine kommen wenn

C9=0 und E9 >0
Gruß


  

Betrifft: leider? von: Erich G.
Geschrieben am: 03.04.2012 12:51:16

Hi Snewi,
"leider kommt wenn C9 und E9 eine hat" ??? Soll ich das verstehen?

Wenn C9=1, E9 egal, kommt die 1 in H9 nicht wegen "C9=0 und E9>0", sondern wegen "C9<2500"
Oder spielt der Teil mit 4500 und 2500 keine Rolle mehr?

Wenn das falsch ist: Wie wolltest du denn die beiden Formeln kombiniert haben?

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: 2 Formeln zu einer von: Reinhard
Geschrieben am: 03.04.2012 12:34:38

Hallo Snewi,

füll mal bitte gewissenhaft C aus:

Tabellenblatt: [Mappe1]!Tabelle1
   │   A  │  B │ C │
---┼------┼----┼---┼
 1 │ C9   │ E9 │ ? │
---┼------┼----┼---┼
 2 │    0 │  0 │   │
---┼------┼----┼---┼
 3 │ 2400 │  0 │   │
---┼------┼----┼---┼
 4 │ 2500 │  0 │   │
---┼------┼----┼---┼
 5 │ 3000 │  0 │   │
---┼------┼----┼---┼
 6 │ 4500 │  0 │   │
---┼------┼----┼---┼
 7 │ 4600 │  0 │   │
---┼------┼----┼---┼
 8 │    0 │ 10 │   │
---┼------┼----┼---┼
 9 │ 2400 │ 10 │   │
---┼------┼----┼---┼
10 │ 2500 │ 10 │   │
---┼------┼----┼---┼
11 │ 3000 │ 10 │   │
---┼------┼----┼---┼
12 │ 4500 │ 10 │   │
---┼------┼----┼---┼
13 │ 4600 │ 10 │   │
---┴------┴----┴---┴
A1:C13
haben das Zahlenformat: Standard

Gruß
Reinhard


  

Betrifft: AW: 2 Formeln zu einer von: Snewi
Geschrieben am: 03.04.2012 13:58:09

Ich möchte nur eine 1 in Spalte F wenn:

C9 >4500 oder C9 <2500 
oder wenn C9 = 0 und gleichzeitig E9 >0 


sonst eine 0 in F

Hoffentlich besser erklärt!

gruß


  

Betrifft: Logik von: Rudi Maintaire
Geschrieben am: 03.04.2012 14:13:09

Hallo,
wenn C9=0 ist, ist sie auch <2500. Oder gilt die erste Bed. nur, wenn E9=0 ist?

Gruß
Rudi


  

Betrifft: AW: Logik von: Snewi
Geschrieben am: 03.04.2012 14:17:23


C9 soll ja nicht kleiner 0 sein sondern = 0! Wenn C9 dann = 0 möchte ich wissen ob E9 > 0! Wenn E9 = 0 dann soll in F auch ne 0 sthen und keine 1!



Gruß


  

Betrifft: bitte genauer lesen von: Erich G.
Geschrieben am: 03.04.2012 14:21:55

Hi Snewi,
"C9 soll ja nicht kleiner 0 sein sondern = 0!" Ja. Rudi schrieb: "wenn C9=0 ist".

Strimmen wir überein darin, dass 0 kleiner als 2500 ist? Genau daraus ergab sich das Ergebnis.

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: =((C9=0)*(E9>0))+(C9>0)*((C9<2500)+(C9>4500)) von: Rudi Maintaire
Geschrieben am: 03.04.2012 14:26:57




  

Betrifft: AW: =((C9=0)*(E9>0))+(C9>0)*((C9<2500)+(C9>4500)) von: Snewi
Geschrieben am: 03.04.2012 14:32:44

so gehts :-)

Danke für eure Unterstützung :-)


  

Betrifft: Alternativen von: Erich G.
Geschrieben am: 03.04.2012 14:46:51

Hi,
hier zwei Alternativen (unterscheiden sich nur bei negativen Werten in C9):

 G
90
100

Formeln der Tabelle
ZelleFormel
G9=(C9=0)*(E9>0) + (0<>C9)*(C9<2500) + (4500<C9)
G10=(C9=0)*(E9>0) + (0<C9)*(C9<2500) + (4500<C9)


@Rudi: Tja, wir tun's - trotzdem... ;-)
@Rudi: (C9>0) mit (C9>4500) multiplizieren? Kann man, muss man aber nicht...

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: so kaum sinnvoll von: Erich G.
Geschrieben am: 03.04.2012 14:17:16

Hi Snewi,
die zweite Bedingung kommt nie zum Tragen:

Wenn C9 = 0 ist , kommt in F eine 1, weil C9 < 2500 ist. Was in E9 steht, spiel keinerlei Rolle.

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: so kaum sinnvoll von: Snewi
Geschrieben am: 03.04.2012 14:19:45


Doch das ist wichtig ich muss wissen wenn in C9 eine 0 steht ob in E9 ein Wert > 0 ist!!
Deswegen muöchte ich das auch getrennt in einer Formel sehen!



Gruß


  

Betrifft: AW: so kaum sinnvoll von: Erich G.
Geschrieben am: 03.04.2012 14:28:22

Hi,
dann musst du die Bedingung "C9 < 2500" durch etwas anderes ersetzen,
denn die erschlägt den Fall C9=0 nebenbei mit (wie C9=1 oder C9=5 oder C9=-7).

Vielleicht meinst du es ja so:

F9=1, wenn
C9 größer als 4500
oder
(C9 größer als 0 und kleiner als 2500)
oder
(C9 = 0 und E9 größer als 0)
sonst F9 = 0

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Erich: warum tun wir uns das an? ;-) owT von: Rudi Maintaire
Geschrieben am: 03.04.2012 14:30:16




  

Betrifft: Entweder du füllst "C" aus oder ... von: Reinhard
Geschrieben am: 03.04.2012 16:58:27

Hallo Snewi,

nicht.
Im letzteren Fall mache ich nicht mit am fröhlichen Ratespiel nach deiner Bedingungslogik.
Und bitte, gewissenhaft ausfüllen, jeder Falscheintrag von dir macht mir nur doppelte Arbeit.

Gruß
Reinhard


Beiträge aus den Excel-Beispielen zum Thema "2 Formeln zu einer"