Microsoft Excel

Herbers Excel/VBA-Archiv

2 Listen in eine bereinigte Liste | Herbers Excel-Forum


Betrifft: 2 Listen in eine bereinigte Liste von: Mathias
Geschrieben am: 18.10.2008 14:25:18

Hallo,

folgende Beispieldatei:

https://www.herber.de/bbs/user/56093.xls

Die ersten beiden Listen möchte ich in die dritte Liste überführen und alle Leerzellen dabei entfernen.

Hat jemand eine Idee, wie ich dass per Excelformel (nicht VBA) hinbekommen könnte?

Ich bekomme es irgendwie nicht hin.

Viele Grüße

Mathias

  

Betrifft: AW: 2 Listen in eine bereinigte Liste von: Beate Schmitz
Geschrieben am: 18.10.2008 14:36:43

Hallo Mathias,

schau mal hier: http://www.online-excel.de/fom/fo_read.php?f=1&bzh=31747&h=31626

Und dort die Formel aus E1.

Gruß,
Beate


  

Betrifft: AW: 2 Listen in eine bereinigte Liste von: Daniel
Geschrieben am: 18.10.2008 14:37:45

Hi

wenn du für komplexe Probleme eine Formellösung suchst, sollte immer diese Addresse deine erste Anlaufstelle sein:

www.excelformeln.de

für dein Problem könnte das hier die Lösung sein (die letze Ergänzung)

http://www.excelformeln.de/formeln.html?welcher=43
{=WENN(ZEILE(A1)>ANZAHL2(A:B);"";WENN(ZEILE(A1)>ANZAHL2(A:A);INDEX(B:B; KKLEINSTE(WENN(B$1:B$99<>"";ZEILE($1:$99));ZEILE(A1)-ANZAHL2(A:A)));INDEX(A:A; KKLEINSTE(WENN(A$1:A$99<>"";ZEILE($1:$99));ZEILE(A1))))) }

das ist eine Matrixformel, dh. Eingabe erfolgt ohne die geschweiften Klammern und muss mit STRG+SHIFT+ENTER abgeschlossen werden

Gruß, Daniel


  

Betrifft: auch bei Excelformeln.de - Lückenlos von: Beate Schmitz
Geschrieben am: 18.10.2008 14:45:33

Schau mal hier:

http://www.excelformeln.de/formeln.html?welcher=43

Zwei Spalten mit Leerzellen ohne Lücken auflisten:

Ergänzung vom 24.09.2008
2 lückenhafte Spalten - hier A und B - lückenlos in einer untereinander (die Spalten müssen nicht nebeneinander liegen):
{=WENN(ZEILE(A1)>ANZAHL2(A:B);"";WENN(ZEILE(A1)>ANZAHL2(A:A);INDEX(B:B; KKLEINSTE(WENN(B$1:B$99<>"";ZEILE($1:$99));ZEILE(A1)-ANZAHL2(A:A)));INDEX(A:A; KKLEINSTE(WENN(A$1:A$99<>"";ZEILE($1:$99));ZEILE(A1))))) }

Gruß,
Beate


  

Betrifft: AW: auch bei Excelformeln.de - Lückenlos von: Mathias
Geschrieben am: 18.10.2008 17:49:01

Hallo,

erstmal vielen Dank für die ausführlichen Tipps!!! Das hift mir schonmal etwas weiter.

Folgenden Bandwurm habe ich mal für die beiden Listen in

B3:B30 und F3:F30 erstellt:

{=WENN(ZEILE(B1)>ANZAHL2(B:F);"";WENN(ZEILE(B1)>ANZAHL2(B:B);INDEX(F:F; KKLEINSTE(WENN(F$3:F$30<>""; ZEILE($3:$30));ZEILE(B1)-ANZAHL2(B:B)));INDEX(B:B; KKLEINSTE(WENN(B$3:B$30<>"";ZEILE($3:$30)); ZEILE(B1))))) }



Doch aus irgendeinem Grunde wirft erscheint für F3 nur "#ZAHL!" und am Ende der Liste fehlt F30.

Kann eigentlich nur ein klitzekleiner Fehler sein, aber ich find ihn einfach nicht.

Muss irgendwo noch ein +1 oder -1 rein???

Viele Grüße

Mathias


  

Betrifft: AW: auch bei Excelformeln.de - Lückenlos von: Daniel
Geschrieben am: 18.10.2008 18:00:58

Hi
wennd du ne Fehlerkorrektur haben willst, solltest du am besten die Datei hochladen.
das erspart langwieriges Rätselraten.
außderdem sollte man wissen, in welche Zelle du die Formel geschrieben hast, sonst kann man nicht beurteilen, ob die relativen Zellbezüge richtig sind.


ansonsten müsste eigentlich von der Logik her dieser Teil der Formel: ANZAHL2(B:F) so lauten: (Anzahl2(B:B)+Anzahl2(F:F))

Gruß, Daniel


  

Betrifft: AW: auch bei Excelformeln.de - Lückenlos von: Mathias
Geschrieben am: 18.10.2008 18:14:52

Hi Daniel,

ok, hier ist die Testdatei

https://www.herber.de/bbs/user/56095.xls

Viele Grüße

Mathias


  

Betrifft: AW: auch bei Excelformeln.de - Lückenlos von: Daniel
Geschrieben am: 18.10.2008 18:29:01

Hi

ganz einfach:
Anzahl2(B:B) zählt natürlich auch die Überschriften mit, deinen Wertebereich schränkst du aber auf die Zeilen 3:30 ein. das passt natürlich nicht zusammen.
dh. du musst beim Zählen der Anzahl der ausgefüllten Zellen dann auch den Zellbereich auf die Zeilen 3:30 beschränken.
Hier bitte beachten, daß der Zellbezug absolut gesetzt werden muss, das gilt für alle ANZAHL2-Funktionen
Gruß, Daniel


  

Betrifft: ERLEDIGT AW: auch bei Excelformeln.de - Lückenlos von: Mathias
Geschrieben am: 18.10.2008 19:38:50

Hallo,

vielen Dank nochmal an alle für die Tipps.

Der letzte Hinweis von Daniel war der entscheidende Tipp.

Jetzt funktionierts wunderbar :-)

Viele Grüße

Mathias


  

Betrifft: AW: Lückenlos - zwei Spalten von: Erich G.
Geschrieben am: 18.10.2008 19:26:14

Hallo Mathias,
probier mal

 BCDEFGHIJKLMNOPQ
2Liste 1   Liste 2          Bereinigte Liste
31   a          1
42   b          2
3028   äää          28
31               a
32               b

Formeln der Tabelle
ZelleFormel
Q3{=WENN(ZEILE(B1)>ANZAHL2(B:B)+ANZAHL2(B:B)+1;""; WENN(ZEILE(B1)>=ANZAHL2(B:B); INDEX(F:F;KKLEINSTE(WENN(NICHT(ISTLEER(F$3:F$100)); ZEILE($3:$99)); 1+ZEILE(B1)-ANZAHL2(B:B))); INDEX(B:B;KKLEINSTE(WENN(NICHT(ISTLEER(B$3:B$100)); ZEILE($3:$99)); ZEILE(B1)))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


Beiträge aus den Excel-Beispielen zum Thema "2 Listen in eine bereinigte Liste"