Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für Verzinsung von Ratensparvertrag | Herbers Excel-Forum


Betrifft: Formel für Verzinsung von Ratensparvertrag von: JogyB
Geschrieben am: 18.10.2008 12:37:53

Hallo zusammen.

Ich möchte den Endbetrag eines Ratensparvertrages für jedes Jahr der Laufzeit in einer Tabelle anzeigen lassen.

Aufbau (Werte starten in Zeile 2):
A: Laufzeit in Jahren
B: Betrag nach x Jahren
C2: Einzahlungsbetrag pro Jahr (wird der Einfachheit halber als Einzahlung zum Jahresanfang angenommen)
D2: Verzinsung in % (Zellenformat Prozent)
E: Hilfspalte mit der Formel =$C$2*(1+$D$2)^A2

In B2 steht dann momentan =Summe($E$2:E2) und das eben runtergezogen bis zum Ende der Laufzeit.

Ich würde das nun gerne ohne Hilfspalte lösen.

Mit {=SUMME($C$2*(1+$D$2)^ZEILE(1:20))} oder {=SUMME($C$2*(1+$D$2)^ZEILE($A$2:A21))} bekomme ich natürlich den Wert nach 20 Jahren.

Nur wie gebe ich das so ein, dass ich nicht in jeder Zeile die Formel von Hand anpassen muss? Der Rückgabewert der Matrixformel ist kein Vektor, also bringt es nichts, die Matrixformel in einen Bereich zu schreiben.

Tja, und jetzt bin ich mit meinem Latein am Ende und hoffe auf die Formelgötter ;).

Ach ja: Bitte keine UDF, dass es damit mit ein paar Zeilen Code geht ist mir auch klar, will das aber gerne ohne VBA lösen.

Danke und Gruss, Jogy

  

Betrifft: AW: Formel für Verzinsung von Ratensparvertrag von: Gerd L
Geschrieben am: 18.10.2008 13:08:44

Hallo Jogy !

=SUMME($C$2*(1+$D$2)^(ZEILE()-1))

Hierbei: ZEILE() minus Anzahl der Zeilen vor der ersten Zelle mit dieser Formel.

Gruß Gerd


  

Betrifft: AW: Formel für Verzinsung von Ratensparvertrag von: JogyB
Geschrieben am: 18.10.2008 15:33:38

Hi.

Irgendwie komme ich da nicht weiter... vielleicht mache ich aber auch was falsch.

Hier kommt ebenfalls kein Vektor raus, d.h. wenn ich es über mehrere Zeilen mache, steht auch wieder in jeder Dasselbe. Und zwar jedesmal der Maximalbetrag, der sich aus der Anzahl der verwendeten Zeilen ergibt, d.h. wenn ich es in 5 Zeilen eintage, kommt dann kommt das Ergebnis nach 5 Jahren.

Gruss, Jogy


  

Betrifft: AW: Formel für Verzinsung von Ratensparvertrag von: Gerd L
Geschrieben am: 18.10.2008 16:17:45

Hallo Jogy,

wenn Dir das nicht kompliziert genug ist, bin ich raus ;-)

 CD
21005,00%
3  
4105,00 
5110,25 
6115,76 
7121,55 
8127,63 

Formeln der Tabelle
ZelleFormel
C4=SUMME($C$2*(1+$D$2)^(ZEILE()-3))
C5=SUMME($C$2*(1+$D$2)^(ZEILE()-3))
C6=SUMME($C$2*(1+$D$2)^(ZEILE()-3))
C7=SUMME($C$2*(1+$D$2)^(ZEILE()-3))
C8=SUMME($C$2*(1+$D$2)^(ZEILE()-3))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Gerd


  

Betrifft: AW: Formel für Verzinsung von Ratensparvertrag von: JogyB
Geschrieben am: 18.10.2008 16:50:29

Hi.

Das ist nicht das was ich gemeint hatte, das ist ja dasselbe, was meine Hilfsspalte auch schon macht - die Summe bewirkt bei Dir ja nichts und damit bleibt letztendlich die Formel übrig, die ich in Spalte E habe (nur dass Du die Zeile-Funktion nutzt anstatt des Jahreswertes aus Spalte A - und der bleibt der Übersichtlichkeit beim Drucken halber in jedem Fall drin).

Was ich haben will ist die Summe der Werte in Spalte C bis zum entsprechenden Jahr - und zwar für jedes Jahr (das entspricht dann dem jeweils aktuellen Guthaben aus dem Ratensparvertrag). Und das würde ich gerne in einer Zelle erledigen, also ohne Spalte C explizit berechnen zu müssen.

Gruss, Jogy


  

Betrifft: AW: Formel für Verzinsung von: Erich G.
Geschrieben am: 18.10.2008 18:00:42

Hallo Jogy,
meinst du das so? (Formel von B2 nach unten kopieren)

 ABCD
1nach JahrBetragJährl. Einz.Zinssatz
211051005%
32215,25  
43331,0125  
54452,563125  
65580,1912813  
76714,2008453  
87854,9108876  

Formeln der Tabelle
ZelleFormel
B2{=SUMME($C$2*(1+$D$2)^A$2:A2)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Formel für Verzinsung von: JogyB
Geschrieben am: 18.10.2008 19:29:52

Hi Erich.

Danke, funktioniert... und eine meiner Matrixformeln aus dem Ausgangsposting funktioniert ebenso (bis auf den kleinen Fehler dass es Zeile(A$1:A1) und nicht Zeile(A$2:A2) heissen muss).

Ist echt seltsam, das hatte ich eigentlich mal ausprobiert und dabei die Fehlermeldung bekommen, dass der Teile eines Arrays nicht geändert werden könnten... aber wahrscheinlich hatte ich da die Matrixformel schon in mehrere Zeilen eingegeben. Naja, manchmal sieht man echt den Wald vor lauter Bäumen nicht mehr.

Gruss, Jogy


Beiträge aus den Excel-Beispielen zum Thema "Formel für Verzinsung von Ratensparvertrag"