Update einer "alten" Formel (hallo Volker C)



Excel-Version: 2000
nach unten

Betrifft: Update einer "alten" Formel (hallo Volker C)
von: Niko
Geschrieben am: 08.05.2002 - 18:23:07

Hallo,

ich hatte vor kurzem mein Problem geschildert und hatte von Volker eine richtige Antwort erhalten.

Das Problem war wie folgt:
---------------------------------------------------------
Ich möchte eine Liste von Zahlen entsprechend formatiert haben:
Er soll aus Nachkommazahlen die zwischen 2",00" und 2",49" immer auf ",50" runden. Aus 2",51" bis 2",89" immer ",90" machen.

Ergebnis: 2,50 und 2,90 (die Vorkommazahlen sollen als "variablen" betrachtet werden.)

Wenn die gesamte Zahl jedoch höher als 149,99 ist, dann soll immer auf die nächste ganze Zahl aufgerundet werden.
-----------------------ANTWORT---------------------

=WENN(B1=150;150;WENN(B1<149,99;WENN(B1-GANZZAHL(B1)<=0,5;GANZZAHL(B1)+0,5;WENN(B1-GANZZAHL(B1)>0,5;GANZZAHL(B1)+0,9));GANZZAHL(B1)+1))
siehe auch: https://www.herber.de/forum/archiv/116to120/t118013.htm

NEU SOLL SEIN:
O.g. funktioniert einwandfrei. Jetzt soll die Formel allerdings auch ",20"; ",70"; berücksichtigen. Also im ganzen: ",20"; "0,50; ",70"; ",90"

Also: Er soll aus Nachkommazahlen die zwischen
2",00" und 2",20" immer auf ",20" runden
2",21" bis 2",50" immer auf ",50" runden
2",51" bis 2",70" immer auf ",70" runden
und aus 2",71" bis 2",90" immer auf ",90" runden.

Das geht, aber wie? :-)


nach oben   nach unten

Erweiterte Formel ...
von: Volker Croll
Geschrieben am: 08.05.2002 - 19:23:25

Hallo Niko,

nach Deinen neuen Vorgaben sieht es jetzt so aus (zusaetzlich habe ich noch abgefangen, wenn in B1 nichts steht):

=WENN(B1="";"";WENN(B1=150;150;WENN(B1<149,99;WENN(B1-GANZZAHL(B1)<=0,2;GANZZAHL(B1)+0,2;WENN(B1-GANZZAHL(B1)<=0,5;GANZZAHL(B1)+0,5;WENN(B1-GANZZAHL(B1)<=0,7;GANZZAHL(B1)+0,7;WENN(B1-GANZZAHL(B1)>0,7;GANZZAHL(B1)+0,9))));GANZZAHL(B1)+1)))

Aber - nicht angegeben hast Du, was z.B. aus genau 2,00 werden soll? Wohin willst Du runden zwischen 2,91 bis 3,00 ? Probier mal, ob das jetzt gelieferte Ergebnis fuer diese Faelle auch passt.

Gruss Volker

nach oben   nach unten

Hallo Volker
von: Niko
Geschrieben am: 08.05.2002 - 20:32:21

Vielen Dank für Deine Hilfe!

Ja, Deine Formel hat geklappt!

"...nicht angegeben hast Du, was z.B. aus genau 2,00 werden soll? Wohin willst Du runden zwischen 2,91 bis 3,00 ? Probier mal, ob das jetzt gelieferte Ergebnis fuer diese Faelle auch passt."

Da hast Du recht, angegeben habe ich das nicht, jedoch habe ich daran gedacht. ;-) Ziel wäre es, aus den Werten zwischen 1",91" und 2",00" eine 2",20" zu machen. Beispiel: Aus 19",99" wird 20",20".

Ich habe mir dabei gedacht das es "schwer" ist bzw. "für Dich" einen grossen Aufwand erfordern würde.

nach oben   nach unten

Auch das geht ...
von: Volker Croll
Geschrieben am: 09.05.2002 - 11:48:38

Hallo Niko,

jetzt sollten wir ein wenig umbauen -> 1. Die bisherige Formel ersetzten durch:

=WENN(B1="";"";WENN(B1=150;150;WENN(B1<149,99;WENN(B1-D1<=0,2;D1+0,2;WENN(B1-D1<=0,5;D1+0,5;WENN(B1-D1<=0,7;D1+0,7;WENN(B1-D1<=0,9;D1+0,9;WENN(B1-D1<1;D1+1,2;D1+1))))))))

2. Damit diese Formel funktioniert brauchen wir eine Hilfsspalte. In meinem Beispiel habe ich D genommen, dann in D1:

=GANZZAHL(B1)

Falls Du eine andere Spalte nehmen willst/musst, dann eben in erster Formel D1 entsprechend ersetzen.

Die Hilfspalte kannst Du dann ueber FORMAT > SPALTE > AUSBLENDEN unsichtbar werden lassen.

Gruss Volker

nach oben   nach unten

Re: Auch das geht ...
von: Niko
Geschrieben am: 09.05.2002 - 13:46:48

Hallo Volker,

vielen Dank für Deine weitere Hilfe! Hat wunderbar geklappt und Du weisst garnicht (oder vielleicht in etwa doch) wieviel Zeit Du mir erspart hast. EINEN GROSSEN DANK - NIKO!


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Update einer "alten" Formel (hallo Volker C)"