Das Archiv des Excel-Forums

Per Formel oder VBA Minus und Pluswerte summieren

Bild

Betrifft: Per Formel oder VBA Minus und Pluswerte summieren
von: chris b

Geschrieben am: 02.10.2003 09:38:32

Hallo Excel Profis ,
eine frage und zwar ist es irgendwie möglich + und - summen getrennt zusammenzurechen?
Ich habe eine datei in der stehen untereinander werte wie hier:

Zeile1 Liste
Zeile2 20
Zeile3 test
Zeile4 -30
Zeile5 25
Zeile6 -130
Zeile7 test2
usw...


Manche werte sind Minuswerte und manche + , ich möchte jetzt gerne mit einer Formel nur die Negativen - Werte in einer anderen zelle zusammengerechnet haben und in einer anderen Zelle nur die positive + Werte.
So müsste also in einer Spalte stehen "- 160" und in einer anderen Spalte "+45" wenn das möglich ist würde ich mich riesig über Hilfe freuen.
UNd am besten noch wenn ihr mir für beide Arten(Makro und Formel) einen Tipp geben könnten ! Danke gruß christian
Bild


Betrifft: AW: Per Formel oder VBA Minus und Pluswerte summieren
von: Mac4:julia
Geschrieben am: 02.10.2003 09:47:42

Hallo Chris,

das müsste eigentlich mit Summewenn zu bewerkstelligen sein:

=SUMMEWENN(A1:A100;"<0") bzw.
=SUMMEWENN(A1:A100;">0")

Marc


Bild


Betrifft: AW: Per Formel oder VBA Minus und Pluswerte summieren
von: chris b
Geschrieben am: 02.10.2003 10:30:27

Jo vielen Dank Julia !


Bild


Betrifft: AW: Per Formel oder VBA Minus und Pluswerte summieren
von: Hans W. Herber
Geschrieben am: 02.10.2003 09:48:19

Hallo Chris,

für das eine:
=SUMMEWENN(A:A;">0";A:A)

und das andere:
=ABS(SUMMEWENN(A:A;"<0";A:A))

gruss hans


Bild


Betrifft: AW: Per Formel oder VBA Minus und Pluswerte summieren
von: chris b
Geschrieben am: 02.10.2003 10:31:20

Thx Hans mal wieder für die schnelle Antwort !!!


 Bild

Excel-Beispiele zum Thema " Per Formel oder VBA Minus und Pluswerte summieren "

Anzeigen von Werten und Formeln download Zeile einfügen und Formeln und Werte übernehmen download
Formeln mit Zelladressen speichern download Zeilenumbruch in Formel erzwingen download
Aktueller Arbeitsblattname in Formel download Variable in Formel einbauen download
Ein Zeichen in einer Formel suchen download Variable in Excel-Formel einbauen. download
Summenformel unter Zahlenreihe eintragen download Arbeitszeittabelle und SVERWEIS-Formel download
Zeilen mit leeren Formeln beim Druck unterdrücken download Ausgabe einer benutzerdefinierten Funktion in Matrixformel download
Listung der mit der Formel KOMBINATIONEN() ermittelten Elemente download Alle Formeln und Links in Werte wandeln download
Formel bis zur letzten Zeile der Nebenspalte kopieren download Summenformel per VBA eintragen download
Namen löschen ohne Formeln zu zerstören download Anzeige der Formel mit Quellblattangabe download
Alle Formeln und Zahlen löschen download Textstring in berechenbare Formel umwandeln download
Spielpaarungen von Vorrunde bis Finale durch Formeln ermitteln download Zahlenstring mit Formel auslesen und Fehlermeldung verhindern download
Wahrheitsprüfung einer mit Zellwerten zusammengestzten Formel download SVERWEIS-Formel über mehrere Fundstellen download
Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel download SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele download
Beispiel für die Anwendung der SUMMEWENN-FORMEL download Datei auswählen, öffnen und Formelsuchdialog anzeigen download
Formelbereich in Einzelelemente aufschlüsseln download Signal, wenn sich Formelwert über eine Grenze bewegt download
Formeleingabe über ShortCut download UserForm-Aufruf, wenn Formel-Wert Grenze überschreitet download
In Abhängigkeit von einem Formelwert Makro starten download In Abhängigkeit von einem Formelwert Mail mit Outlook versenden download
Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel download Sortierung mit Formel-Leerstrings am Ende download
Nach Formelkalkulation Zellwert erhöhen download Markierung von Formeln über bedingte Formatierung download
Zellschutz nur für Formeln download Text in Formel und Formel in Text download
Blatt ohne Code, Steuerelement und Formeln speichern download Zählen von in einer Formel vorkommenden Zahlen download
Temporärer VBA-Einsatz einer Matrixformel download Eintragen von Matrixformeln in eine Jahres-/Monatsmatrix download
Dynamischer Blattname in SVERWEIS-Formel download Bei Eintrag Übernahme der Formel aus Nebenzelle download
TextBox-Eingabe mit Formel weiterberechnen und zurückgeben download Formeltexte anzeigen download
Formel zur Ermittlung von Ostersonntag download Ermittlung von Datenbank- und Array-Formelergebnissen per VBA download
Werte eins bestimmten Monats summieren download Spalten bedingt summieren und Zellen formatieren download
Ab der aktiven Zelle summieren download Zellen nach Schriftfarbe summieren download
Tabelle nach mehreren Kriterien summieren download Werte summieren, in erste freie Zeile eintragen, Differenz errechnen download
Wahlweise gerade oder ungerade Zeilen summieren download Stunden und Minuten getrennt summieren download
Bei Änderung der Kostenstelle Werte summieren download Zahlen unter Berücksichtigung von Monat und Jahr summieren download
Unter Berücksichtigung von Anfang/Ende-Datumsangaben summieren download Werte in Abhängigkeit zur Währungsformatierung summieren download
Monatsblätter in Abhängigkeit ihres Namens summieren download Werte in Abhängigkeit von CheckBox-Aktivierung summieren download
Monatsbereiche aus Folgeblättern summieren download Eine Zeile mit vorgegebenem Interall summieren download
Nach unterschiedlichen Währungen summieren download Summieren von Werten mit gleicher Schriftfarbe download
Werte gem. Start- und Endmonat summieren download Gefilterte Daten summieren download
Nach Währung und Zeitspannen summieren download Nach Wochentagen summieren download
Zeiten summieren download Tabelle gem. Baugruppenbezeichnungen summieren download