Spalten auslesen per Formel oder VBA

Bild

Betrifft: Spalten auslesen per Formel oder VBA
von: Josef Thelen
Geschrieben am: 04.03.2005 22:44:16
Hallo Forum,
habe eine Arbeitsmappe mit den TB: "Auswertung" und "MA3 bis MA45".
(In diesem Programm, sollen die Fehlstunden vom ganzen Jahr ermittelt werden.)
Nun möchte ich gerne aus den TB: "MA3 bis MA45" jeweils die Fünfzehnte Spalte,
also "O3:O400" mit SUMMEWENN auslesen und das Ergebnis in das TB "Auswertung" in "B3" eintragen. Es soll immer nur ein TB ausgelesen werden. Der Aufruf, soll aus dem TB "Auswertung" D3 erfolgen. (Ich möchte in "Auswertung" D3, z.B. MA5 eingeben, dann soll nur das Ergebnis aus "MA5" in "Auswertung" B3 eingetragen werden). Beim Aufruf eines anderen TB, soll der Wert in "B3" überschrieben werden.
Ich möchte Euch bitten, mir bei diesem Problem zu helfen.
Vielen Dank schon mal im voraus!
Mit freundlichen Grüssen
Josef Thelen

Bild

Betrifft: =SUMMEWENN(INDIREKT("'"&B3&"'!O3:O400");">0")
von: Boris
Geschrieben am: 04.03.2005 22:49:04
Hi Josef,
summiert dir alle Werte größer Null aus O3:O400 des in B3 vorgegebenen Blattes.
Grüße Boris
Bild

Betrifft: AW: =SUMMEWENN(INDIREKT("'"&B3&"'!O3:O400");">0")
von: Josef Thelen
Geschrieben am: 05.03.2005 00:27:44
Hallo Sepp und Boris,
beide Vorschläge arbeiten genau so, wie ich es mir vorgestellt habe.
Vielen Dank Euch beiden.
Mit freundlichen Grüssen
Josef Thelen
PS: Best Off
Bild

Betrifft: AW: Spalten auslesen per Formel oder VBA
von: Josef Ehrensberger
Geschrieben am: 04.03.2005 22:51:00
Hallo Namensvetter!
Meinst du so?
 
 BCD
360 MA5
Formeln der Tabelle
B3 : =SUMMEWENN(INDIREKT(D3&"!O3:O400");">10";INDIREKT(D3&"!O3:O400"))
 


Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild

Betrifft: Ich würde die Hochkommata immer dazusetzen
von: Boris
Geschrieben am: 04.03.2005 22:53:04
Hi Sepp,
...wenngleich sie hier (weil offensichtlich ohne Leerzeichen) nicht von Nöten sind - aber sicher ist irgendwie sicher...;-)
Grüße Boris
Bild

Betrifft: AW: Ich würde die Hochkommata immer dazusetzen
von: Josef Ehrensberger
Geschrieben am: 04.03.2005 22:56:20
Hallo Boris!
Das mach ich sonst eigentlich immer, aber hier hab ich in
der Eile darauf verzichtet;-)

Gruß Sepp
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Spalten auslesen per Formel oder VBA"