Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn mit mehreren Variablen | Herbers Excel-Forum


Betrifft: Zählenwenn mit mehreren Variablen von: Gorkij
Geschrieben am: 29.01.2010 09:33:50

Hallo,
habe ein kleines Problem mit der ZÄHLENWENN-Funktion:
Ich möchte die Funtion von mehreren Variablen abhängig machen, wobei es sich um eine Oder-Verknüpfung handeln soll, das heißt, wenn eines von mehreren Kriterien erfüllt ist soll diese "Ereignis" gezählt werden.
Bsp.: in Der Spalte A stehen in den Zeilen 1 - 3 Äpfel, Birnen, Bananen,
gesucht wird nach Äpfel und Birnen, der Wert in der Zelle mit der Zählenwenn-Funktion müsste hier also 2 sein.
Obendrein sollen die Suchbegriffe variabel sein, d.h., sie sollen nicht in eine Formel aufgenommen werden, sondern an anderer Stelle in der Tabelle aufgeführt werden.
Geht das?

  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: Hajo_Zi
Geschrieben am: 29.01.2010 09:39:20

Hallo Gorkij,

für den ersten Teil.
Zählenwenn erweitern
=SUMME(ZÄHLENWENN(C1:C12;{"ja"."u"}))
Die Matrixkonstante {"ja"."u"} kannst du um beliebige Suchbegriffe erweitern.
von Boris

GrußformelHomepage


  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: Gorkij
Geschrieben am: 29.01.2010 09:59:57

Hallo Hajo,
wie bei deinen Antworten kaum anders zu erwarten: Es funktioniert.
Der Wermutstropfen besteht jetzt darin, dass die zweite Idee offenbar so nicht zu verwirklichen ist; überlege daher, "Hilfszellen " mit mehreren einfachen Zählenwenn-Abfragen einzurichten und dann die Summe dieser Zellen als Ergebnis auszuweisen. Zwar nicht elegant, aber da die Tabelle von Leuten benutzt werden soll, die noch weniger von excel verstehen als ich zumindest praktikabel, solltste Du noch eine andere Idee haben, wäre das natürlich schön.
Danke dir und wünsche dir einen schönen und hoffentlich rutschfreien Tag.
Gorkij


  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: Josef Ehrensberger
Geschrieben am: 29.01.2010 10:16:10

Hallo Gorkij,

eine Möglichkeit.

Tabelle1

 ABCDEFGH
1a  Suchbegriffe:fda 
2c  Anzahl:17   
3f       
4b       
5d       
6a       
7c       
8b       
9d       
10e       
11f       
12a       
13b       
14c       
15f       
16d       
17a       
18b       
19e       
20d       
21f       
22c       
23b       
24d       
25f       
26c       
27d       
28e       
29a       
30f       

Formeln der Tabelle
ZelleFormel
E2{=SUMME(WENN((A1:A30=E1:H1)*(E1:H1<>""); 1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: Gorkij
Geschrieben am: 29.01.2010 10:32:38

.... Und was ffür eine!!!
Hab's ausprobiert und nach einigem Ruckeln (Fehler zwischen Monitor und Rückenlehne) funktionierte es.
Danke dir
da ich aus dem Ländlichen komme:
Holl' Di senkrecht!!
Gorkij


  

Betrifft: Zählenwenn mit mehreren Variablen von: jockel
Geschrieben am: 29.01.2010 10:39:59

eine ähnliche mit kriterien untereinander... den bereich ist kann man dan recht groß wählen einträge in diesen bereich hinzufügen oder löschen, und: man könnte diese (hilfs)spalte ausblenden...


Tabelle1

 ABCDEFGHI
1a    Suchbegriffe:fda  f
2c    Anzahl:17      d
3f    Anzahl:22      a
4b               
5d               
6a               
7c              c
8b               
9d               
10e               
11f               
12a               
13b               
14c               
15f               
16d               
17a               
18b               
19e               
20d               
21f               
22c               
23b               
24d               
25f               
26c               
27d               
28e               
29a               
30f               

verwendete Formeln
Zelle Formel
E2 {=SUMME(WENN((A1:A30=E1:G1)*(E1:G1<>""); 1))}
E3 {=SUMME((A1:A100<>"")*(A1:A100=MTRANS(I1:I10)))}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.5






  

Betrifft: AW: Name Jockel von: Hajo_Zi
Geschrieben am: 29.01.2010 10:59:59

Hallo Jockel,

wird der Name jetzt 2x Personen im Forum benutzt?
nach dem Abspann würde ich vermuten es ist Jörg?
Jockel habe ich aber auch schon mit der Unterschrift Joachim gesehen

GrußformelHomepage


  

Betrifft: @ Hajo... von: jockel
Geschrieben am: 29.01.2010 11:30:45

jepp, du hast mich erwischt - ich bin's jörg ;-) dass es (jetzt) noch einen Jockel gibt, habe ich bemerkt..., aber so ist das halt. mit meinen (user-)namensvetter habe ich nix zu tun... :-)

cu soon jörg


  

Betrifft: AW: @ Jörg von: Hajo_Zi
Geschrieben am: 29.01.2010 11:35:28

Hallo Jörg,

das ist dann das Problem in diesem Forum, den ersten Jockel erkennt man nur an seiner Signatur.

Gruß Hajo


  

Betrifft: AW: @ Jörg von: jockel
Geschrieben am: 29.01.2010 11:44:55

ich sehe hier kein problem... was ist so schlimm daran, dass es zwei gibt einen großen Jockel und einen kleinen (kleines licht) ?

cu jörg


  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: Gorkij
Geschrieben am: 29.01.2010 12:28:32

Es funktioniert, aber jetzt hat mich der Ehrgeiz gepackt:
Suchbereich sollen jetzt die Zellen in d14 - ae14 sein, in ag 14 soll über deine Formel ausgewiesen werden, wie oft die in p7-vz eingetragenenen Werte enthalten sind. Wenn ich deine Formel entsprechend übertrage bekomme ich als Wert #NV; ohne dass ich den Fehler entdecken könnte.
Muss noch etwas geändert werden, wenn in Zeilen statt Spalten gesucht wird?
liebe Grüße
Gorkij


  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: jockel
Geschrieben am: 29.01.2010 12:44:01

hi Gorkij, was heißt "...wie oft die in p7-vz eingetragenenen Werte enthalten sind..."?

cu jörg


  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: Gorkij
Geschrieben am: 29.01.2010 12:50:35

Entschuldige, Tippfehler: Es muss heißen in p7 - v7, d.h., in der Zeile 7 sind in den Spalten p - v Werte (Buchstaben) eingetragen, dern Häufigkeit in den Zeilen d14 - ae 15 festgestellt werden soll.
Wenn also etwa in d14 und in f 15 je ein "s" eingetragen ist und in p7 ebenfalls ein "s" steht sollte das Ergebnis "2" sein.
Wie gesagt, bei der Suche in d14 - d87 nach Werten aus Zeile d7 bis j7 funktioniert das tadellos.
Schónmal Danke für deine Bemühungen


  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: jockel
Geschrieben am: 29.01.2010 13:02:30

hi Gorkij, meinst du so?


offen

 DEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAH
1                                                            a
2                                                            b
3                                                            c
4                                                             
5                                                             
6                                                             
7                                                            s
8                                                             
9                                                             
10                                                             
11                                                             
12                                                             
13                                                             
14s                                                        2 
15    s                                                       

verwendete Formeln
Zelle Formel
AG14 {=SUMME((D14:AE14<>"")*(D14:AE14=AH1:AH100)+(D15:AE15<>"")*(D15:AE15=AH1:AH100))}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.5





cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: AW: Zählenwenn mit mehreren Variablen von: Gorkij
Geschrieben am: 29.01.2010 13:23:44

beinahe; nur dass die Suchkriterien nicht in AH 1 - ah100, sondern in Zeile p7 - v7 eingetragen sind.
Habe deine Formel kopiert und eingefügt, mit Eintrag von Suchkriterien in ah1 - ah 100 arbeitet sie auch, ändere ich sie aber ab, indem ich statt ah1:ah100 p7:v7 eingebe geht's nicht mehr.
Solltest Du antworten ärgere dich nicht, dass ich mich voraussichtlich erst morgen oder Montagmelde, habe jetzt nämlich noch ein paar Termine.
viele Grüße
Gorkij


  

Betrifft: bzw. ... von: jockel
Geschrieben am: 29.01.2010 13:25:15

mit der formel in AH15...:


vorschlag

 DEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAH
1                                                            a
2                                                            b
3                                                            c
4                                                             
5                                                             
6                                                             
7                        sau                              s
8                                                             
9                                                             
10                                                             
11                                                             
12                                                             
13                                                             
14s                                                        2 
15    s                                                    2 

verwendete Formeln
Zelle Formel
AG14 {=SUMME((D14:AE14<>"")*(D14:AE14=AH1:AH100)+(D15:AE15<>"")*(D15:AE15=AH1:AH100))}
AG15 {=SUMME((D14:AE14<>"")*(D14:AE14=(MTRANS(P7:V7)))+(D15:AE15<>"")*(D15:AE15=(MTRANS(P7:V7))))}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.5





cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: AW: bzw. ... von: Gorkij
Geschrieben am: 01.02.2010 08:20:14

Hallo Jörg,
es funktioniert - beide Formeln, die ich auch beide verwenden konnte.
Herzlichen Dank

Gorkij


Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mit mehreren Variablen"