Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Zählenwenn, variabler Bereich | Herbers Excel-Forum


Betrifft: Zählenwenn, variabler Bereich von: Hansi
Geschrieben am: 24.11.2009 09:44:51

Hallo Experten,

kann man in einer ZÄHLENWENN-Funktion den Bereich variabel angeben?

Ich wollte von Zeile 1 bis zur aktuellen Zeile ein Wort zählen lassen.

=Zählenwenn(B1:B & Zeile();"Test")

funktioniert leider nicht :-(

Gruß Hans

  

Betrifft: fast: =ZÄHLENWENN(B1:INDIREKT("B"&ZEILE());"Test") von: WF
Geschrieben am: 24.11.2009 10:03:40

.


  

Betrifft: Ich bin ja bei sowas immer... von: {Boris}
Geschrieben am: 24.11.2009 10:38:44

Hi Hansi,

...für die BEREICH.VERSCHIEBEN-Variante, weil sie die Bezüge dynamisch händelt (interessant, wenn mal Spalten eingefügt / verschoben werden):

=ZÄHLENWENN(BEREICH.VERSCHIEBEN(B$1;;;ZEILE());"Test")

Aber das Ergebnis ist natürlich erstmal das Selbe.

Grüße Boris


  

Betrifft: @Boris: d'accord !!!! :-)) _oT von: NoNet
Geschrieben am: 24.11.2009 10:51:58

_oT


  

Betrifft: prinzipiell ja - de facto nein von: WF
Geschrieben am: 24.11.2009 11:45:38

fügt vor Spalte B mal ein paar Spalten ein - INDIREKT funktioniert weiterhin.

Salut WF


  

Betrifft: Alles ein Sache der Anforderung von: {Boris}
Geschrieben am: 24.11.2009 12:13:09

Hi Walter,

in wahrscheinlich 99% aller Fälle ist die Bezugsanpassung gewünscht. Ein unverwüstlicher Bezug zu einer bestimmten Spalte (hier: B) ist imho die ganz klare 1%-Ausnahme. ;-)
Aber was sollen wir uns darüber den Kopf zerbrechen ;-))

Grüße Boris


  

Betrifft: Vielen Dank, klappt super! owT von: Hansi
Geschrieben am: 24.11.2009 11:47:30




Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn, variabler Bereich"