Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wennabfrage oder doch was anderes?

Wennabfrage oder doch was anderes?
30.03.2013 10:36:08
Simon
Hallo,
ich habe mal eine Datei mit Erklärung angehängt.
Ich bekomm es fast hin, nur hebeln sich bei mir die Wennabfragen gegenseitig aus, so das es immer einmal nicht funktioniert.
Die Berechnung soll jeweils bei Länge und Breite funktionieren.
Ich danke euch!
https://www.herber.de/bbs/user/84620.xls

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wennabfrage oder doch was anderes?
30.03.2013 10:52:27
hary
Hallo Simon
Meinst du das so?
Sheet1
 EF
811030

verwendete Formeln
Zelle Formel Bereich
E8 =WENN(ANZAHL2(H8:I8)=0;A8+(2*C2);A8-SUMME(H8:I8)) 
F8 =WENN(ANZAHL2(J8:K8)=0;B8+(2*C2);B8-SUMME(J8:K8)) 

Tabellendarstellung in Foren Version 5.30


gruss hary

Anzeige
AW: Wennabfrage oder doch was anderes?
30.03.2013 11:15:27
Simon
Hallo Hary,
das ist schon fast super!
nur funktioniert es noch nicht, wenn ich in H8/I8 nur eine Zahl angebe. Ich müsste dann ja in E8 auf A8+C2+H8 oder I8 kommen.
Dank dir schon mal und frohe Ostern!

AW: Wennabfrage oder doch was anderes?
30.03.2013 11:28:06
hary
Moin
Versteh ich nicht ganz. Hier mal 2 Moegliche Ergebnisse.
Sheet1
 EFGHIJK
811030  10  1010
911580         
1011575         

verwendete Formeln
Zelle Formel Bereich
E9 =WENN(ANZAHL2(H8:I8)=0;A8+(2*C2);A8+(ANZAHL2(H8:I8)*C2)+SUMME(H8:I8)) 
F9 =WENN(ANZAHL2(J8:K8)=0;B8+(2*C2);B8+(ANZAHL2(J8:K8)*C2)+SUMME(J8:K8)) 
E10 =WENN(ANZAHL2(H8:I8)=0;A8+(2*C2);A8+C2+SUMME(H8:I8)) 
F10 =WENN(ANZAHL2(J8:K8)=0;B8+(2*C2);B8++C2+SUMME(J8:K8)) 

Tabellendarstellung in Foren Version 5.30


gruss hary

Anzeige
AW: Wennabfrage oder doch was anderes?
30.03.2013 12:03:46
Simon
Die Rechnungen in E10, F10 sind schon fast richtig.
Wenn J=0 und K=0 dann ist F8 60, ist richtig
Wenn J=10 und K=0 dann ist F8 45, ist richtig
Wenn J=0 und K=10 dann ist F8 45, ist richtig,
aber wenn J=10 und K=10 dann ist ist F8 35. Soll aber ja nur 30 sein, da auf beiden Seiten der Platte eine Kante und somit B8 - J8 - K8.
ich sag ja, da hebelt sich immer etwas gegenseitig aus. Es ist zum wahnsinnig werden...

mal ohne ANZAHL2, dafür Matrixformel
30.03.2013 13:20:20
Erich
Hi Simon,
was meinst du dazu?
(Bitte achte auf den Hinweis zu Matrixformeln uín Zeile 9.
Die Formeln in Zeile 10 sind "normale" Formeln, dafür mit SUMMENPRODUKT.)
 ABCDEFGHIJK
6LängeBreite  LängeBreite vornehintenlinksrechts
7           
810050  11030   1010
9    11030     

Formeln der Tabelle
ZelleFormel
E8{=A8+SUMME(--(H8:I8=0))*C2-SUMME(H8:I8)}
F8{=B8+SUMME(--(J8:K8=0))*C2-SUMME(J8:K8)}
E9=A8+SUMMENPRODUKT(0+(H8:I8=0))*C2-SUMME(H8:I8)
F9=B8+SUMMENPRODUKT(0+(J8:K8=0))*C2-SUMME(J8:K8)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
Korrektur der Zeilennummern
30.03.2013 13:23:04
Erich
Hi Simon,
so sollte es da stehen:
(Bitte achte auf den Hinweis zu Matrixformeln in Zeile 8.
Die Formeln in Zeile 9 sind "normale" Formeln, dafür mit SUMMENPRODUKT.)
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

AW: Korrektur der Zeilennummern
30.03.2013 14:13:27
Simon
Erich, du bist ein Held!
bin Glücklich das ich nicht zu doof war, sondern es was war, was ich noch nicht kannte ;)
Funktionieren beide super!
Ganz schoene Oster noch!
Gruss Simon aus Wesseloh:)

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige