Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn mit variabler Referenz

Betrifft: Zählenwenn mit variabler Referenz von: daniel
Geschrieben am: 21.11.2012 10:04:35

Hallo Leute

Ich habe eine Tabelle mit 12 Spalten und Zellinhalte mit nummerischen Werten in jeder Zeile (teilweise auch leer). In der 13. Spalte (selbe Zeile) steht der Wert mit der Bedingung (Referenzwert für jede Zeile unterschiedlich)

Ich möchte nun zählen wieviele Zellen einer Zeile der gesuchten Bedingung entsprechen. Irgendwie tu ich mich schwer damit...!

In der Beilage ein Beispiel:

https://www.herber.de/bbs/user/82712.xls

Vielen Dank schon mal für die Unterstützung

Gruss

Daniel

  

Betrifft: AW: Zählenwenn mit variabler Referenz von: ChrisL
Geschrieben am: 21.11.2012 10:22:57

Hi Daniel

=ZÄHLENWENN(A2:L2;">="&M2)

cu
Chris


  

Betrifft: Zählenwenn passt schon ... von: Matthias L
Geschrieben am: 21.11.2012 10:23:31

Hallo

Tabelle1

 ABCDEFGHIJKLMN
1JanFebMrzAprMaiJunJulAugSepOktNovDezReferenzZählenwenn
2308040 50  207010  652
379 85   10    90822
430   1910 212131  204

Formeln der Tabelle
ZelleFormel
N2=ZÄHLENWENN(A2:L2;">="&M2)
N3=ZÄHLENWENN(A3:L3;">="&M3)
N4=ZÄHLENWENN(A4:L4;">="&M4)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Stell die Berechnung(Optionen) auf automatisch!
Gruß Matthias


  

Betrifft: AW: Zählenwenn mit variabler Referenz von: daniel
Geschrieben am: 21.11.2012 10:24:21

Nachtrag:
Zählenwenn soll Treffer zählen, die grösser oder gleich dem Referenzwert sind


  

Betrifft: Browser schon aktualisiert ;-) kwT von: Matthias L
Geschrieben am: 21.11.2012 10:29:05




  

Betrifft: vielen Dank, funktioniert perfekt von: daniel
Geschrieben am: 21.11.2012 10:33:40

Hi Mathias und Chris

Ihr wart beide so schnell, dass während dem Schreiben meines Nachtrages schon eure Lösungen hatte :-) herzlichen Dank, euch Beiden.

Gruss

Dani


  

Betrifft: vielen Dank, funktioniert perfekt von: daniel
Geschrieben am: 21.11.2012 10:34:04

Hi Mathias und Chris

Ihr wart beide so schnell, dass während dem Schreiben meines Nachtrages schon eure Lösungen hatte :-) herzlichen Dank, euch Beiden.

Gruss

Dani


 

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mit variabler Referenz"