Zählenwenn mit Spalte

Bild

Betrifft: Zählenwenn mit Spalte
von: Heinz
Geschrieben am: 01.12.2015 17:25:25

Liebe Excellenten,
eigentlich habe ich gedacht, ich würde das hainkriegen.
Folgendes Problem:
Ich habe eine Tabelle mit sehr vielen Spalten.
In der Ersten Zeile der Spalte steht ein spezifisches Wort
wie z.B. "Banane", "Kirsche", "Orange".
In den nächsten ca. 200 Zeilen jeder Spalten (also darunter) stehen jeweils Zahlenwerte oder die Zellen sind leer.
Mein Wunsch - es ist ja bald Weihnachten -
Eine Formel, die mir folgendes ausrechnet:
Wie häufig ist in einer Spalte, in welche in der erste Zeile
der Wert "Orange" steht, in den darunter liegenden Zellen ein
Wert größer 0 enthalten.
Natürlich ist das ein fiktives Beispiel.
Ich freue mich auf eure Vorschläge und
wünsche allen einen schönen Abend.
Heinz

Bild

Betrifft: AW: Zählenwenn mit Spalte
von: Hajo_Zi
Geschrieben am: 01.12.2015 17:43:13
Hallo Heinz,


=ZÄHLENWENN(INDEX(A:J;;VERGLEICH("Orange";A1:J1;0));">" &0)



Bild

Betrifft: AW: nicht ganz eindeutig, so wie Du schreibst ...
von: neopa C
Geschrieben am: 01.12.2015 17:47:58
Hallo Heinz,
... z.B. in der Spalte A (wo noch keine Werte zu zählen sind) folgende Formel:


=ZÄHLENWENN(INDEX($1:$1048576;;ZEILE(A2));">0")
und diese nach unten ziehend kopieren.
Diese ermittelt Formel ermittelt dann in der ersten Zelle für Spalte B alle Zahlenwerte, dann für Spalte C ...
Gruß Werner
.. , - ...

Bild

Betrifft: Danke an Hajo und Werner, alles super
von: Heinz
Geschrieben am: 01.12.2015 18:46:32


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mit Spalte"