Zählenwenn mit Bedingungen

Bild

Betrifft: Zählenwenn mit Bedingungen
von: Robert
Geschrieben am: 13.05.2015 14:26:54

Hallo Zusammen,
ich hoffe ich kann mein Problem verständlich schildern.
Also, ich habe in den Spalten A B und C Zahlen werte stehen. in Spalte D steht ein "x" oder nicht. Mich interessiert jetzt die Anzahl der Datensätze in denen in den Spalten A ODER B ODER C eine "1" steht und in Spalte D ein "x". Mit SUMMENPRODUKT wäre es ja kein Problem, wenn dieses ODER nicht wäre.
Ich hoffe mir kann jemand helfen.
Schöne Grüße,
Robert

Bild

Betrifft: AW: Zählenwenn mit Bedingungen
von: SF
Geschrieben am: 13.05.2015 14:31:39
Hola,
Summenprodukt kann ODER.

=SUMMENPRODUKT(((A1:A3=1)+(B1:B3=1)+(C1:C3=1))*(D1:D3="x"))
Gruß,
steve1da

Bild

Betrifft: AW: Zählenwenn mit Bedingungen
von: Robert
Geschrieben am: 13.05.2015 14:43:09
Hallo Steve,
danke für Deine Antwort. Aber das Problem ist so leider nicht gelöst. So zählt die Formel alle Kombinationen aus 1 und x. Ich möchte aber, dass ein Datensatz in dem zum Beispiel eine 1 in Spalte A und auch eine 1 in Spalte B steht nur einmal gezählt wird.
Beispiel:
A B C D
1 2 1 y
1 2 3 x
1 1 1 x
Das Ergebnis sollte hier 2 sein, da es nur zwei Datensätze gibt in denen in A B oder C eine 1 und in Spalte D ein X. Es sollen also nicht die Kombinationen aus 1 und x gezählt werden, sondern die Zeilen in denen mindestens eine dieser Kombinationen auftaucht.
Ich hoffe jetzt ist es verständlicher.
Danke im Voraus
Gruß,
Robert

Bild

Betrifft: AW: Zählenwenn mit Bedingungen
von: SF
Geschrieben am: 13.05.2015 14:49:15
Hola,
dann mach dir ne Hilfsspalte:

=((A1=1)+(B1=1)+(C1=1))*(D1="x")
Diese Formel nach unten ziehen, dann:
=ZÄHLENWENN(F1:F3;">0")
In meinem Beispiel ist die Hilfsspalte in F.
Gruß,
steve1da

Bild

Betrifft: AW: Zählenwenn mit Bedingungen
von: Robert
Geschrieben am: 13.05.2015 14:56:45
Ich brauch es leider ohne Hilfsspalte.
Aber trotzdem danke für Deine Mühe.

Bild

Betrifft: Wo ist das Problem? Steves Fml muss doch ...
von: Luc:-?
Geschrieben am: 14.05.2015 01:23:05
…nur etwas ergänzt wdn, Robert:
=SUMMENPRODUKT(((A1:A3=1)+(B1:B3=1)+(C1:C3=1)>0)*(D1:D3="x"))
Dann kommt auch 2 raus!
Gruß, Luc :-?

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mit Bedingungen"