Microsoft Excel

Herbers Excel/VBA-Archiv

WENN/ODER Funktion | Herbers Excel-Forum


Betrifft: WENN/ODER Funktion von: Dessin
Geschrieben am: 27.10.2008 20:15:48

Guten Abend

ich möchte gerne wissen, wieviele ODER-Fragen in eine WENN Funktion eingebunden werden können.
folgendes Beispiel:

Grundfunktion: wenn (X=wahr,dann A1 sonst B1)

meine Frage: wenn (oder(C1={"x";"y"};D1={"x";"y"});A1;B1)

C1 ist eine ODER Frage die ich, wie ich weiß, mit 30 Beispielen abfragen kann, aber D1 ist schon eine zweite ODER Frage, und wieviele weitere ODER Fragen mit je bis zu 30 Beispielen kann man setzen?

Meine konkrete Funktion sieht so aus:

=WENN(ODER(C2={"PET";"Pilsener";"Pils";"0,35";"0,4";"&";"Fg";"15er";"oZ";"Drink"};D2={"PET";"Pilsener";"Pils";"0,35";"0,4";"&";"Fg";"15er";"oZ";"Drink"};E2=
{"PET";"Pilsener";"Pils";"0,35";"0,4";"&";"Fg";"15er";"oZ";"Drink"};F2={"PET";"Pilsener";"Pils"; "0,35";"0,4";"&";"Fg";"15er";"oZ";"Drink"});B2;A2)

und sie funktioniert nicht.

Was mache ich falsch, kann mir jemand helfen
bis bald
Dessin

  

Betrifft: AW: WENN/ODER Funktion von: Domtsgi
Geschrieben am: 27.10.2008 21:04:58

Guten Abend.

ziemlich umständliche Formel.
Eine andere Lösung:

Die Kriterien packst du in die Zellen Z1:Z30...
=WENN(ZÄHLENWENN(Z1:Z30;C2)=0;A1;B1)

Gruss Domtsgi


  

Betrifft: AW: WENN/ODER Funktion von: Dessin
Geschrieben am: 27.10.2008 21:15:48

Hallo


Die Kriterien packst du in die Zellen Z1:Z30...
=WENN(ZÄHLENWENN(Z1:Z30;C2)=0;A1;B1)



das Verstehe ich garnicht, was soll das sein?

bis dann
Dessin


Beiträge aus den Excel-Beispielen zum Thema "WENN/ODER Funktion"