Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Erste Stelle Zahl oder Buchstabe

Erste Stelle Zahl oder Buchstabe
17.10.2013 16:57:25
Heinz
Hallo liebe Excellenten,
ich habe folgende Aufgabenstellung.
Ich habe eine Liste, in welcher in der ersten Spalte
Kürzel für Bücher stehen. Die Bezeichnungen beginnen
immer mit einer Zahl, also z.B. 9004_Roman_X; 80_Biografie_Y
In der selben Spalte sind zwischendurch auch Kürzel für Zeitschriften, also
z.B. Gong_2013; TV_1_HJ oder Computerbild_13.
Diese beginnen immer mit einem Buchstaben.
In der zweiten Spalte ist sowohl für Bücher als auch
Zeitschriften jeweils eine Stückzahl.
Die Zellen in Spalte 1 sind nicht alphabteisch und dürfen auch
nicht sortiert werden (sonst wär's ja einfach ;-)).
Wie kann ich jetzt z.B. eine Formel bilden, die mir alle
Zahlen in der Spalte 2 addiert, wenn in der Spalte 1 der Eintrag
mit einer Zahl beginnt (das wären die Bücher,
bzw. mit einem Buchstaben beginnt (das wären die Zeitschriften).
Ich freue mich auf Eure Lösungen und wünsche allen einen
schönen Abend.
Heinz

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Erste Stelle Zahl oder Buchstabe
17.10.2013 17:12:58
EtoPHG
Hallo Heinz,
z.B. mit =SUMMENPRODUKT((LINKS(A2:A999;1)>="A")*B2:B999)
Die Differenz von SUMME(B:B) - obiger Formel wären dann die Bücher (mit den Zahlen)!
Gruess Hansueli

oder so ...
17.10.2013 17:17:49
neopa
Hallo Heinz,
...

=SUMMENPRODUKT(ISTZAHL(--LINKS(A1:A999;1))*B1:B999)

Gruß Werner
.. , - ...

Super, Danke an beide o.T.
17.10.2013 17:20:38
Heinz

AW: Erste Stelle Zahl oder Buchstabe
17.10.2013 17:21:26
Erich
Hi Heinz,
so vielleicht:
 ABCDE
2Gong_20131   
3Computerblöd_1310   
49004_Roman_X100 Ztschr:10100
5TV_1_HJ1000   
680_Biografie_Y10000 Bücher:1011

Formeln der Tabelle
ZelleFormel
E4=SUMMENPRODUKT(0+ISTZAHL(0+LINKS(A$2:A$6)); B$2:B$6)
E6=SUMMENPRODUKT((1-ISTZAHL(0+LINKS(A$2:A$6))); B$2:B$6)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
oh Mann, war ich langsam... ;-) (owT)
17.10.2013 17:23:07
Erich

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige