Microsoft Excel

Herbers Excel/VBA-Archiv

Kombination Zählenwenns & WVerweis rückwärts

Betrifft: Kombination Zählenwenns & WVerweis rückwärts von: Joerschi
Geschrieben am: 18.11.2014 21:03:18

Hallo liebes Forum,

Folgende Aufgabenstellung möchte ich lösen:
Es gibt eine Referenztabelle mit 10 Spalten, die Überschriften lauten 1 bis 10.
Die Tabelle enthält allerlei Werte, wobei nur die "GT"-Werte (grün markiert) interessant sind.

Nun möchte ich in verschiedenen Kombinationen der Überschriften herausfinden, wie viele "GT"-Werte zu den jeweiligen Überschriften aus allen Zeilen gleichzeitig (!) enthalten sind. Die Überschriften werden sozusagen als Querverweis/Vorgabe benötigt.
Ich denke, es ist eine Kombination aus Zählenwenns und WVerweis rückwärts (siehe hier: http://www.excelformeln.de/formeln.html?welcher=25), aber ich bekomme es nicht hin.

Hat jemand eine Idee?

Hier eine Skizze zum Problem nebst Beispieldatei:

(Gelb sind die gesuchten Formeln / die Lösungen sind handausgezählt kursiv daneben geschrieben, ich hoffe ich habe mich nicht verzählt...
Außerdem ein Beispiel mit Linien verdeutlicht)
https://www.herber.de/bbs/user/93855.xlsx

Viele Grüße
Joerschi

  

Betrifft: Abgesehen mal von der fehlenden ... von: Luc:-?
Geschrieben am: 19.11.2014 03:59:19

…Kennzeichnung der beiden Vorspalten der ErgebnisTabelle als 2 und-verknüpfte Suchspalten, der Angabe der Ziffern-Überschriften als Zahlen in der Daten- und als Texte in der ErgebnisTabelle und der fehlenden (Hilfs-)„Linien“, Joerschi,
ja, du hast dich verzählt — nur 2 von den 7 Ergebnissen sind richtig (und in deiner Abbildung auch nicht kursiv)! Die richtigen Ergebnisse (hier als Vertikal­Vektor-Matrix­Konstante dargestellt) lauten {17;13;14;9;14;15;11}! Ansonsten ist VERGLEICH hier besser als WVERWEIS. Die Formel lautet dann …
N4[:N10]:=ZÄHLENWENNS(INDEX($A$4:$J$29;0;VERGLEICH(L4;$A$3:$J$3;0));"GT";INDEX($A$4:$J$29;0;VERGLEICH(M4;$A$3:$J$3;0));"GT")
…und kann nach unten kopiert wdn.
Morrn, Luc :-?


  

Betrifft: AW: Abgesehen mal von der fehlenden ... von: Joerschi
Geschrieben am: 19.11.2014 09:17:56

Dank Dir Luc.
Ich hatte mich tatsächlich verzählt :-( (naja, deswegen die Formel - im Original sind die Tabellen ungleich umfangreicher).

Aber die Formel zeigt bei mir nur #NV an, auch wenn ich sie als Matrix-Formel mit STRG+SHIFT+RETURN eingebe...

Viele grüße
Joerschi


  

Betrifft: geht auch mit SUMMENPRODUKT() ... aber ... von: neopa C (paneo)
Geschrieben am: 19.11.2014 09:40:59

Hallo Joerschi,

... wenn Du ein #NV als Fehlermeldung erhältst, dann hast Du wahrscheinlich in A3:J3 oder in L4:M10 Textwerte und keine echten Zahlenwerte. Das kannst Du ändern, in dem Du diese Werte mal mit 1 multiplizierst.

Übrigens hätte ich eine etwas alternative Variante, die auch in älteren Excelversionen lauffähig ist.

=SUMMENPRODUKT((INDEX(A$4:J$29;;VERGLEICH(L4;A$3:J$3;))="GT")*(INDEX(A$4:J$29;;VERGLEICH(M4;A$3:J$3;))="GT"))


Gruß Werner
.. , - ...


  

Betrifft: AW: geht auch mit SUMMENPRODUKT() ... aber ... von: Joerschi
Geschrieben am: 19.11.2014 09:53:56

Vielen Dank Werner, Lösung funktioniert auch super.

PS: Hatte A3:J3 und L4:M10 nach Luc´s Hinweis alle schon als Zahl formatiert. Aber eben trotzdem das #NV :-(. Egal, mit dem *1 funktioniert es. Muss ich in den Formaten nochmal probieren, woran es liegen kann.

Nochmals Danke Euch beiden und LG
Joerschi


  

Betrifft: Referenztabelle in anderem Tabellenblatt? von: Joerschi
Geschrieben am: 19.11.2014 10:07:29

ich hätte doch noch mal ne Frage.
Die Referenztabelle mit den Werten befindet sich auf einem anderen Tabellenblatt ("Tabelle1") als die Formellösung mit den Vorgabewerten ("Tabelle2").
Kann es sein, dass die Formel mit Index+Vergleich deswegen ebenfalls nicht funktioniert?

Viele Grüße
Joerschi


  

Betrifft: erledigt von: Joerschi
Geschrieben am: 19.11.2014 14:58:22

erledigt. Nochmals die Formatierung.
Danke an alle Helfer!


 

Beiträge aus den Excel-Beispielen zum Thema "Kombination Zählenwenns & WVerweis rückwärts"