WENN / ODER-Funktion



Excel-Version: 9.0 (Office 2000)

Betrifft: WENN / ODER-Funktion
von: Flo
Geschrieben am: 27.05.2002 - 14:18:40

Hallo zusammen,

wie kann ich eine WENN- und eine ODER-Funktion miteinander verknüpfen? Ich will in Zelle A1 prüfen, ob entweder in der Zelle B1 ODER B2 ODER B3 ein Wert steht. Wenn ja, dann soll Excel in Zelle A1 ein 'X' eintragen, ansonsten ''.


  

Re: WENN / ODER-Funktion
von: Maja
Geschrieben am: 27.05.2002 - 14:22:16

Mit UND:

=WENN(NICHT(UND(ISTLEER(B1);ISTLEER(B2);ISTLEER(B3)));;X;"")

Also wenn alle drei leer sind, trägt er nichts ein, wenn in einem ein Wert steht, dann X.
Gruß,
Maja

  

Re: WENN / ODER-Funktion
von: Timo
Geschrieben am: 27.05.2002 - 14:23:20

So:
=WENN(ODER(B1<>"";B2<>"";B3<>"");X;"")

Einfach in A1 eintragen und los gehts!

Gruss
Timo

  

Hups, ein Semikolon zuviel
von: Maja
Geschrieben am: 27.05.2002 - 14:23:27

=WENN(NICHT(UND(ISTLEER(B1);ISTLEER(B2);ISTLEER(B3)));"X";"")

so;-)


  

Re: WENN / ODER-Funktion
von: Frank Scharwey
Geschrieben am: 27.05.2002 - 14:24:36

Hallo

Versuchge es mit dieser Formel in A1

WENN(B1<"";"X";WENN(B2<"";"X";WENN(B3<"";"X";"")))

Gruss

Frank


  

Auch was vergessen...
von: Timo
Geschrieben am: 27.05.2002 - 14:26:11

=WENN(ODER(B1<>"";B2<>"";B3<>"");"X";"")

So ists besser...

Gruss
Timo


  

Re: WENN / ODER-Funktion (ohne ODER)
von: Andreas
Geschrieben am: 27.05.2002 - 14:28:15

Hallo Flo,

hier noch zwei Varianten:
=WENN(B1&B2&B3="";"";"X")

=WENN(ANZAHLLEEREZELLEN(B1:B3)=3;"";"X")

Viel Spaß,
Andreas

  

Re: WENN / ODER-Funktion
von: Frank Scharwey
Geschrieben am: 27.05.2002 - 14:32:07

und "X" ;-)

  

Re: WENN / ODER-Funktion
von: Maja
Geschrieben am: 27.05.2002 - 14:34:11

lol, der Montag schlägt zu.

Grüße,
Maja