Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn Funktion

Betrifft: Zählenwenn Funktion von: Markus
Geschrieben am: 08.09.2014 21:58:15

Hallo Excel User,
habe schon viel im Forum gelesen, aber ich bekomme es einfach nicht hin. Habe eine Jahresübersicht für Fahrzeugeinsätze bzw. Fahrer erstellt. Nun möchte ich anhand des Wochentages (Mo. Di. Mi. usw.) unter Berücksichtigung von Feiertagen jeweils die Tage zählen die der jeweilige Fahrer geleistet hat. Die Fahrer können per Drop Down Liste im 1. Tabellenblatt ausgewählt werden. Die Auswahldaten liegen alle auf dem 2. Tabellenblatt. Ausgewertet soll auf dem 3. Tabellenblatt. In Zelle D11 des 1. Tabellenblattes kann das Jahr (365 Tage) ausgewählt werden. Daraufhin werden auch die Feiertage automatisch berechnet. Des weiteren habe ich ein Problem mit meinen Hyperlinks (Sprungmarken) im ersten Tabellenblatt. Beim kopieren auf ein anderes Laufwerk sind diese dann ohne Funktion. Ich hoffe ich habe mich verständlich ausgedrückt.

https://www.herber.de/bbs/user/92532.xlsx

  

Betrifft: AW: Zählenwenn Funktion von: fcs
Geschrieben am: 09.09.2014 12:46:15

Hallo Markus,

Formel in B4: =SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A4)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$A$375=B$3)*1)

Formel in B11: =SUMMENPRODUKT((Vorlage365!$F$11:$F$375<>"")*(Vorlage365!$A$11:$A$375=B$3)*1)

Formel in B15: =SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A4)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$B$11:$B$375=B$14)*1)

Formel in B22: =SUMMENPRODUKT((Vorlage365!$F$11:$F$375<>"")*(Vorlage365!$B$11:$B$375=B$14)*1)

Die Formeln kannst du dann nach Recht und unten kopieren.

Gruß
Franz


  

Betrifft: AW: Summenprodukt von: Markus
Geschrieben am: 09.09.2014 16:49:01

Hallo Franz,
danke für deine schnelle Antwort. Die Formeln funktionieren soweit, nur müssten Sie noch mit einander verknüpft werden. Die Formeln in B4 u. B11 werten den Fahrer1 (Spalte A) aus, die Formeln in B15 u. B22 werten den Fahrer2 (Spalte B) aus. Beide Fahrer werden aber auf Fahrzeug1 eingesetzt. (siehe Tabellenblatt 3 Zeile 2).
Die Spalten O u. P. (Fahrer 1 u.2) sollten für das Fahrzeug2 ausgewertet werden. Ich hab die Datei noch mal mit deinen Formeln hochgeladen. Das Ergebnis kannst du auf Tabellenblatt 3 nach vollziehen.
https://www.herber.de/bbs/user/92554.xlsx


Ich hab mal versucht deine Formel für (Fahrzeug1)um zustellen. Ich weiß nicht ob man das so machen kann, schau sie dir mal an.

Formel in B4: =SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A4)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$b$375=B$3)*1)

Formel in B11: =SUMMENPRODUKT((Vorlage365!$F$11:$F$375<>"")*(Vorlage365!$A$11:$B$375=B$3)*1)


  

Betrifft: AW: Summenprodukt von: fcs
Geschrieben am: 10.09.2014 01:12:56

Hallo Markus,

die Formeln kannst du so umstellen, das Einsätze von Fahrer 1 und 2 für das Fahrzeug 1 erfasst werden.

Übersicht Fahrer

 AB
3 U
4Montag0
5Dienstag0
6Mittwoch0
7Donnerstag0
8Freitag0
9Samstag0
10Sonntag0
11Feiertag1
12Gesamt1

Formeln der Tabelle
ZelleFormel
B4=SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A4)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$B$375=B$3)*1)
B5=SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A5)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$B$375=B$3)*1)
B6=SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A6)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$B$375=B$3)*1)
B7=SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A7)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$B$375=B$3)*1)
B8=SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A8)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$B$375=B$3)*1)
B9=SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A9)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$B$375=B$3)*1)
B10=SUMMENPRODUKT((TEXT(Vorlage365!$D$11:$D$375;"TTTT")=$A10)*(Vorlage365!$F$11:$F$375="")*(Vorlage365!$A$11:$B$375=B$3)*1)
B11=SUMMENPRODUKT((Vorlage365!$F$11:$F$375<>"")*(Vorlage365!$A$11:$B$375=B$3)*1)
B12=SUMME(B4:B11)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Für Fahrzeug 2 und Spalten O und P musst du dann die Formeln entsprechend umstellen.

Gruß
Franz


  

Betrifft: AW: Summenprodukt von: Markus
Geschrieben am: 10.09.2014 16:02:42

Hallo Franz,

danke für die Antwort, hatte ich schon vorab so umgesetzt und funktioniert einwandfrei. Nachmals Danke.
Gruß Markus


 

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn Funktion"