bei Zeile einfügen per VBA Summenformel anpassen



Excel-Version: 2000
nach unten

Betrifft: bei Zeile einfügen per VBA Summenformel anpassen
von: Klaus
Geschrieben am: 12.04.2002 - 17:43:41

wie kann ich erreichen, dass eine Summenformel im Tabellenblatt z.B. Zelle A1: '=Summe(A2:A10)' nach dem einfügen einer Zeile nach der 10ten Zeile sich in '=Summe(A2:A11)' ändert!


Für den Fall, dass die Summe unter der Liste steht hab ich hier im Forum mal eine geniale Lösung gelesen:

=SUMME(A1:BEREICH.VERSCHIEBEN(A12;-1;0))

nur kann ich diese Lösung nicht übertragen. Schade, denn ich muss eine ziemlich umfangreiche, bereits vorhandene Arbeitsmappe erweiterbar gestalten, bei der die Summen über den zu summierenden Listen stehen.

VIELEN DANK schon mal für jede Hilfe!



nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: Hajo
Geschrieben am: 12.04.2002 - 17:58:13

Hallo Klaus

ich löse solche Sachen immer wie folgt zwischen der Zeile wo die Summe steht z.B. Zeile 30 und den Daten lasse ich immer eine Zeile frei (=Summe(A1:A29) und füge vor der Leerzeile die neue Zeile ein, dann wird die Formel automatisch geändert.

Gruß Hajo

nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: MRR
Geschrieben am: 12.04.2002 - 17:58:14

Muss die Summe direkt unter der letzten Zeile stehen? Oder wäre es denkbar, dass Du oberhalb der Summenzeile eine - evtl. ganz schmale - Zeile einblendest, oberhalb der neue Zeilen eingefügt werden? Dann könnte die Summe von vornherein =SUMME(A2:A11) lauten. Werde vor Zeile 11 neue Zeilen geschaffen, ist die Formel auf dem aktuellen Stand.
Matthias
nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: Hajo
Geschrieben am: 12.04.2002 - 18:00:28

Hallo Matthias

das ist schon Extrem die Antwort in so einem kurzen Abstand und dann haben wir beide noch die gleiche Idee.

Gruß Hajo


nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: MRR
Geschrieben am: 12.04.2002 - 18:09:20

Stimmt - Du bist immer so schnell...
Matthias

nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: Klaus
Geschrieben am: 12.04.2002 - 18:10:18

Idee funktioniert, wobei ich ungern mit toten Zeilen oder Hilfszellen in denen irgendwelche temporären Werte gepackt sind arbeite!

übrigens:
die Summe muss ÜBER der ersten Zeile stehen, wenn sie direkt unter der Liste stehen würde hätte ich ja die geniale Lösung ohne Leerzeile (hab allerdings wie ich gerade gesehen habe, bei meinem Posting in der Formel A12 statt A11 geschrieben)

Klaus

nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: Hajo
Geschrieben am: 12.04.2002 - 18:13:31

Hallo Klaus

wenn sie in der ersten Zeile steht und du willst alle Werte der Spalte addieren warum nicht gleich
=Summe(A2:A65536)

Gruß Hajo

nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: Klaus
Geschrieben am: 12.04.2002 - 18:19:18

dann teste doch mal meine Formel aus dem Forum hier!
In Zelle A11: =SUMME(A1:BEREICH.VERSCHIEBEN(A11;-1;0))
bewirkt eine Aufsummierung von A1:A10 und wenn zwischen A10 und Formel in A11 eine Zeile eingefügt wird, rückt die Formel nach A12 und sieht dann so aus:
=SUMME(A1:BEREICH.VERSCHIEBEN(A12;-1;0))

Das klappt auch ohne Leerzeile, nur in meinem Fall steht sie Summe leider NICHT unter, sondern über der zu summierenden Liste!

Eine Leerzeile belassen und verstecken löst zwar mein Problem, ich finde jedoch die andere Methode eleganter und dachte vielleicht kann mir ja jemand einen Tip geben, wie ich diese anpassen kann!

Trotzdem DANKE!

nach oben   nach unten

Re: bei Zeile einfügen per VBA Summenformel anpassen
von: Klaus
Geschrieben am: 12.04.2002 - 18:22:34

Servus Hajo,

mit A1:A10 war nur ein Beispiel. In der Spalte sind ca. 100-120 Summen über einzelne Positionen, die erweiterbar sein sollten!

Ansonsten siehe mein Posting unten!

nach oben   nach unten

Universallösung:
von: Jürgen
Geschrieben am: 12.04.2002 - 18:35:54

Hallo Klaus,

so kannst du die ursprüngliche Summe A2:A10 durch einfügen von Zeilen davor oder danach anpassen lassen!

=SUMME(BEREICH.VERSCHIEBEN(A1;1;0):BEREICH.VERSCHIEBEN(A11;-1;0))

Servus!

nach oben   nach unten

DAAAAAAAAAAAAAAAAAANKEEEE !!!
von: Klaus
Geschrieben am: 12.04.2002 - 18:42:06

genial, manchmal bin wohl einfach zu dämlich :-)
so ist es die optimale Lösung!

schönes Wochenende!

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "bei Zeile einfügen per VBA Summenformel anpassen"