Formelinhalte monatsabhängig per Makro

Bild

Betrifft: Formelinhalte monatsabhängig per Makro
von: Basti
Geschrieben am: 29.03.2005 17:44:45
Hallo zusammen,
Ich habe folgende formeln in zellen AD6-AD15:
=WENN(Kalkulation_Juni05!AE6<>0;Kalkulation_Juni05!AE6;"")
AE6 ist dabei entsprechend AD6, also wäre AE15 = AD16 in obiger Formel. Ich möchte nun per Makro entsprechend dem akutellen Datum die Formel automatisch ändern lassen. In Zelle A2 steht das aktuelle Datum in der Form: TT.MM.JJJJ Die o.g. Formeln beziehen sich aber immer auf einen Monat im Voraus.
Beispiel: A2 = 11.06.2005, dann muss die Formel in Zelle AD6 so aussehen:
=WENN(Kalkulation_Mai05!AE6<>0;Kalkulation_Mai05!AE6;"")
Wie kann ich das realisieren? Ich hab selber schon einige umständliche Ideen, denke jedoch, dass das auch einfacher geht.
Grüße + VIELEN DANK IM VORAUS,
Basti

Bild

Betrifft: AW: Formelinhalte monatsabhängig per Makro
von: Josef Ehrensberger
Geschrieben am: 29.03.2005 22:44:45
Hallo Basti!
Probier mal.

=WENN(INDIREKT("Kalkulation_"&TEXT(DATUM(JAHR(A2);MONAT(A2)-1;1);"MMMM")&"05!AE6")<>0;INDIREKT("Kalkulation_"&TEXT(DATUM(JAHR(A2);MONAT(A2)-1;1);"MMMM")&"05!AE6");"")


Gruß Sepp
P.S.: Rückmeldung nicht vergessen!


Bild

Betrifft: AW: Formelinhalte monatsabhängig per Makro
von: Basti
Geschrieben am: 30.03.2005 17:30:08
ging super. DANKE!!!
mensch, wie kommt man auf solche bandwurmformeln :-) ???
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Access Anwendung öffnen"