verzwickte formel ? oder ich binn zu blöd :)

Bild

Betrifft: verzwickte formel ? oder ich binn zu blöd :) von: Bernd
Geschrieben am: 16.02.2005 19:07:02

Halli Hallo liebe Ex(el)perten,

ich habe mal wieder ein Problem,
da meine Recherche nicht erfolgreich war, frage ich hier mal nach.


Also es geht (möglicherweise) um eine mehfache wenn Formel:

es soll ein Wert (Kg Gewicht) eingegeben werden zb in G12, in g13 sollte dann eine Ausrechnung erscheinen.
Soweit so gut...
nun kommt der knackpunkt, die Folgenden bedingungen sollten per wenn oder Formel gelöst werden:
bis 1200kg 2,04 per angefangener 100Kg
ab 1201 bis 1500Kg 26,38 (Festwert)
1501 bis 2000Kg 28,12 (Festwert)
2001 bis 2500Kg 29,24 (Festwert)
2501 bis 3000Kg 30,47 (Festwert)
ab 3001Kg 1,01 per Kg

kann mir da jemand helfen ?
Vielen Dank im Vorraus Gruß Bernd Schneider

Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: KlausF
Geschrieben am: 16.02.2005 19:28:07

Also doch das erstere! ;-)))

=WENN(G12>3000;G12*1,01;WENN(G12>2500;30,47;WENN(G12>2000;29,24;WENN(G12>1500;28,12;WENN(G12>1200;26,38;AUFRUNDEN(G12/100;0)*2,04)))))

Gruß!
Klaus


Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: Bernd
Geschrieben am: 16.02.2005 19:47:49

Vielen dank
leider gibt die Formel den Fehler #Wert aus
aber die Formel von Andreas M funktioniert wunderbar

vielen Dank nochmal :)


Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: KlausF
Geschrieben am: 16.02.2005 20:21:53

Sorry, aber bei mir funzt's.
(Selbstverständlich teste ich meine Tipps - zwar mit Excel97, müßte aber auch bei XP klappen.)

Ich werd's überleben!
Gruß
Klaus


Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: Andreas M
Geschrieben am: 16.02.2005 19:30:45

Versuchs mal damit

=WENN(G12<=1200;(GANZZAHL((G12-1)/100)+1)*2,04;WENN(G12<=1500;26,38;WENN(G12<=2000;28,12;WENN(G12<=2500;29,24;WENN(G12<=3000;30,47;G12*0,0101)))))


Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: Bernd
Geschrieben am: 16.02.2005 19:45:39

Supi, das klappt

mein Dank wird Dir ewig nachschleichen :)

freu - freu - freu


Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: HermannZ
Geschrieben am: 16.02.2005 19:40:19

Hallo Bernd,

oder mit der Funktion Wahl,

Beispiel;

Test
 DE
27  
28geg. WertErgebniss
2934563490,56
30  
31  
32  
33  
Formeln der Tabelle
E29 : =WAHL(VERGLEICH(D29;{0;1201;1501;2001;2501;3001});2,04*D29/100;26,38;28,12;29,24;30,47;1,01*D29)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: Bernd
Geschrieben am: 16.02.2005 19:50:23

Vielen dank
die Formel von Andreas M funktioniert wunderbar und ist
auch leicht zu Ändern wenn dies der fall sein sollte

vielen Dank nochmal :)


Bild


Betrifft: AW: verzwickte formel ? oder ich binn zu blöd :) von: Hübi
Geschrieben am: 16.02.2005 20:16:29

Hi Bernd,

du schließt Preis-Änderungen nicht aus ;-))

Hier sind Änderungen ganz leicht einzuarbeiten, ohne in die Formel zu gehen.
Tabelle1
 ABCD
1Datum16.02.2005  
2Gewicht101 kg  
3Preis4,08 €  
4Vorgaben   
5gültig ab01.01.200401.01.200501.06.2005
6GewichtPreis  
7ab 1 kg0,54 €/100 kg2,04 €/100 kg3,04 €/100 kg
81.201 kg16,38 €26,38 €36,38 €
91.501 kg18,12 €28,12 €38,12 €
102.001 kg19,24 €29,24 €39,24 €
112.501 kg20,47 €30,47 €40,47 €
12ab 3.100 kg0,51 €/kg1,01 €/kg2,01 €/kg
13Hoch lebe die Preiserhöhung ;-)
Formeln der Tabelle
B3 : =WENN(B2<A8;SVERWEIS(B2;A7:E12;VERGLEICH(B1;A5:E5))*AUFRUNDEN(B2/100;0);SVERWEIS(B2;A7:E12;VERGLEICH(B1;A5:E5))*WENN(B2>=A12;B2;1))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: Cool => Big THX von: Bernd
Geschrieben am: 16.02.2005 21:56:22

Das ist ja noch besser,
ich hatte die andere Formel umgeschrieben
damit sie sich die Preise von einem 2ten Blatt holen kann
und diese hätte mann dann ändern können, aber es wären auch alle
vorrangegangenen Daten mitgeändert worden :(

Aber diese Variante lässt keine Wünsche mehr offen

vielen Dank


Bild


Betrifft: Danke für die Antwort - erledigt o.T. von: Hübi
Geschrieben am: 16.02.2005 22:30:38




Bild


Betrifft: AW: bei HZ und KF... von: FP
Geschrieben am: 16.02.2005 21:50:50

Hi Bernd,

... kaufe ich nicht ein - siehe 3001 kg ;-)

Frage: sind 3001 kg wirklich billiger als 3000 kg ???

Meine Lösung(en): ich würde die Lösung mit Hilfstabelle wählen, da leichter anzupassen

Tabelle1
 ABCDEFGHI
1 je 100 kg  FPFP 2AMKFHZ
2 2,04  00,00 0,00 0,00 0,00 0,00
300,00  992,04 2,04 2,04 2,04 2,02
412,04  1934,08 4,08 4,08 4,08 3,94
51014,08  2876,12 6,12 6,12 6,12 5,85
62016,12  3818,16 8,16 8,16 8,16 7,77
73018,16  47610,20 10,20 10,20 10,20 9,71
840110,20  57512,24 12,24 12,24 12,24 11,73
950112,24  67214,28 14,28 14,28 14,28 13,71
1060114,28  76316,32 16,32 16,32 16,32 15,57
1170116,32  85618,36 18,36 18,36 18,36 17,46
1280118,36  95220,40 20,40 20,40 20,40 19,42
1390120,40  104222,44 22,44 22,44 22,44 21,26
14100122,44  114024,48 24,48 24,48 24,48 23,26
15110124,48  120024,48 24,48 24,48 24,48 24,48
16120126,38  150026,38 26,38 26,38 26,38 26,38
17150128,12  200028,12 28,12 28,12 28,12 28,12
18200129,24  250029,24 29,24 29,24 29,24 29,24
19250130,47  300030,47 30,47 30,47 30,47 30,47
2030011,01  300130,48 30,48 30,31 3031,01 3031,01
21   310031,48 31,48 31,31 3131,00 3131,00
22   400040,57 40,57 40,40 4040,00 4040,00
Formeln der Tabelle
E2 : =SVERWEIS(D2;A$3:B$19;2;1)+MAX(D2-3000;0)*B$20/100
F2 : =WAHL(VERGLEICH(D2;{0;1201;1501;2001;2501;3001});AUFRUNDEN(D2/100;0)*2,04;26,38;28,12;29,24;30,47;30,47+MAX(D2-3000;0)*0,0101)
G2 : =WENN(D2<=1200;(GANZZAHL((D2-1)/100)+1)*2,04;WENN(D2<=1500;26,38;WENN(D2<=2000;28,12;WENN(D2<=2500;29,24;WENN(D2<=3000;30,47;D2*0,0101)))))
H2 : =WENN(D2>3000;D2*1,01;WENN(D2>2500;30,47;WENN(D2>2000;29,24;WENN(D2>1500;28,12;WENN(D2>1200;26,38;AUFRUNDEN(D2/100;0)*2,04)))))
I2 : =WAHL(VERGLEICH(D2;{0;1201;1501;2001;2501;3001});2,04*D2/100;26,38;28,12;29,24;30,47;1,01*D2)
B4 : =ZEILE(A1)*B$2
B5 : =ZEILE(A2)*B$2
B6 : =ZEILE(A3)*B$2
B7 : =ZEILE(A4)*B$2
B8 : =ZEILE(A5)*B$2
B9 : =ZEILE(A6)*B$2
B10 : =ZEILE(A7)*B$2
B11 : =ZEILE(A8)*B$2
B12 : =ZEILE(A9)*B$2
B13 : =ZEILE(A10)*B$2
B14 : =ZEILE(A11)*B$2
B15 : =ZEILE(A12)*B$2
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Bild


Betrifft: AW: bei HZ und KF... von: Bernd
Geschrieben am: 16.02.2005 22:03:31

Hallo, danke für die Hilfe

zu Deiner Frage , ja so ist das leider
3001 Kg sind günstiger als 3000 Kg

Gruß Bernd :)


Bild


Betrifft: AW: dann halt so... von: FP
Geschrieben am: 16.02.2005 22:14:55

Hi Bernd,

Tabelle1
 ABCDEF
1 je 100 kg  FPFP 2
2 2,04  00,00 0,00
300,00  992,04 2,04
412,04  1934,08 4,08
51014,08  2876,12 6,12
62016,12  3818,16 8,16
73018,16  47610,20 10,20
840110,20  57512,24 12,24
950112,24  67214,28 14,28
1060114,28  76316,32 16,32
1170116,32  85618,36 18,36
1280118,36  95220,40 20,40
1390120,40  104222,44 22,44
14100122,44  114024,48 24,48
15110124,48  120024,48 24,48
16120126,38  150026,38 26,38
17150128,12  200028,12 28,12
18200129,24  250029,24 29,24
19250130,47  300030,47 30,47
2030011,01  300130,47 30,31
21   310031,31 31,31
22   400040,40 40,40
Formeln der Tabelle
E2 : =MAX(SVERWEIS(D2;A$3:B$19;2;1);(D2>=D$20)*D2*B$20/100)
F2 : =WAHL(VERGLEICH(D2;{0;1201;1501;2001;2501;3001});AUFRUNDEN(D2/100;0)*2,04;26,38;28,12;29,24;30,47;D2*0,0101)
B4 : =ZEILE(A1)*B$2
B5 : =ZEILE(A2)*B$2
B6 : =ZEILE(A3)*B$2
B7 : =ZEILE(A4)*B$2
B8 : =ZEILE(A5)*B$2
B9 : =ZEILE(A6)*B$2
B10 : =ZEILE(A7)*B$2
B11 : =ZEILE(A8)*B$2
B12 : =ZEILE(A9)*B$2
B13 : =ZEILE(A10)*B$2
B14 : =ZEILE(A11)*B$2
B15 : =ZEILE(A12)*B$2
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


 Bild

Beiträge aus den Excel-Beispielen zum Thema "verzwickte formel ? oder ich binn zu blöd :)"