Microsoft Excel

Herbers Excel/VBA-Archiv

Fehler in der Formel | Herbers Excel-Forum


Betrifft: Fehler in der Formel von: Roger
Geschrieben am: 27.01.2010 09:02:10

Hallo zusammen

Ich habe folgende Formel:

=SUMMENPRODUKT((ANZAHL2(SU!F$4:F34)*(MONAT(SU!C$4:C34)=D27)*(SU!C$4:C34>0)))

Damit will ich im Blatt SU die Einträge in Spalte F zählen, in Spalte C ist jeweils ein Datum, in Zelle D27 der Monat 1.

Das ganze zählt aber nicht richtig. Es müssten wenn ich 2 Einträge in der Spalte F, im Januar habe als die Zahl 2 erscheinen. Es erscheint aber die Zahl 68. IN Spalte F sind 2 Einträge und in Spalte C sind 29 Einträge welche zum teil für andere Berechnungen gebraucht werden.
Ich hoffe ich habe mich einigermassen verständlich ausgedrückt.

Besten Dank für euer Hilfe
Gruss
Roger

  

Betrifft: AW: Fehler in der Formel von: jockel
Geschrieben am: 27.01.2010 10:14:32

hi Roger, versuch mal entweder die formel in A1 oder B1...:

SU

 AB
122

verwendete Formeln
Zelle Formel
A1 =SUMMENPRODUKT((SU!F$4 :F34<>"")*(MONAT(SU!C$4 :C34)=D27)*(SU!C$4 :C34>0))
B1 =SUMMENPRODUKT((SU!F$4 :F34<>"")*(MONAT(SU!C$4 :C34)=D27))

Tabellendarstellung in Foren Version 4.3





cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: Super Danke vielmals von: Roger
Geschrieben am: 27.01.2010 10:21:06

Hallo Jörg

Super klappt bestens mit der Formel in A1. Die andere Klappt auch.

Gruss
Roger


Beiträge aus den Excel-Beispielen zum Thema "Fehler in der Formel"