Microsoft Excel

Herbers Excel/VBA-Archiv

wo steckt der fehler in der Formel? | Herbers Excel-Forum


Betrifft: wo steckt der fehler in der Formel? von: e-mo
Geschrieben am: 21.02.2012 13:17:17


Hi,

ich tüffele hier an dieser Formel und weiss nicht, wo der fehler steckt!
folgendes soll die formel machen:
vergleich 2 werte, die (ist monat mit wert aus vormonat) und soll bei differenzen in der Zelle ++, -- oder + / - darstellen, je nachdem wie die ausprägung ist.

die formel:

=WENNFEHLER(WENN(INDEX(AM7:BJ7;VERGLEICH($B$1;$AM$6:$BJ$6;0))>(INDEX(AM7:BJ7;VERGLEICH($B$1-1; $AM$6:$BJ$6;0)))+0,05;"++";WENN(INDEX(AM7:BJ7;VERGLEICH($B$1;$AM$6:$BJ$6;0))>(INDEX(AM7:BJ7; VERGLEICH($B$1-1;$AM$6:$BJ$6;0)))-0,05;"--";WENN(INDEX(AM7:BJ7;VERGLEICH($B$1;$AM$6:$BJ$6;0))> (INDEX(AM7:BJ7;VERGLEICH($B$1-1;$AM$6:$BJ$6;0);"+";"-")))));"")

irgendwo und irgendwie ist irgendwas falsch...komme nicht dahinter...

e-mo

  

Betrifft: AW: ohne Beispieltabelle versteh' ich da nix! oT von: JoWE
Geschrieben am: 21.02.2012 13:33:02




  

Betrifft: AW: ohne Beispieltabelle versteh' ich da nix! oT von: e-mo
Geschrieben am: 21.02.2012 13:47:35

hi,

habe eine datei kurz mit dieser formel modifiziert...jedoch sehe ich jetzt nichts...

in C4 sollte also das entsprechende symbol sichtbar sein.

https://www.herber.de/bbs/user/79019.xlsx


e-mo


  

Betrifft: AW: wo steckt der fehler in der Formel? von: mumpel
Geschrieben am: 21.02.2012 13:53:54

Hallo!

Weisst Du überhaupt was die Funktion"Wennfehler" ist bzw. macht? So wie Du es nutzt ist es falsch. Nutze stattdessen "IstFehler". Beispiel: =WENN(ISTFEHLER(A1-B1);0;A1-B1).

Gruß, René


  

Betrifft: AW: wo steckt der fehler in der Formel? von: e-mo
Geschrieben am: 21.02.2012 14:32:00

bin einbisschen weiter gekommen....keine lösung, aber immerhin etwas weiter.
Folgendes habe ich herausgefunden.
Bei der referierung vom Monat mit B1-1, referiert er leider nicht den Wert aus dem Vormonat in der Formel. Wenn ich das aber in einer anderen Zelle direkt eingebe, dann tut er das...aber leider nicht in der Formel.

e-mo


  

Betrifft: AW: wo steckt der fehler in der Formel? von: e-mo
Geschrieben am: 24.02.2012 12:37:41

Hat niemand einen Ansatz?
Wie gesagt, wenn ich das Datum direkt eingebe, dann ist es kein Problem. Bei einer Referenz zu einer anderen Zelle mit der Formel -1 zum Monat (also aktueller Monat-1) funktioniert die ganze Formel nicht mehr, da die Formel den Monat nicht erkennt.

Gruss,
e-mo


  

Betrifft: AW: wo steckt der fehler in der Formel? von: Bernd
Geschrieben am: 24.02.2012 17:40:04

Hallo e-mo,

ich weiß nicht, ob es die Lösung ist, aber vielleicht ist es ja hilfreich:

https://www.herber.de/bbs/user/79083.xlsx

Gruß
Bernd


  

Betrifft: AW: wo steckt der fehler in der Formel? von: e-mo
Geschrieben am: 27.02.2012 13:53:41

Hallo Bernd,

das hat mir sehr viel geholfen! hatte nicht richtig verstanden, wieso meine referenz als datum nicht in der formel nicht erkannt wird, aber bei deinem beispiel ist es eindeutiger und sicherer! vielen dank,

gruss,
e-mo


Beiträge aus den Excel-Beispielen zum Thema "wo steckt der fehler in der Formel?"